Problème avec lien "Lire la suite".

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème avec lien "Lire la suite".

    Hello,
    je bloque sur un souci depuis suffisamment de temps pour venir demander de l'aide.

    J'ai un template qui, en page d'accueil affiche un module de présentation d'articles (qui sont en fait des news). Ce module est du type "mod_articles_category" pour afficher les dernières news. Ce module est aussi associé au menu-item de la page d'accueil pour n'être affiché que sur celle-ci.

    Maintenant j'ai activé le lien "Lire la suite" pour les articles afin d'afficher le contenu d'un article dans une nouvelle page.
    Le hic c'est que ce lien pointe vers une url du type : ...localhost/index.php/component/content/article/48-news/10-news-2?Itemid=101.
    Ce qui fait que c'est la page d'accueil qui se réaffiche avec, forcément, les modules qui lui sont associé et ensuite dessous le contenu de mon article.
    Ce que je cherche à faire c'est afficher une page qui contient l'article seulement, c'est à dire ne pas avoir les modules qui sont explicitement associés à l'entrée menu "accueil".

    Est-ce qu'il y a un moyen de faire fonctionner la chose comme je l'entends (si je me suis bien expliqué ) ?

    Merci d'avance.

  • #2
    Re : Problème avec lien "Lire la suite".

    .localhost/index.php/component/content/article/48-news/10-news-2?Itemid=101

    Ce lien proviens du module ou du composant contenu?
    Mon site en cours de construction avec de nouvelles catégories de documents...
    https://informaticien51.fr

    Commentaire


    • #3
      Re : Problème avec lien "Lire la suite".

      C'est l'url générée par le module lors de l'affichage du lien "Lire la suite".

      Commentaire


      • #4
        Re : Problème avec lien "Lire la suite".

        une surcharge du module avec en fin d url &tmpl=component
        Mon site en cours de construction avec de nouvelles catégories de documents...
        https://informaticien51.fr

        Commentaire


        • #5
          Re : Problème avec lien "Lire la suite".

          J'ai créé un nouveau menu avec comme type "Articles » Liste des articles d'une catégorie" et j'y ai attaché la catégorie.
          Je n'utilise ce menu nulle part.
          Maintenant avec ce menu j'ai une bonne URL du type : /index.php/les-news/10-news-2 et au final, plus le problème des modules que j'ai assigné à seulement la page d'accueil, ils n'apparaissent plus.
          Donc avec cette bidouille ça fonctionne, je ne comprends pas vraiment pourquoi. Et surtout est-ce que c'est mieux de surcharger le module et de changer l'URL comme tu me le suggères ?

          Commentaire


          • #6
            Re : Problème avec lien "Lire la suite".

            Envoyé par xt0f Voir le message
            J'ai créé un nouveau menu avec comme type "Articles » Liste des articles d'une catégorie" et j'y ai attaché la catégorie.
            Je n'utilise ce menu nulle part.
            Maintenant avec ce menu j'ai une bonne URL du type : /index.php/les-news/10-news-2 et au final, plus le problème des modules que j'ai assigné à seulement la page d'accueil, ils n'apparaissent plus.
            Donc avec cette bidouille ça fonctionne, je ne comprends pas vraiment pourquoi. Et surtout est-ce que c'est mieux de surcharger le module et de changer l'URL comme tu me le suggères ?
            Le menu fantome...j avais pas pensé a cela.

            Les modules sont assignés à un élément de menu.
            Que celui ci soit visible ou non, les éléments de menus sont actifs, donc on peut y assigner des modules.
            Cette technique permet de cibler des modules ou composants sans lien de menu direct

            La technique que je t ais indiqué permet d afficher seulement l'article ou l'élément, et supprimes tous les modules, l entete du template. j e pensait que c etait ce que tu voulais.
            Mon site en cours de construction avec de nouvelles catégories de documents...
            https://informaticien51.fr

            Commentaire


            • #7
              Re : Problème avec lien "Lire la suite".

              Bonjour,

              Je vais tenter d'être le plus précis et claire possible.

              J'ai sur ma Homepage un texte/article que je souhaiterai ouvrir via le 'lire la suite...' mais sur un autre lien-menu.

              En effet, si je clique sur le "Lire la suite..." de mon article, il reste sur la Homepage alors que le but initial est de le faire rediriger vers mon lien-menu!


              Merci de me venir en aide car je nage!

              Bien à vous.

              Commentaire


              • #8
                Re : Problème avec lien "Lire la suite".

                Bienvenue !

                Si tu as un lien de menu qui est défini comme devant afficher l'article, même dans un menu non affiché, l'ouverture de l'article ne se fait pas sur la page d'accueil, mais sur sa propre page.
                Exemple ici : http://aide.joomla.fr/exemple/ pour une version 2.5 ou http://joom3.robertg-conseil.fr/ sur une 3.1
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire


                • #9
                  Re : Problème avec lien "Lire la suite".

                  Merci de votre réponse rapide.

                  En effet, l'article reste ouvert sur la page d'accueil après avoir cliqué sur 'lire la suite' mais c'est justement ce que je veux éviter.

                  Mon but à moi serait de parvenir sur cette page http://www.gerechtsdeurwaarders.be/i...ure/europeenne en cliquant sur 'lire la suite...'

                  Est-ce possible?

                  Merci

                  Commentaire


                  • #10
                    Re : Problème avec lien "Lire la suite".

                    Bien sûr : c'est ce que montrent les exemples puisque l'adresse des pages change (et le module de connexion qui ne doit s'afficher que sur l'accueil disparaît) lorsque, sur la page d'accueil, on clique sur le titre des articles ou sur le lien "lire la suite".
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                    Commentaire


                    • #11
                      Re : Problème avec lien "Lire la suite".

                      Merci est-il possible d'obtenir la démarche à faire car je suis bloqué.

                      Lorsque je dé-publie sur mon article mes composants de ma page d’accueil, je les dé-publie également sur la page d'accueil.

                      Comprenez-vous?

                      Merci

                      Commentaire


                      • #12
                        Re : Problème avec lien "Lire la suite".

                        Merci du renseignement... à force de chercher on fini par trouver!

                        Merci Bien!

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins

                        Partenaire de l'association

                        Réduire

                        Hébergeur Web PlanetHoster
                        Travaille ...
                        X