Bug administration/configuration - plus de menu

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • foebb
    a répondu
    en fait, quand je vais dans le code source de la page Configuration :

    <div class="modal hide fade" id="imageModal_jform_offline_image">
    <div class="modal-header">
    <button type="button" class="close" data-dismiss="modal">×</button>
    <h3>Changer d'image</h3>
    </div>
    <div id="imageModal_jform_offline_image-container">
    </div>
    </div>
    <script>
    jQuery('#imageModal_jform_offline_image').on('show ', function() {
    document.getElementById('imageModal_jform_offline_ image-container').innerHTML = '<div class="modal-body"><iframe class="iframe" src="" height="" width=""></iframe></div>';
    });

    </script>
    <div class="input-prepend input-append">
    <span rel="popover" class="add-on pop-helper field-media-preview" title="Image sélectionnée" data-content="Aucune image sélectionnée." data-original-title="Image sélectionnée" data-trigger="hover">
    <span class="icon-eye" aria-hidden="true"></span>
    </span>
    <input type="text" name="jform[offline_image]" id="jform_offline_image" value="" readonly="readonly" class="input-small hasTooltip field-media-input input-large wf-media-input" />
    <a class="btn add-on button-select">Sélectionner</a>
    <a class="btn icon-remove hasTooltip add-on button-clear" title="Effacer"></a>
    </div>

    le script jquery non trouvé est chargé au niveau du bouton d'ajout 'Image hors ligne' D'ailleurs quand je clique sur ce bouton, il ne passe rien..


    Laisser un commentaire:


  • foebb
    a répondu
    La scan n'a trouvé aucun terme imageModal_jform_offline_image

    Laisser un commentaire:


  • foebb
    a répondu
    Envoyé par lomart Voir le message
    Pourtant ce code est bien quelque part !
    Essayer avec un autre navigateur pour s'assurer qu'il ne s'agit pas d'une extension ?
    Je viens de tester avec l'inspecteur de Firefox, sa console retourne les mêmes erreurs que chrome dt.

    index.php:177 Uncaught ReferenceError: jQuery is not defined
    at index.php?option=com_config:177
    (anonymous) @ index.php?option=com_config:177
    index.php Failed to load resource: the server responded with a status of 500 (Internal Server Error)

    Laisser un commentaire:


  • foebb
    a répondu
    En attendant la fin du scan, je viens de repenser que j'ai installé ce plugin il y a 2 jours, mais comme je n'étais pas rentré dans les configs de l'admin je ne sais pas si il y avait déjà ce bug ou non. Je viens cependant de le désinstaller mais le bug subsiste !

    Un petit changement au niveau de la console, cela retourne index.php?option=com_config:177 au lieu de 180 à la fin...je ne saurais pas interpréter ce changement d'id
    Myportfolio is the No-1 user choice for an online portfolio extension on Joomla.

    Laisser un commentaire:


  • lomart
    a répondu
    Pourtant ce code est bien quelque part !
    Essayer avec un autre navigateur pour s'assurer qu'il ne s'agit pas d'une extension ?

    Laisser un commentaire:


  • foebb
    a répondu
    je lance une recherche étendue à tout mon serveur...

    Laisser un commentaire:


  • foebb
    a répondu
    Oui moi non plus je ne l'ai pas trouvé non plus via Brackets. Le script ne trouve pas non plus :/
    Dernière édition par foebb à 01/11/2017, 10h53 Raison: orthographe

    Laisser un commentaire:


  • lomart
    a répondu
    Je ne trouve pas "imageModal_jform_offline_image" dans les fichiers d'une installation de J381
    Il faudrait faire un GREP sur ton installation avec l'excellent script de Cavo789 : https://github.com/cavo789/joomla_fr...r/src/php_grep

    Laisser un commentaire:


  • foebb
    a répondu
    il y a cela en entête du fichier dans la console : <form action="/administrator/index.php?option=com_config" id="application-form" method="post" name="adminForm" class="form-validate">
    <div class="row-fluid">

    la page est https://www."monsite".fr/administrator/index.php?option=com_config
    Dernière édition par foebb à 01/11/2017, 09h48

    Laisser un commentaire:


  • foebb
    a répondu
    Envoyé par lomart Voir le message
    Tu l'as vu avec la console, mais quel est le fichier d'origine dans Joomla ?
    ce n'est pas cela : index.php?option=com_config:180 ? sinon comment je peux le savoir ?

    Laisser un commentaire:


  • lomart
    a répondu
    De la console chrome dev tools
    Tu l'as vu avec la console, mais quel est le fichier d'origine dans Joomla ?

    Laisser un commentaire:


  • foebb
    a répondu
    Envoyé par lomart Voir le message
    Le code provient de quel fichier ?
    De la console chrome dev tools

    Laisser un commentaire:


  • lomart
    a répondu
    Le code provient de quel fichier ?

    Laisser un commentaire:


  • foebb
    a répondu
    La console retourne l'adresse index.php?option=com_config:180 ou n'est pas trouvé jquery. Mais je ne comprend pas pourquoi cette erreur est apparu sans que je n'ai rien touché au site ces derniers temps.

    C'est ce script qui n'est pas chargé :

    <script>jQuery('#imageModal_jform_offline_image'). on('show', function () {
    document.getElementById('imageModal_jform_offline_ image-container').innerHTML = '<div class="modal-body"><iframe class="iframe" src="" height="" width=""></iframe></div>';
    });

    Comment puis-je réparer cette erreur jquery ?
    Dernière édition par foebb à 01/11/2017, 08h43

    Laisser un commentaire:


  • lomart
    a répondu
    JQuery n'est pas trouvé. Il faut commencer par corriger les erreurs
    Non, je parle du code qui affiche le menu

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X