Problème de lien de connexion

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème de lien de connexion

    Bonjour,

    Je viens solliciter votre aide pour une incompréhension.
    Quand je crée un lien de menu pour se connecter au site, je tombe bien sur le menu de connexion mais dès que je clique sur me connecter, j'ai une erreur.
    Quand je regarde le pourquoi de l'erreur, je remarque que l'adresse url n'est pas complète : https://index.php/?option=com_users&view=profile
    Le site à disparu de l'url.

    Le problème est résolu si je désactive la Réécriture d'URL en clair (SEF) mais je ne le souhaite pas donc je cherche une solution.

    Auriez-vous une idée ?

    Merci d'avance à toutes et tous.
    Dernière édition par julien2810 à 03/03/2018, 11h58

  • #2
    Bonjour Julien,

    Tu utilises un composant pour gérer tes réécritures d'url ?

    As-tu modifié le fichier .htaccess se trouvant à la base du site ?

    Peut-on avoir un lien pour voir le problème en live ?
    Développeur Web | Service Création | Mon Linkedin

    Commentaire


    • #3
      Bine sur, et merci pour votre réponse rapide.

      Voici l'adresse du site : https://jeuxderegard.be/connexion
      Vous pouvez essayer de vous connecter avec : user : test pass : test

      J'utilise simplement la réécriture dans les paramètres de joomla.
      C'est la première fois que cela m'arrive

      Merci d'avance pour le temps accordé et un bon samedi.

      Edit: j'ai bien renommer le fichier .htaccess
      Photographe passionné depuis des années, venez découvrir mon univers et vous laissez transporter pour un voyage unique.

      Commentaire


      • #4
        As-tu défini une redirection après connexion, dans cette page de connexion ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          C'est dans le lien de menu de type "Connexion" -> "Paramètres" -> "Redirection de connexion" que tu peux voir si tu peux vérifier ou modifier la page de redirection mentionnée par RoberG
          Développeur Web | Service Création | Mon Linkedin

          Commentaire


          • #6
            Je n'ai touché à rien de ce côté la

            Commentaire


            • #7
              Essaie de forcer le retour sur la page d'accueil après connexion et déconnexion.
              Sinon, donne-nous une adresse de page qui nécessite d'être connecté pour en voir le contenu, afin qu'on sache si le paramètre "défaut" y renvoie ou pas.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #8
                Je viens de faire la redirection vers la page d'accueil après connexion et déconnexion et j'ai créé un lien de menu qui se nomme : test qui ne doit s'afficher que pour les utilisateurs enregistré.
                Mais sans succès.
                Vu que le lien vers le composant de connexion n'est pas bon la requête n'est pas prise en compte je suppose.

                Commentaire


                • #9
                  Étrangement quand je vais me connecter par le lien : https://jeuxderegard.be/test
                  La connexion se fait sans soucis

                  Commentaire


                  • #10
                    Le fonctionnement me paraît donc (à peu près) correct : "défaut" va renvoyer vers la page qui a appelé le formulaire, alors que si tu vas directement sur la page de connexion en saisissant toi-même son adresse, la page par défaut serait cette même page, pour se déconnecter.
                    J'essaierai sur un site de test pour vérifier mon hypothèse...
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                    Commentaire


                    • #11
                      J'ai remis les paramètres par défaut dans le lien de connexion pour la redirection.
                      Bon, en attendant si personne ne trouve de solution, je peux toujours créer un lien de menu vers un endroit ou l'on doit être connecté en l'appelant connexion ce qui renverrait sur la page de connexion qui fonctionne
                      Bon c'est un peut barbare mais ça devrait fonctionner
                      En tout cas je suis impatient de voir si quelqu'un trouve une solution à ce problème assez spécial
                      Je vous remercie pour votre temps encore une fois.

                      Commentaire


                      • #12
                        Essaie de régénérer le lien de menu menant vers l'accueil. Ou redirige sur une autre page lors de la connexion...

                        Petit conseil, il faut que tu optimises tes images en page d'accueil, redimensionne-les à la taille à laquelle elles doivent apparaitre afin qu'elle ne mettent pas deux minutes à se charger... (vide ton cache navigateur et recharge la page si tu n'as pas constaté la lenteur du chargement des images)
                        Développeur Web | Service Création | Mon Linkedin

                        Commentaire


                        • #13
                          Bon, après test, "défaut" devrait ouvrir la page de profil quand la page de connexion est affichée par un lien direct.
                          Par contre, pour la connexion, il me semble préférable d'utiliser le module, quitte à l’associer à un plugin ou un module comme SClogin qui le rend plus discret.

                          Logiquement, lorsqu'un lien de menu tente d'ouvrir une page réservée aux enregistrés, le formulaire d'identification devrait s'afficher automatiquement. Mais lors de mon test, ça n'a pas fonctionné, et il me semble avoir vu passer une discussion récente sur le sujet, que je n'ai hélas pas suivie...
                          Dernière édition par RobertG à 03/03/2018, 11h42
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                          Commentaire


                          • #14
                            Bon j'ai fait un truc un peux dégueulasse en attendant mais cela fonctionne

                            J'ai créer un lien de menu qui renvoie vers une page d'accueil réservé uniquement pour les enregistrés.
                            Je l'ai nommé : connexion comme ça avec l'url : https://jeuxderegard.be/connexion Il tombera sur la page qui demande de d'abord s'identifier qui elle est fonctionnelle
                            Et du coup il auras accès sans soucis à ses liens d'administrations.

                            C'est un peut crade je trouve mais ça fonctionne et je ne suis pas obliger de supprimer la réécriture des urls.

                            C'est le futur site pour mon père donc si jamais vous constatez qu'en faisant comme ça je risque d'avoir des problèmes lié à la sécurité je suis preneur

                            EDIT : C'est dans un menu caché bien évidemment

                            Commentaire


                            • #15
                              J'ai retrouvé la discussion à laquelle je faisais référence en disant que je ne l'avais pas suivie : https://forum.joomla.fr/forum/joomla...e-de-connexion
                              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X