[Réglé] Error 500 après migration sur nouveau serveur.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #16
    j'ai un soucy sur mon forum

    des que je veux regarder un sujet k'ai une erreur

    Commentaire


    • #17
      Juan-marco
      Tu devrais ouvrir un post par sujet ... car on risque de te perdre ... même si j'ai capté que c'est dans une continuité de mise a jour Joomla!
      “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

      Commentaire


      • #18
        Un dossier ne devrait jamais être en 777.

        Quelle est ta version de php ? Si tu es déjà en version 7 (super) tente de revenir en php 5.6 pour voir si tu as encore l'erreur.
        Christophe (cavo789)
        Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

        Commentaire


        • #19
          J’ai ISPConfig mais je ne vois pas où je peux switcher entre les différentes versions de php je suis actuellement avec la version 7

          Commentaire


          • #20
            Bonjour

            Envoyé par Juan-marco Voir le message
            je suis actuellement avec la version 7
            Oui je m'en doutais car l'erreur ci-dessous est une incompatibilité avec PHP7 càd que le code doit être revu pour être fonctionnel.
            Ta version de Joomla est 3.6.5 (cette version est accessible publiquement sur ton site mal sécurisé (puisque administrator/manifests/files/joomla.xml est accessible en URL)) ==> installe 3.8.5 et vois si cela résous le souci.

            Fatal error: Cannot use Joomla\String\String as String because 'String' is a special class name in /var/www/clients/client1/web1/web/libraries/vendor/joomla/registry/src/Format/Json.php on line 12

            [EDIT]
            Je vois qu'on t'a déjà proposé de passer en 3.8.5. L'erreur JS ne me dit rien mais, une piste, tu pourrais installer une version intermédiaire pour voir si cela corrige le souci et donc p.ex. passer de 3.6.5 à 3.7.2 (https://www.joomla.fr/joomla/telecha...ennes-versions) puis de 3.7.2 vers 3.8.5; juste une piste...
            [/EDIT]
            Dernière édition par cavo789 à 12/03/2018, 19h56
            Christophe (cavo789)
            Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

            Commentaire


            • #21
              +1 avec Cavo
              je passerai par des versions intermédiaires avant le grand saut vers 3.8
              “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

              Commentaire


              • #22
                Ok je tente en 3.7.2 et je vous tiens au courant.

                Commentaire


                • #23
                  je suis passé en 3.7.2 et le soucy étais toujours la.

                  et maintenant en 3.8.5 j'ai une erreur site :

                  Notice: Constant JROUTER_MODE_RAW already defined in /var/www/clients/client1/web1/web/libraries/cms/router/router.php on line 17

                  Notice: Constant JROUTER_MODE_SEF already defined in /var/www/clients/client1/web1/web/libraries/cms/router/router.php on line 24

                  Notice: Constant _QQ_ already defined in /var/www/clients/client1/web1/web/libraries/src/Language/Language.php on line 18
                  , et l'administration qui merdouille..

                  Notice: Constant _QQ_ already defined in /var/www/clients/client1/web1/web/libraries/src/Language/Language.php on line 18
                  Fichiers joints
                  Dernière édition par Juan-marco à 12/03/2018, 20h44

                  Commentaire


                  • #24
                    alors j'ai corrigé pas mal d’erreurs en supprimant le dossier libraires et en refaisant la mise a jour.

                    par contre maintenant mon forum est marqué en maintenance avec une erreur :
                    Le Forum est actuellement hors-ligne pour une opération de maintenance

                    Merci de revenir ultérieurement !
                    Deprecated: Non-static method jmodlbox::getinput() should not be called statically in /var/www/clients/client1/web1/web/modules/mod_jmodlbox/mod_jmodlbox.php on line 14

                    et dans la partie admin



                    Fichiers joints

                    Commentaire


                    • #25
                      Tu as été dans ton écran backend pour ton forum ? Kunena je suppose => va voir dans la config de Kunena.

                      Pour tes messages ci-dessus ce sont des notices => configuration générale du site dans l'admin, gestionnaire d'erreurs à mettre sur Aucun
                      Christophe (cavo789)
                      Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                      Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

                      Commentaire


                      • #26
                        Il me reste encore un petit détail mais il est de taille. Sur le forum il y a beaucoup de double... je m’explique l’identifiant et le mot de passe.
                        vous comprendrez de quoi je parle en allant directement dessus : https://www.partygame.fr/index.php/forum

                        Commentaire


                        • #27
                          Peux-tu s'il te plaît fermer cette discussion car le sujet "Erreur 500 après migration" semble résolu non ? Ensuite ouvrir une autre discussion pour ton nouveau problème en prenant le soin de l'expliquer. Désolé mais "allez voir et vous comprendrez", c'est un peu facile.

                          Essaie d'expliquer le problème avec des mots afin que, plus tard, ton post soit réutilisable, quelqu'un qui aurait le même problème que toi et trouverais le message puisse aussi recevoir une réponse.

                          Merci
                          Christophe (cavo789)
                          Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                          Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X