Aucune réception de Mail en partant du formulaire contact.

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Aucune réception de Mail en partant du formulaire contact.

    Bonjour à tous,

    J'ai un problème de Mail... Lorsqu'une personne veut envoyer un Mail via le formulaire de contact, la destinataire ne reçois pas le Mail en question, ni la copie (si la personne a coché la case) ; et ce, même si il a un message en vert au-dessus du formulaire qui me dit 'Merci pour votre message'.

    Idem lorsque je teste via l'onglet 'serveur' du menu 'system'.

    Pour des raisons pratiques les deux adresses sont identiques juste pour les tests, depuis que la directrice de l'école m'a prévenu cet après-midi qu'elle ne recevait plus de Mail en provenance de sa 'page contact'.

    Les adresses se terminent bien par xxxx@sitedelecole.be' (Pour les curieux... https://www.ecolesaintdominique.be/ ).

    La directrice de l'école m'avait prévenu (il y a +/- 1 mois de Spams écrit en Chinois....

    Quelqu'un a une solution ?
    En vous remerciant...


  • #2
    As-tu vérifié dans la Manager si les mails ne sont pas bloqués par l'hébergeur ?
    S'il y a eu des spams avec copie à l'expéditeur et que des tas d'erreurs sont survenues, ou des remplissages du formulaire par des robots, c'est l'explication la plus probable.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      Si, dans la configuration principale de Joomla!, le "Serveur de Mail" (dans l'onglet "serveur") est mis sur "PHP mail" (ce qui est le réglage par défaut), et que les mails n'arrivent pas aux destinataires, c'est la fonction a été bloquée par l'hébergeur. Celui-ci en principe aurait dû vous avertir.
      Demandez-lui de la réactiver, mais avant cela, pour éviter à nouveau le spam, enlevez la case à cocher "Envoyer une copie" (c'est elle qui intéresse les spammeurs) et ajoutez un CAPTCHA au formulaire.
      J'ai eu un cas similaire avec le site d'un client et cela a réglé le problème.
      Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
      Administrateur certifié Joomla! 3
      https://www.betterweb.fr

      Commentaire


      • #4
        Bonjour à vous deux.

        Je vous ai lu il y a de ça plus d'une heure. Et depuis, je fais les modifications que vous m'avez conseillées. En ce qui concerne le CAPTCHA, pas de problème même si j'ai dû un peu cherchez .

        Par contre, en ce qui concerne l'éventuel blocage chez l'hébergeur (OVH) je ne sais pas trop où regarder.

        Voici 3 screenshots qui pourraient vous aider à m'aiguiller...

        Inutile de dire que j'ai déjà testé et que je ne reçois toujours rien ! (J'ai momentanément changer l'adresse Mail de la directrice avec la mienne qui fait évidemment partie du domaine de l'école.)

        Des idées ?? En vous remerciant.

        Commentaire


        • #5
          Le mieux, c'est de les contacter. Sur la console OVH, le fait que les adresses ne soient pas bloquées pour spam veut dire que vous pouvez envoyer des emails de ces adresses depuis leur serveur, mais cela ne veut pas dire que cela soit possible depuis le site. Et en l'occurrence, c'est du site que venait le spam, donc c'est lui qu'OVH a bloqué (en désactivant la fonction php mail).
          Vous devez donc leur dire que le problème est réglé et qu'ils peuvent débloquer le site.
          Une alternative, c'est d'utiliser SMTP à la place de PHP mail et d'utiliser les données du serveur SMTP qu'OVH met à votre disposition pour l'envoi de mail.
          Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
          Administrateur certifié Joomla! 3
          https://www.betterweb.fr

          Commentaire


          • #6
            Bon, pour ne pas vous laisser sans nouvelle, j'ai écris chez OVH. Voici mon Mail :
            "Bonjour, Ayant créé le site Web en Joomla! pour l'école Saint-Dominique (www.ecolesaintdominique.be), la Directrice de l'école m'a dit qu'elle ne recevait plus aucun Mail à partir du formulaire 'contact' de Joomla!. Il y a quelque temps (1 mois +/-) elle a reçu de nombreux Mails (SPAM) écrit en Chinois. Puis, ça s'est arrêté et depuis, elle reçoit plus rien ! Est-ce du côté d'OVH vous auriez bloqué quelque chose ? Sinon, comment puis-je résoudre le problème ? En vous remerciant. B. Pirard." Je ne sais pas si OVH est très réactif (c'est la première fois que j'écris) mais j'ai envoyé ce Mail à 10:29 et toujours rien ! A bientôt.

            Commentaire


            • #7
              Bonsoir,
              On est d'accord pour dire que ton souci n'a rien a voir avec Joomla! maintenant .
              Et sais tu qu'il y a des guides OVH ... en tapant dans Google tu serais arriver facilement ici
              https://docs.ovh.com/fr/hosting/suiv...s-automatises/

              Mais comme on est gentil par ici :
              Tu rentres dans ton manager
              Tu vas sur le domaine concerné par le bloquage (pas sur les mails ...)
              Tu vas dans le menu "Plus +" puis le sous menu "Scripts Emails"
              a partir de la déjà, tu peux vérifier l'état du service, s'il n'est pas "actif", c'est qu'il est la le blocage et s'il y a blocage, et bien rapproche toi d'OVH pour la procédure de déblocage, elle change constamment .
              Ou tu peux aussi te rapprocher de la communauté OVH ... car elle est plus active que leur support
              Un conseil aussi, oublie les mails vers OVH, si tu as vraiment un souci, appelles les !
              Dernière édition par manu93fr à 28/04/2018, 20h14
              Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

              Commentaire


              • #8
                Bonsoir Manu93fr,

                Merci pour ta réponse. Effectivement, je n'ai pas cherché sur Google mais juste sur le site d'OVH. Et j'avoue avoir échoué dans ma recherche sur le site OVH.

                Après ta réponse super précise, j'ai, hélas, vu que l'Etat du service est 'Bounce'.

                Là je vais dormir mais dès demain je passe à "l'action".

                Bonne nuit.

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X