URL rewirting fonctionne à moitié

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • URL rewirting fonctionne à moitié

    Bonjour, j'ai un soucis depuis... je ne sais quand, mais lorsque j'arrive à mon site via une url du genre : /index.php?option=com_content&view=article& id=2328&catid=159
    l'url rewriting ne se fait pas. Pourtant, j'ai tout mes URL d'articles niquel. Je suis passé en HTTPS, peut-pêtre ai je cassé quelque chose ?

    Si vous avez des pistes..

  • #2
    Qu'entends-tu pas l'url rewriting ne se fait pas ?

    Si tu arrives sur une page du site via une URL classique, donc non SEO (déjà décodée), la page de l'article doit bien s'afficher et les liens dans cette page sont générés conformément à la configuration de ton routeur.

    Par contre l'adresse dans le navigateur reste telle qu'elle a été donnée, ce qui est tout à fait normal.
    Joomla ne va pas recharger la page après avoir transformée l'URL donnée en mode SEO, pour à nouveau la décoder en non SEO afin de pouvoir l'afficher ce serait idiot.

    ...ou alors je n'ai pas compris ta demande, d'où ma demande de précision au début de ma réponse.
    Dernière édition par roland_d_alsace à 29/04/2018, 19h44
    A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
    Rejoignez le Joomla Users Groupe Alsace...
    roland_d_alsace va-t-il devenir roland_du_grand_est ?

    Commentaire


    • #3
      Je crois que tu as parfaitement compris ma question.
      A part pour ca :
      "Par contre l'adresse dans le navigateur reste telle qu'elle a été donnée, ce qui est tout à fait normal.
      Joomla ne va pas recharger la page après avoir transformée l'URL donnée en mode SEO, pour à nouveau la décoder en non SEO afin de pouvoir l'afficher ce serait idiot."

      c'est le contraire. Je voudrais que quand je colle l'url réel, joomla affiche l'url propre.

      Du coup j'ai un fonctionnement normal? Je pensais que joomla reecrivait les url automatiquement, même celles collées dans la barre du navigateur.
      je vais voir avec acymailing poutquoi donc leur composant ne me génère plus d'url propre.

      merci
      Dernière édition par christophe31 à 29/04/2018, 20h34

      Commentaire


      • #4
        Bonjour

        Donc, si tu colles dans la barre d'adresse https://tonsite/index.php?option=com_users&view=login tu voudrais que ton site fasse une redirection vers https://tonsite/login ?

        Non, cela n'existe pas et ... pourquoi ? En principe personne ne connait l'URL non SEF. Il n'y a aucune raison que quelqu'un arrive sur ton site avec cette URL non réécrite; l'intérêt pour Joomla de faire un redirect 301 est plutôt mince. Et, comment pourrait-il savoir ? Il lui faudrait parcourir chaque entrée de menu pour voir si l'une d'entre elles pourrait être utilisée et ce ne serait pas très performant.

        Bonne soirée.
        Christophe (cavo789)
        Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
        Mes logiciels OpenSource : https://www.avonture.be
        Les 8 et 9 mars prochain ? J'peux pas, j'ai JoomlaDay 2019 #jd19fr (plus d'infos)

        Commentaire


        • #5
          Merci Christophe.
          Je vais attendre ma reponse d'Acymailing alors, pour savoir comme générer des urls propres.

          Commentaire


          • #6
            Envoyé par christophe31 Voir le message
            Je crois que tu as parfaitement compris ma question.
            A part pour ca :
            "Par contre l'adresse dans le navigateur reste telle qu'elle a été donnée, ce qui est tout à fait normal.
            Joomla ne va pas recharger la page après avoir transformée l'URL donnée en mode SEO, pour à nouveau la décoder en non SEO afin de pouvoir l'afficher ce serait idiot."

            c'est le contraire. Je voudrais que quand je colle l'url réel, joomla affiche l'url propre.

            Du coup j'ai un fonctionnement normal? Je pensais que joomla reecrivait les url automatiquement, même celles collées dans la barre du navigateur.
            je vais voir avec acymailing poutquoi donc leur composant ne me génère plus d'url propre.

            merci
            Si, c'est donc c'est bien ce que je dis.

            Si tu colles une URL non SEO dans la barre d'adresse de ton navigateur ( /index.php?option=com_content&view=article& id=2328&catid=159),
            Joomla ne va pas la transformer en URL SEO, car il n'y a aucun intérêt, il a tout ce qu'il a besoin pour afficher ce que internaute demande.

            C'est quand tu places une URL SEO que le routeur de Joomla va la transformer en URL classique (en interne, sans l'afficher), car il a besoin de savoir quel composant, vue, item etc... charger.

            Ce que tu souhaites nécessiterai une nouvelle requette http pour renvoyer l'URL SEO au navigateur.
            ...pour au retour devoir recalculer l'URL non SEO, dont Joomla a besoin, donc refaire le travail inverse alors qu'il disposait de l'information à la 1ère requette.

            Ceci pour quelle raison : juste pour le plaisir des yeux de l'internaute ?

            Rapport avec acymailing :

            Acymailing ne génère pas les URL SEO dans les mails.

            Ce n'est pas conseillé, car :
            • Ces URL ne passeront pas dans un moteur de référencement
            • Dans le courriel, le lecteur clique sur le texte du lien (titre ou "lire la suite" dans la cas d'un article) et ne voit pas le lien (sauf dans l’entête du navigateur)
            L’intérêt de ne pas utiliser une URL SEO dans un courriel est que par exemple pour un lien sur un article, si tu changes le titre (et donc l'alias) d'un article après l'envoi des mails,
            • avec l'URL SEO le lien est rompu,
            • alors qu'avec une URL classique (type : monsite.tld/index.php?option=com_content&view=article&id=2328& catid=159) le lien fonctionnera toujours.

            Idem pour un lien sur un evenement, etc...
            Dernière édition par roland_d_alsace à 01/05/2018, 17h05
            A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
            Rejoignez le Joomla Users Groupe Alsace...
            roland_d_alsace va-t-il devenir roland_du_grand_est ?

            Commentaire


            • #7
              Ce sont des URL générées par AcyMailing. Mon site ayant des URL sef, je veux que la newsletter pointe vers ses mêmes url, c'est quand même plus pro.
              De plus, pour les stats google analytics, c'est mieux d'avoir une seule URL par article.

              Commentaire


              • #8
                Envoyé par christophe31 Voir le message
                Ce sont des URL générées par AcyMailing. Mon site ayant des URL sef, je veux que la newsletter pointe vers ses mêmes url, c'est quand même plus pro.
                De plus, pour les stats google analytics, c'est mieux d'avoir une seule URL par article.
                Dans un courriel, aucun intérêt, au contraire.
                Regarde entre temps j'ai complété ma réponse ci-dessus :

                Acymailing ne génère pas les URL SEO dans les mails.

                Ce n'est pas conseillé, car :
                • Ces URL ne passeront pas dans un moteur de référencement
                • Dans le courriel, le lecteur clique sur le texte du lien (titre ou "lire la suite" dans la cas d'un article) et ne voit pas le lien (sauf dans l’entête du navigateur)
                L’intérêt de ne pas utiliser une URL SEO dans un courriel est que par exemple pour un lien sur un article, si tu changes le titre (et donc l'alias) d'un article après l'envoi des mails,
                • avec l'URL SEO le lien est rompu,
                • alors qu'avec une URL classique (type : monsite.tld/index.php?option=com_content&view=article&id=2328& catid=159) le lien fonctionnera toujours.

                Idem pour un lien sur un evenement, etc...
                A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                Rejoignez le Joomla Users Groupe Alsace...
                roland_d_alsace va-t-il devenir roland_du_grand_est ?

                Commentaire


                • #9
                  Effectivement, ça se vaut comme arguments.
                  Le soucis c'est que ça a tjs fonctionné avec l'url sef, et depuis quelques mois, ça a changé...

                  Commentaire


                  • #10
                    Je n'ai pas souvenir d'avoir eu des URL SEO générés par acymailing dans le passé.

                    Je n'ai pas gardé toutes les NL de mes sites, la + ancienne étant de novembre 2017 et c'était déjà ainsi avec des URL non SEO.

                    Par exemple : le lien du texte "Lire la suite" d'une de mes NL acymailing du 24/11/2017
                    A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                    Rejoignez le Joomla Users Groupe Alsace...
                    roland_d_alsace va-t-il devenir roland_du_grand_est ?

                    Commentaire


                    • #11
                      Etrange, parce que chez moi ça a tjs été sef...
                      J'attend le retour de Acymailing, en tout cas, tout semble fonctionner normalement... ce qui me rassure, merci

                      Commentaire


                      • #12
                        OK je pense qu'on a tous les 2 raison

                        Dans acymailing > configuration > configuration > onglet "interfaces", dans le groupe "fonctionnalités", il y a un bouton oui/non intitulé "utiliser les url SEF".
                        Dernière édition par roland_d_alsace à 01/05/2018, 18h44
                        A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                        Rejoignez le Joomla Users Groupe Alsace...
                        roland_d_alsace va-t-il devenir roland_du_grand_est ?

                        Commentaire


                        • #13
                          Oui mais... c'est ecrit que ca n'est que pour le front end...

                          Commentaire


                          • #14
                            Regarde qu'elle valeur tu as et essaie.

                            La plupart du temps l'envoi se fait en front.

                            En tous cas le cron s’exécute en front : http://monsite.tld/index.php?option=com_acymailing&ctrl=cron
                            Dernière édition par roland_d_alsace à 01/05/2018, 18h53
                            A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                            Rejoignez le Joomla Users Groupe Alsace...
                            roland_d_alsace va-t-il devenir roland_du_grand_est ?

                            Commentaire


                            • #15
                              C'est déjà activé depuis un moment.
                              Le soucis, c'est que j'avais des url sef dans mes newsletters, avant même de les envoyer, donc avant que le cron task ne prenne la main... Je ne comprend pas.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X