Cannot use object of type stdClass as array

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • daneel
    a répondu
    Bonjour,

    Le problème est identique pour les utilisateurs de template à base d'helix 3 + Joomla 3.8.10
    https://www.joomshaper.com/forums/ca...class-as-array

    https://forum.joomla.org/viewtopic.php?t=963139

    Yann
    Dernière édition par daneel à 27/06/2018, 08h53

    Laisser un commentaire:


  • pmleconte
    a répondu
    Il semble qu'il y ait une discussion afin de savoir s'il faut ou non corriger ce problème causé par une évolution : https://github.com/joomla/joomla-cms/issues/20879

    Est-ce un bug ou une amélioration ?

    Pascal

    Laisser un commentaire:


  • pmleconte
    a répondu
    Si vous avez des informations de votre côté, merci de nous tenir informé, on les transmettra à l'équipe de développement.

    Pascal

    Laisser un commentaire:


  • pmleconte
    a répondu
    Dans administrator/components/com_menus/models/item.php, il y a une ligne supplémentaire qui force une variable à être un objet ligne 630 ajout de
    Code:
    $data = (object) $data;
    Ce qui signifie que votre menu créé par Cobalt ou par votre template envoie une valeur dans $data qui n'est pas un objet.

    Pascal

    Laisser un commentaire:


  • KEZEO
    a répondu
    Merci beaucoup , je vais explorer cette piste

    Laisser un commentaire:


  • pmleconte
    a répondu
    Sur Github, il y a eu plusieurs cas similaires et cela semble dû à des extensions externes : https://github.com/joomla/joomla-cms/issues/20878 (coalaweb) et https://github.com/joomla/joomla-cms/issues/20874 (PWT SiteMap).

    C'est lié à un changement dans Com_Menu (voir https://github.com/joomla/joomla-cms/pull/20313).

    Pascal

    Laisser un commentaire:


  • KEZEO
    a répondu
    Bon j'ai essayé de réinstaller la dernière maj 3.8.10 et en manuel, mais le problème réapparaît
    Je vais chercher c'est étrange
    Dernière édition par KEZEO à 26/06/2018, 18h00

    Laisser un commentaire:


  • pmleconte
    a répondu
    Il y a une nouvelle version 3.8.10 qui vient de sortir, mais, je ne pense pas que cela corrige votre problème.

    Pascal

    Laisser un commentaire:


  • KEZEO
    a répondu
    en mode debug, le site ne disait rien, j'ai restauré Joomla avant la MAJ et tout marche bien, du fait j'hésite à mettre à jour lol lol lol

    Laisser un commentaire:


  • pmleconte
    a répondu
    Essayez de passer en mode developpement pour avoir plus d'informations : https://kb.joomla.fr/procedures/debu...-developpement

    Pascal

    Laisser un commentaire:


  • KEZEO
    a répondu
    alors le template est Yootheme fuse dernière version, et oui c'est cette version de cobalt. J'ai désinstallé Jce, mais le problème persiste. Là je sèche c'est très étrange

    Laisser un commentaire:


  • pmleconte
    a répondu
    Quel template ? quelle version Cobalt CCK ? version 8.762 ?

    Laisser un commentaire:


  • KEZEO
    a répondu
    Cobalt cck de mintjoomla, mais tout allé bien jusqu'a la maj

    Laisser un commentaire:


  • pmleconte
    a répondu
    Quel composant ?

    Laisser un commentaire:


  • KEZEO
    a répondu
    Merci de votre aide, non cest une installation où il y a q'un composant. Avant la mise a jour pas de problème

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X