Problème administration articles et modules après restauration

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème administration articles et modules après restauration

    J'ai reconstruit en test un site avec la version Joomla 3.8.10.
    Après avoir transféré le site en production :
    En mode administration, le contenu des articles et des modules ne sont plus visibles et modifiables, ce qui n'est pas normal.
    Par contre les contenus des articles et modules sont visibles par les utilisateurs.

    Le site en production a été successivement construit :
    1) par akeeba kirstart après une sauvegarde akeeba sur une base de test correcte.
    2) par recopie par Filezilla de l'ensemble des fichiers et un import SQL pour construire les tables de la base MySQL.
    Donc la base de production ne peut pas être modifiée pour les articles et les modules sous le compte d'administration.

    Merci pour votre aide.
    Dernière édition par gh8392 à 10/07/2018, 17h22

  • #2
    Bonjour.

    Euh, quelque-chose m'échappe : de deux choses l'une :
    * ou bien vous prenez le backup avec Akeeba et vous l'installez avec Akeeba Kickstart (donc pas besoin d'uploader les fichiers via Filezilla ni de toucher à la base de données)
    * ou bien vous faites tout manuellement si vous maîtrisez mais alors il n'y a pas besoin d'Akeeba

    A mon avis votre souci vient du mélange.
    Faites tout avec Akeeba Backup et Akeeba Kickstart et tout doit fonctionner...
    Le JoomlaDay 2019 aura lieu le 8 et 9 mars à Paris ... On vous attend tous pour rencontrer la communauté, faire plus ample connaissance, assister aux conférences .... et surtout passer un BON moment ensemble
    “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer
    Présentations : slides.woluweb.be, ... | Coordonnées complètes : www.woluweb.be

    Commentaire


    • #3
      Merci pour votre réponse.

      J'ai fait successivement les deux essais, entre chaque essai j'ai effacé les fichiers en production et réinitialisé la base.

      Pour les deux essais, sous l'administration, le contenu des articles et des modules n'est pas affiché et il n'est pas possible d'en modifier le contenu.
      Les onglets "Enregistrer" "Enregistrer & Fermer" ... sont présents mais ne servent à rien.

      Merci pour votre aide

      Commentaire


      • #4
        Bonjour,

        Le problème est résolu.
        J'accède maintenant via l'administration aux contenus des articles et des modules en production.
        Ce que j'ai fait :
        Puisque je ne pouvais mettre à jour le site et la base de production uniquement en faisant les modifications en base de test et en reportant ces modifications en production.

        J'ai donc générer un sql complet (export) à partir de la base de test.
        J'ai supprimé la base MySql en production et je l'ai recréée vide puis sous PhpAdmin j'ai importé le SQL précédent.

        Miracle j' accède de nouveau aux articles et aux modules.
        Le blocage avait été constaté deux fois : une fois en production et une autre fois pour un site de test crée.

        Je n'ai aucune explication.

        C'est réglè mais je ne sais pas comment l'indiquer.
        [Réglé]

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X