httpS et http sans S, me pose un problème de menu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • httpS et http sans S, me pose un problème de menu

    Bonjour à tous,

    c'est très curieux, mais quand je mets mon site avec httpS j'ai beau cliquer sur les menus rien ne se passe,
    alors que si je le mets juste http ça fonctionne, comme ça :
    http://rouhling.net/portail/index.php

    est-ce un souci de réglage quelque part?
    je suis hébergé chez OVH

    merci pour vos conseils

  • RobertG
    a répondu
    Un robot peut-être ?
    Mais comme je l'ai dit, je ne connais rien ni chez OVH, ni dans Joomla! qui envoie des messages sur les erreurs de type 404.

    Laisser un commentaire:


  • Bege
    a répondu
    oui c'est ce que j'ai pensé, mais par exemple à l'instant j'en ai reçu une flopée contenant exactement le même lien et reçu à une ou deux minutes près en même temps,
    ce serait quand même une sacrée coïncidence qu'il y a ai plusieurs visiteurs qui cliquent en même temps sur les liens non?

    je vais attendre demain pour voir si le changement du .htaccess fait quelque chose, et sinon je fais une demande à OVH

    Laisser un commentaire:


  • RobertG
    a répondu
    Cela veut dire que quelque part, chez des visiteurs ou sur des moteurs de recherche, ces adresses sont mémorisées et encore utilisées, d'où les erreurs puisqu'elles n'existent plus.

    Laisser un commentaire:


  • Bege
    a répondu
    ok, alors pour essai je mets en veille le .htaccess qui est à
    la racine, et je mets celui avec le code ci dessus à sa place

    Pour ce qui est des mails avec les liens indiquant des erreurs 404, c'est vraiment très curieux car le plus souvent elles indiquent des liens vers des articles qui n'existent plus depuis longtemps, comme par exemple cet article ou j'indiquais les télévisions locales :
    http://www.rouhling.net/portail/inde...catid=18%27A=0
    J'ai même supprimé tous les articles archivés et vidé les articles de la corbeille, c'est pour ça que je ne comprends pas???

    Laisser un commentaire:


  • RobertG
    a répondu
    Quand on tape rouhling.net dans la barre d'adresse du navigateur, on ne passe pas aussitôt en https, donc le code n'est pas au bon endroit et doit être mis à la racine du site, sinon, il faudrait ajouter "portail", mais autant que la page d'accueil passe déjà en https.
    Je ne m'y connais pas assez en .htaccess pour te dire quoi faire du code actuel que tu cites.

    J'oubliais : pour les erreurs 404, je n'ai personnellement jamais reçu de mails me les signalant su les sites hébergés par OVH. N'as-tu pas une extension installée, en cause ? Et as-tu vérifié qu'en http comme en https les pages cherchées ne sont pas effectivement manquantes ? De nombreuses attaques se font avec des adresses bidon qui renverront toujours des erreurs 404.
    Dernière édition par RobertG à 15/10/2018, 16h00

    Laisser un commentaire:


  • Bege
    a répondu
    ah oui alors justement j'ai mis ce .htaccess dans le répertoire de Joomla, mais je reçois toujours ces mails,
    **********************************************
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rouhling.net [NC]
    RewriteRule ^(.*) https://rouhling.net/$1 [L,R=301]
    **********************************************

    et je viens de voir que j'ai ce .htaccess dans le répertoire racine de mon hébergement
    **********************************************
    Options -Indexes
    Options -MultiViews

    <Files ~ "\.(inc|ttf)$">
    Deny from all
    </Files>

    <IfModule mod_rewrite.c>
    RewriteEngine on
    # RewriteBase /
    RewriteRule ^sitemap\.xml$ sitemap.php [L,NC]
    RewriteRule image/[^/]+/(\d+)-.*\.(gif|jpe?g|png)$ image.php?id=$1 [L,NC]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond $1 !^(favicon\.ico|robots\.txt|sitemap\.php|sitemap\. xml)
    RewriteRule (.*) index.php?q=$1 [QSA,L]
    </IfModule>

    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>
    **********************************************
    pour moi c'est du Chinois
    lequel laisser? laisser les deux?

    j'érigerais une statue en bronze sur la place de mon village à celui qui m'aidera à régler ce problème d'emails "404"
    pour mémo, ces mails ont commencés à venir quand j'ai passé Joomla en httpS

    Laisser un commentaire:


  • RobertG
    a répondu
    Pourquoi ne pas essayer ? Rien ne t'empêche de revenir en arrière si ça ne fonctionne pas comme attendu.

    Laisser un commentaire:


  • Bege
    a répondu
    du nouveau?

    merci

    Laisser un commentaire:


  • Bege
    a répondu
    mais je disais justement ceci :*
    *******************************************
    ok, alors je mets ça dans le .htaccess qui remplacera l'ancien,
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rouhling.net [NC]
    RewriteRule ^(.*) https://rouhling.net/$1 [L,R=301]

    c'est bien ça?
    *******************************************
    et personne ne m'a dit sic 'est bon?
    et si ce .htaccess je dois le mettre à la racine du site ou juste dans le répertoire de Joomla?

    désolé mais entre mon déménagement, les cartons et toutes ces réponses je m'y perds un peu,
    merci pour votre indulgence

    Laisser un commentaire:


  • RobertG
    a répondu
    N'ai-je pas dit plus haut d'utiliser le htaccess.txt standard de Joomla! pour y ajouter le code cité, avant de le renommer en .htaccess ?

    Laisser un commentaire:


  • Bege
    a répondu
    est-ce que ce .htaccess est bon? et est-ce que je dois aussi le mettre ans le répertoire de Joomla?
    merci

    Laisser un commentaire:


  • Bege
    a répondu
    Je viens de déménager et je ne peux me connecter qu'avec mon mobile, donc brièvement en attendant d'avoir à nouveau une connexion THD

    alors je pense que l'adresse que j'ai donnée renvoi une erreur 404 mais que je ne suis que le seul à voir la page en tant qu'administrateur, c'est un article qui n''est plus ne ligne mais dans la corbeille.

    Pour ce qui est du fichier .htaccess je m'y perds un peu, est-ce que c'est celui qui est à la racine du site? ou celui qui est dans le dossier de Joomla car ce dernier est dans un dossier?

    voilà le contenu de celui de la racine du site :
    Options -Indexes
    Options -MultiViews

    <Files ~ "\.(inc|ttf)$">
    Deny from all
    </Files>

    <IfModule mod_rewrite.c>
    RewriteEngine on
    # RewriteBase /
    RewriteRule ^sitemap\.xml$ sitemap.php [L,NC]
    RewriteRule image/[^/]+/(\d+)-.*\.(gif|jpe?g|png)$ image.php?id=$1 [L,NC]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond $1 !^(favicon\.ico|robots\.txt|sitemap\.php|sitemap\. xml)
    RewriteRule (.*) index.php?q=$1 [QSA,L]
    </IfModule>

    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>


    Laisser un commentaire:


  • RobertG
    a répondu
    As-tu forcé le passage en https par du code dans ton .htaccess ? Manifestement pas.
    De plus, cette adresse, même en https, renvoie une erreur 404.

    Laisser un commentaire:


  • Bege
    a répondu
    Bonjour à tous,

    en fait je me rend compte que les emails d'erreur 404 que je reçois d'OVH indiquent tous des liens sans le "S" du http, par exemple comme ça :
    http://rouhling.net/portail/index.ph...es-de-l-amitie

    alors c'est peut être une question de configuration quelque part?

    merci pour votre patience

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X