Texte modifié sur le site

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • jmad
    a répondu
    Bonsoir à tous,

    Merci pour vos conseils.

    J'ai "tout" compris pour la restauration d'un site Joomla, et beaucoup plus facile que la méthode que j'employais.
    Finalement, j'ai importé le template de mon site sous Xampp et le site fonctionne correctement.
    J'ai certainement modifié le template en défaut mais avec l'âge... je ne m'en souviens plus.

    Merci encore de votre aide
    Cordialement

    Laisser un commentaire:


  • jmad
    a répondu
    J'ai fait la restauration mais toujours le même problème. Pourtant, je suis en Joomla 3.8.13 qui fonctionnait normalement. Quand je suis passé en Joomla 3.9 le site fonctionnait correctement mais c'est en début de semaine que l'incident est arrivé. Je ne me souviens pas d'avoir modifié le site entretemps.

    Par contre, je ne connaissais pas l'astuce de restauration en ajoutant le fichier kickstart.php.
    Je viens de trouver le site qui explique cette utilisation, je vais l'étudier et je recommencerai une restauration.

    Par contre, le même site sur Xampp fonctionne correctement en Joomla 3.8.13. Sur ce site, j'ai installé Rokpad (OK).

    Laisser un commentaire:


  • RobertG
    a répondu
    Comment la restauration a-t-elle été faite ?
    Comme je le répète souvent ces derniers temps, s'il s'agit d'une restauration à partir d'une sauvegarde Akeeba, il me semble indispensable, lors d'un gros problème après mise à jour, de vider la base des tables du site, d'archiver avant suppression tous les fichiers et dossiers du site en récupérant à la racine le jpa de sauvegarde et en y ajoutant le fichier kickstart.php pour repartir sans la moindre trace (fichiers et tables ajoutés) de la version qui a déclenché l'erreur.

    Laisser un commentaire:


  • manu93fr
    a répondu
    Bonjour,
    le site a été restauré en 3.8.13 et c'est visiblement pareil ... ce n'est donc pas lié a la mise à jour !
    Essaie juste de changer de template momentanément pour voir si le défaut est toujours là

    +1000 avec tous les autres, c'est un souci d'encodage utf-8

    Laisser un commentaire:


  • jmad
    a répondu
    Bonjour à tous,

    Merci pour votre aide. J'ai modifié le site en suivant vos conseils, peut-être n'ai-je pas tout bien réalisé. J'ai toujours les mêmes incidents.
    Je vais restaurer le site avec une sauvegarde en Joomla 3.8.13 pour vérifier si le fonctionnement est correct comme il l'était au départ.

    A bientôt.

    Laisser un commentaire:


  • lefabdu51
    a répondu
    Salut,

    Note le probleme des entites mal traduite est aussi visible dans la barre d'onglet.
    LE soucis est un encodage vers l'unicode au lieu de utf8.

    A tester avec un os libre pour voir si le dysfonctionnement persiste.

    1er test:
    vider le cache joomla.

    2eme test:
    placez la ligne ci dessous dans le fichier index.php du template juste sous la balise <head>
    J'ai l'impression qu 'il prend la mauvaise par défaut et la renvoies pour le rendu et qu'il détécte touts les navigateurs comme un ie....
    Code:
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    Dernier test supprimmez la ligne ci dessous:
    Elle sert à donner la version d'ie pour lequel la page doit etre rendue..
    Elle est optionelle et n est à utiliser que si le template provoque des dysfonctionnements sur les vieilles versions d'ie.
    Elle peut être supprimée sans soucis.
    Penser à vider le cache après.
    Code:
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    1ere piste annexe :

    Un dysfonctionnement de php .

    2eme piste annexe

    Laisser un commentaire:


  • RobertG
    a répondu
    Dans le code-source de la page ont trouve deux lignes l'une avec le charset windows-1252, l'autre avec le charset utf-8 : il doit bien y avoir quelque chose qui ajoute ce windows-1252

    Laisser un commentaire:


  • jmad
    a répondu

    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252"> Je ne trouve pas cet en-tête. Dans le template je n'ai que ces 2 balises meta:

    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta name="author" lang="fr" content="Jean-Marie DESHAYES">

    C'est un template personnel que j'ai réalisé en suivant pas à pas la procédure de M KEIFLIN Cédric (http://www.joomlack.fr ).


    Je ne suis ni informaticien, ni webdesigner, je me forme avec des livres (et des cours sur internet).

    Je vais essayer l'éditeur Rokpad, d'abord sur un serveur interne.

    Laisser un commentaire:


  • lomart
    a répondu
    Pourquoi avez-vous cet entete ?

    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
    en général, on a utf-8

    Quel est votre template ?

    Laisser un commentaire:


  • jmad
    a répondu
    Je viens de changer d'éditeur (éditeur JCE) ce n'est pas mieux. Je vais revenir avec CodeMirror, c'est plus sûr.

    Laisser un commentaire:


  • lomart
    a répondu
    La saisie est modifiée ... bizarre !
    Dans l'éditeur codemirror, vous avez quoi ?

    Plutôt que codemirror, essayez Rokpad (https://rockettheme.com/joomla/extensions/rokpad). C'est tout confort

    Laisser un commentaire:


  • jmad
    a répondu
    J'ai oublié: tous les "é" ont été corrigés

    Laisser un commentaire:


  • jmad
    a répondu
    Résidence a été corrigé mais dans le texte qui suit j'ai laissé les défauts , dans l'onglet le mot Résidence est en défaut.
    J'ai le même site en interne sur Xampp, mais joomla version 3.8.13 et je n'ai pas ce souci.

    https://www.relaisdeposte.fr/

    Laisser un commentaire:


  • lomart
    a répondu

    Une URL pour voir le problème ?

    Laisser un commentaire:


  • jmad
    a répondu
    Oui, firefox, chrome, Opera, IE 11

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X