impossible d'éditer des liens de menus : page blanche

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] impossible d'éditer des liens de menus : page blanche

    Bonjour ,

    Exactement le même problème et mêmes symptômes sur joomla 3.9.2 tout récemment mis à jour.
    Qui fonctionnait tout bien jusque là :-(

    C'est parti en vrille d'un coup.

    à la base:
    menu_composant:
    # lien-1 (toutes langues)
    # lien-2 (toutes langues)
    # lien-3 (toutes langues)
    # lien-4 (toutes langues)

    Contexte:
    - j'ai modifié lien-1 (passé en lang fr)
    - puis voulu créé sa version anglaise dans la foulée >> - lien-5 (gb)

    Dans l'onglet /association/ > j'ai associé lien-1 (fr) à lien 5 (gb)

    MAIS je n'ai pas cliqué sur le bouton "propagation" qui s'affiche à côté (c'est nouveau?)
    Cela peut-il être la cause?

    Nota: à partir de ce bug, tous les liens suivant lien-1 avaient "disparus"
    De la liste sur le gestionnaire Joomla > mais pas de la BDD

    J'ai pu les faire réapparaître en repassant le paramètre langue de fr_FR à * (pour ALL) du lien de menu auquel j'avais ajouté l'association
    les liens de menu disparus sont revenus sur le panneau de gestion

    Je retente de rééditer un lien de menu (de n'importe quel menu) > boum, même problème rien de corrigé.

    Y compris en supprimant les 2 liens de menu initiaux et associés

    Complément info :
    J'ai installé Hikashop version free >> le multilingue n'est pas activé dans cette version

    Les liens en questions pointent vers Hika
    Mais le problème se manifeste sur tous les autres liens de menu
    J'ai désactivé Hika, tous ses plugins et ses modules
    ça ne résoud rien



    Je sèche
    Quelqu'un aurait une idée? Une piste?
    Merci pour votre aide
    Dernière édition par lesoutier à 12/02/2019, 09h08

  • #2
    Ah y est..
    Trouvé le bug

    Le Responsable est le template Joomshaper qui utilise le plugin Helix3
    Pour une fois que j'utilise un template autre que le livré standard de Joomla ... :-(
    J'essaie même pas de réparer >> supprime direct

    Pour aider les autres
    Ce qui m'a permis de trouver le bug:
    • Sur le serveur > forcer l'affichage des erreurs php: j'ai eu l'erreur php qui a dénoncé le plug-in helix3.php
    • retour sur le forum et requête helix > j'ai trouvé de suite ma réponse ici :-)
      Que j'avais trouvé dans mes 1ères recherches

      Incident clos pour ma part
      Mais ce ticket n'est pas à moi: peux pas le passer en [Réglé] [MODO]D'ou l'intérêt de ne pas se coller derrière une discussion qui n'est pas la sienne en pensant qu'on a le même souci ! Il vaut mieux en ouvrir une nouvelle et faire un lien vers celle que tu penses être pareil[/MODO]
    (mots-clés pour les prochains: édition menu impossible, édition liens de menu impossible en administrateur, page blanche édition menu)
    Dernière édition par manu93fr à 11/02/2019, 02h05

    Commentaire


    • #3
      Bonsoir,
      j'ai déplacé ta discussion

      Pour ton souci et UNIQUEMENT le tien
      Je pense que ton template Joomshaper n'était tout simplement pas a jour ...
      Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

      Commentaire


      • #4
        Envoyé par manu93fr Voir le message
        Bonsoir,
        j'ai déplacé ta discussion

        Pour ton souci et UNIQUEMENT le tien
        Je pense que ton template Joomshaper n'était tout simplement pas a jour ...
        OK Manu
        Merci
        Je passe en réglé donc :-)

        Le template je l'ai téléchargé il y a 2 jours
        Il s'agit du template lt_xmas_gift_joomla_ chez ltheme.com

        Ensuite j'ai installé le helixultimate_template_j3 de Joomshaper pour voir si avec helix ça résolvait le problème >> pas moyen non plus.
        Donc j'ai tout viré.
        Je repars sur ma méthode habituelle (personnalisation css du template standard)

        En passant, Akeeba Backup Core 4.2.0 (dernière version ) pose problème avec php 7.2
        Il faut rester sur php 7.1

        Bonne journée :-)

        Commentaire


        • #5
          PS > tenté de passer en [Réglé] 3 fois mais ça n'enregistre pas...

          Commentaire


          • #6
            Akeeba backup est en version 6.3.3 actuellement.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Envoyé par crapouille63 Voir le message
              PS > tenté de passer en [Réglé] 3 fois mais ça n'enregistre pas...
              Voila qui est fait.
              Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
              Confucius

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins

              Partenaire de l'association

              Réduire

              Hébergeur Web PlanetHoster
              Travaille ...
              X