L'activation du CDN enclenche une boucle de redirections

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] L'activation du CDN enclenche une boucle de redirections

    Bonjour,

    A force de lire partout que mettre en place un CDN c'est vraiment top pour accélérer un site, soulager la pression sur les serveurs, toussa, j'ai fini par craquer sur le CDN (Cloudflare) inclus dans mon pack hébergement chez 1&1 Ionos.

    J'ai fait quelques captures d'écran si ça peut aider (de l'interface 1&1 montrant les caractéristiques du CDN inclus), mais à peine activé... bing ! Ein Gross Problem
    Je file en effet sur GTMetrix pour contempler le gain permis par le CDN et là... analyse impossible, boucle de redirection !
    Je fonce sur le site bien connu de tout le monde pour tester les redirections, et ça se confirme : redirections loop
    mon https://www.domaine.fr renvoie vers https://www.domaine.fr qui renvoie vers https://www.domaine.fr qui ...

    Comme juste avant ça j'avais implanté le plugin de sécurité des entêtes http, je désactive à l'envers les dernières options (bien que n'ayant rencontré aucun problème au moment où je les ai implantées, le site de test securityheaders.com m'ayant même renvoyé un magnifique A 2 minutes plus tôt.
    Mais bon, il fallait que je sois sure.
    Bref.
    j'ai fini par désactiver complètement le plugin, et la boucle de redirection était toujours là.

    Là je me suis dit, ma fille, j'espère qu'on désactive un CDN aussi facilement qu'on l'active, et que ça reste sans conséquence, respire un grand coup, puis clique sur Désactiver le CDN.
    Byebye.
    Quelques ctrl+f5 plus tard, GT metrix finit par réussir une analyse, de même que securityheaders.com (qui me recolle l'affreux F que j'avais au départ).
    Je réactive le plugin, récupère ma note A.

    Mais je n'ai pas de CDN.
    Y avait-il quelque chose de particulier à configurer lors de l'activation à côté de quoi je suis passée ?
    Pourtant quand j'ai essayé de regarder de plus près les réglages par défaut pour les modifier, j'ai surtout trouvé des options désactivées (tellement que je me demande bien quel est l'intérêt d'un CDN si c'est pour ne rien lui faire faire, ou presque).

    Voilà voilà.
    J'ai eu un CDN pendant 5 ou 10 minutes.

    Et maintenant ?

    Merci d'avance pour vos conseils toujours éclairés.
    et bonne soirée.

    Flo
    Dernière édition par FlodAriege à 04/05/2019, 16h18 Raison: PB réglé (installation plugin Cloudflare for Joomla + réglage SSL sur TOTAL + laisser mijoter 30 minutes)
    Flo, Ariège

    Il n'y a que celui qui a honte d'apprendre qui a peur de demander

  • #2
    En cherchant en anglais, j'ai trouvé ça :
    https://support.cloudflare.com/hc/en...ct-loop-errors
    ... mais c'est déjà assez difficile en français pour moi, alors là je ne comprends pas bien...
    Se pourrait-il que je sois en flexible ssl et qu'il faille que je règle le cdn cloudflare sur Full ?
    Si oui, comment fait-on ça ? (Le cdn cloudflare étant intégré comme option dans mon hébergement 1&1)
    daneel (ou quelqu'un d'autre) une idée ?

    Edit:
    Et sur l'aide 1&1, je lis à propos de l'offre cdn incluse dans mon contrat:
    Paramètre / explication
    SSL (CDN Plus seulement) Chiffrement SSL côté visiteur, Chiffrement SSL complet ou désactivé.
    Cela pourrait-il vouloir dire que l'offre "gratuite" CDN (PAS CDN Plus) best pas compatible avec SSL ?

    ... Ce que semblerait confirmer ceci, à propos de CDN PLUS:
    «Support SSL (HTTPS) : le service CDN est compatible avec votre configuration existante SSL. Si vous n'utilisez pas actuellement SSL, CDN peut vous fournir une fonctionnalité SSL. Pas de configuration requise.»
    ... Texte qu'on ne retrouve pas à propos de l'offre CDN (pas plus),... Même si dans le tableau, en face de support SSL il y a une belle couche cette pour l'offre incluse dans le contrat.

    Comme souvent chez 1&1, c'est clair comme de l'eau de boudin...

    Merci
    Dernière édition par FlodAriege à 02/05/2019, 21h12
    Flo, Ariège

    Il n'y a que celui qui a honte d'apprendre qui a peur de demander

    Commentaire


    • #3
      Envoyé par FlodAriege;n2000078
      [USER="7381"
      daneel[/USER] (ou quelqu'un d'autre) une idée ?
      Bonsoir, tu peux corriger ce problème très rapidement en utilisant ce plugin libre et gratuit de simbunch (copie en pièce jointe)
      https://www.simbunch.com/products/fr...are-for-joomla

      Cette petite extension injecte simplement une petite ligne de code php qui vérifie la valeur transmise par cloudflare ( HTTP_CF_VISITOR ) afin de déterminer si la page est en https.
      On peut également utiliser le code htaccess ou pour nginx comme expliqué sur cette page :
      https://codediary.net/posts/forcing-...-flexible-ssl/
      mais perso, je préfère la version php (installe, active et c'est tout)



      Fichiers joints
      FlodAriege likes this.
      Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

      Commentaire


      • #4
        Merci daneel

        J'ai donc installé et activé le plugin, puis activé le pack CDN sur 1&1... avec toujours le même résultat : quand je fais un scan sur securityheaders.com, ça m'affiche "too many redirects"

        Quelques détails:
        J'ai veillé, comme indiqué dans la doc du plugin, à le positionner en 1ère position

        Dans les paramètres généraux lors de l'activation du Pack CDN chez 1&1, j'ai le choix à la rubrique SSL entre :
        - ARRÊT
        - SSL flexible
        - SSL total
        Avec le descriptif suivant :
        Utilisez le SSL pour protéger la transmission des données entre votre site Web et les visiteurs. Le SSL peut prendre jusqu'à 10 minutes pour être activé.
        L'option SSL flexible étant celle réglée par défaut, j'ai laissé tel quel.

        Je me demande sérieusement si le pack CDN inclus dans mon contrat 1&1 est, oui ou non, compatible avec le https......... (cf mon post précédent)
        C'est dans le descriptif de l'offre payante qu'on trouve le texte :
        Tous les avantages inclus dans l'offre Pack CDN, plus :
        Support SSL (HTTPS) : le service CDN est compatible avec votre configuration existante SSL.
        Si vous n'utilisez pas actuellement SSL, CDN peut vous fournir une fonctionnalité SSL.
        Pas de configuration requise.
        Mais dans ce cas, pourquoi ai-je des paramètres SSL qui s'affichent dans les paramètres généraux du pack CDN ???

        Bon, en attendant ton retour, je vais essayer deux ou trois trucs (genre changer, justement, le réglage des paramètres SSL)
        A très vite j'espère


        EDIT 17:11:
        J'ai changé le paramètre SSL pour le régler sur SSL total (au lieu de flexible qui était la valeur par défaut)
        J'ai bien failli modifier mon configuration.php pour y instruire la variable live_site comme indiqué sur le site de l'éditeur du plugin ... mais je n'ai pas pu écraser le fichier existant. Cette sécurité supplémentaire m'a fait douter, et du coup j'ai laissé le fichier inchangé (c'est-à-dire avec la variable live_site = '')
        Tout ceci m'a pris un peu de temps (30 minutes à vue de nez)
        J'ai refait un énième scan sur securityheaders.com et...
        YESSS !!! Le scan est repassé au vert
        Il fallait probablement laisser le temps à Cloudflare d'activer le SSL (quand c'est gratuit ce n'est apparemment pas immédiat)

        Problème réglé, merci daneel !!
        Dernière édition par FlodAriege à 04/05/2019, 16h16 Raison: Installer le plugin Cloudflare for Joomla, régler le SSL sur TOTAL et... laisser du temps au temps (30 min)
        Flo, Ariège

        Il n'y a que celui qui a honte d'apprendre qui a peur de demander

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins

        Partenaire de l'association

        Réduire

        Hébergeur Web PlanetHoster
        Travaille ...
        X