Comment modifier le Titre de la page principale ?

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • RobertG
    a répondu
    Il faut en effet se méfier de tout ce qui, associé à un site qu'on déplace ou clone, a en cache, dans une configuration ou dans la base comme ici, des infos correspondant au site originel.
    Il m'est arrivé à moi aussi d'avoir des surprises à cause de ça.

    Laisser un commentaire:


  • Eddy.vh
    a répondu
    C'est pour ça qu'il faut faire des pauses. Meme si on pense le contraire on gagne alors du temps puisqu'on travaille avec une meilleure concentration.

    Laisser un commentaire:


  • lendrevi
    a répondu
    Grand merci à RobertG qui vient de trouver mon erreur : j'avais laissé en place un composant non utilisé ici (cf. efso), mais qui provenait de ma copie initiale et comportait donc des infos du site origine !
    Comment ne l'avais-je pas vu plus tôt ? À force de travailler jours & nuits sur un site, le nez dans le guidon ... on finit par ne plus voir l'essentiel. La richesse d'un nouvel œil extérieur est primordiale.

    Laisser un commentaire:


  • lendrevi
    a répondu
    Envoyé par RobertG Voir le message
    C'est invraisemblable !
    Peux-tu me donner par MP ou via un de mes sites un accès de super utilisateur sur ce site, et éventuellement un accès au cPanel ? J'essaierai de comprendre ce qui peut se passer.
    C'est très sympa de ta part. Je t'envoie ceci en MP. Tu m'excuseras, mais l'ensemble est très sécurisé. Je te précise tout ceci.

    Laisser un commentaire:


  • RobertG
    a répondu
    C'est invraisemblable !
    Peux-tu me donner par MP ou via un de mes sites un accès de super utilisateur sur ce site, et éventuellement un accès au cPanel ? J'essaierai de comprendre ce qui peut se passer.

    Laisser un commentaire:


  • lendrevi
    a répondu
    Envoyé par RobertG Voir le message
    Il n'y a aucune raison pour que le site aille chercher des infos dans un dossier/base et d'autres dans un autre.
    Il faut donc te mettre à la recherche de ce que tu as pu transférer comme infos du premier site dans le second, dont des mots-clés ou descriptions liés à des articles ou éléments de menus.
    N'oublie pas aussi que JCH Optimize a peut-être laissé aussi des traces dans son propre dossier de cache (dans media), qu'on peut désactiver en utilisant le paramètre avec .htaccess dans son premier onglet de paramétrage, ce qui fait que JCH utilise alors les dossiers cache standards.

    J'ai des sites de tests chez O2switch, chacun dans son propre dossier hors de public_html et regroupés dans un dossier "sitestest" et pas vu jusqu'ici de mélanges de données
    J'ai nettoyé le cache de jch optimize et réactivez tous les réglages ... mais sans résultat sur ce problème.
    Et après copie provenant d'un autre site, je n'ai conservé aucun article et aucun élément de menu source. Tout a été reconstruit, et le template reconfiguré.
    Dernière édition par lendrevi à 11/09/2019, 07h35

    Laisser un commentaire:


  • lendrevi
    a répondu
    Envoyé par Eddy.vh Voir le message
    Bonjour.

    Est-ce que me.site est multilingue ?
    Oui, Eddy.

    Laisser un commentaire:


  • RobertG
    a répondu
    Il n'y a aucune raison pour que le site aille chercher des infos dans un dossier/base et d'autres dans un autre.
    Il faut donc te mettre à la recherche de ce que tu as pu transférer comme infos du premier site dans le second, dont des mots-clés ou descriptions liés à des articles ou éléments de menus.
    N'oublie pas aussi que JCH Optimize a peut-être laissé aussi des traces dans son propre dossier de cache (dans media), qu'on peut désactiver en utilisant le paramètre avec .htaccess dans son premier onglet de paramétrage, ce qui fait que JCH utilise alors les dossiers cache standards.

    J'ai des sites de tests chez O2switch, chacun dans son propre dossier hors de public_html et regroupés dans un dossier "sitestest" et pas vu jusqu'ici de mélanges de données

    Laisser un commentaire:


  • Eddy.vh
    a répondu
    Bonjour.

    Est-ce que me.site est multilingue ?

    Laisser un commentaire:


  • lendrevi
    a répondu
    Pour mieux me faire comprendre, voici ci-dessous les premières lignes du "code" de la page principale de mon site. On y trouve bien les anomalies précédemment déclarées :

    Code:
    <!DOCTYPE html><html lang=fr-FR dir=ltr><head><meta name=viewport content="width=device-width, initial-scale=1.0"><meta http-equiv=X-UA-Compatible content="IE=edge"/><meta charset=utf-8 /><base href=https://www.rendez-vous-medecine.com/ /><meta name=keywords content="... liste des mots clés d'un tout autre site, et non les mots-clé énoncés dans l'admin du site..."/><meta name=rights content="Seuls les Membres enregistrés peuvent utiliser ce site. Les visiteurs ont néanmoins accès au site, et peuvent effectuer des recherches"/><meta name=robots content="index, follow"/><meta name=description content="... description d'un tout autre site, et non la description énoncée dans l'admin du site ..."/><meta name=generator content="Joomla! - Open Source Content Management"/><title>... titre d'un tout autre site, et non le titre énoncé dans l'admin du site...</title><link href=/favicon.ico rel="shortcut icon" type=image/vnd.microsoft.icon /><link rel=stylesheet href=/media/plg_jchoptimize/assets/gz/0/101bdd997cf2fc10bfd7dca18291d713.css /><style>pre{white-space:pre-wrap;white-space:-moz-pre-wrap;white-space:-pre-wrap;white-space:-o-pre-wrap;word-wrap:break-word}textarea:invalid{border:2px dashed red;width:80%}textarea:valid{border:2px dashed green solid lime;width:80%} ... etc ...
    J'ai mis en couleur rouge les éléments aberrants qui proviennent d'un autre site.
    Il me vient une idée qui pourrait expliquer ceci : je suis hébergé chez O2switch en mutualisé. J'ai donc un espace client qu'on appellera "toto".
    1. dans le dossier /public_html, j'ai placé tous les éléments constitutifs d'un site qu'on appellera "site1",
    2. venant d'acheter un nouveau nom de domaine supplémentaire, O2switch m'a conseillé de placer les éléments constitutifs du nouveau site appelé "site2" dans un nouveau dossier "site2" placé à la racine de mon espace client "toto".
    Et les éléments de la page principale du nouveau site "site2" que je mets ici en couleur rouge proviennent du 1er site "site1" !
    N'est-ce pas là que résiderait un conflit ?
    Dernière édition par lendrevi à 11/09/2019, 05h57

    Laisser un commentaire:


  • lendrevi
    a répondu
    Envoyé par RobertG Voir le message
    Comme les mots-clés ne sont plus pris en compte par les moteurs de recherche, je ne m'y intéresse guère, mais si je me souviens bien, c'est ce qui est défini dans les articles ou autres liens de menu, etc. qui passent avant ce qui a été mis dans la configuration générale.
    C’est en effet ce qu’on pense aujourd’hui. Idem pour la description.
    Reste donc ce point noir concernant la balise « title »
    Dernière édition par lendrevi à 11/09/2019, 05h58

    Laisser un commentaire:


  • RobertG
    a répondu
    Comme les mots-clés ne sont plus pris en compte par les moteurs de recherche, je ne m'y intéresse guère, mais si je me souviens bien, c'est ce qui est défini dans les articles ou autres liens de menu, etc. qui passent avant ce qui a été mis dans la configuration générale.

    Laisser un commentaire:


  • lendrevi
    a répondu
    Envoyé par RobertG Voir le message
    Pour le titre : en le modifiant dans les paramètres du lien de menu d'accueil (pas forcément dans le titre du lien).
    J'ai bien essayé comme ceci, mais sans résultat. Et ceci ne suffirait pas à prendre en compte les mots-clés & description tels que je les ai définis dans l'admin (onglet "site" de la configuration).
    Les premières lignes de code de cette page principale sont toujours erronés (sans correspondance avec mes paramètres de configuration dans l'admin).
    Dernière édition par lendrevi à 10/09/2019, 17h01

    Laisser un commentaire:


  • RobertG
    a répondu
    Pour le titre : en le modifiant dans les paramètres du lien de menu d'accueil (pas forcément dans le titre du lien).

    Laisser un commentaire:


  • Comment modifier le Titre de la page principale ?

    Bonjour,

    Si je possède le site dont l'url principale est par exemple :
    ---> https://www.site.com
    Comment puis-je lui affecter une balise de titre principal tel que <title>xxxxx</title> ?
    En d'autres mots, où se trouve la page de code sur laquelle je vais pouvoir ajouter ou modifier cette balise, à quelle adresse pour l'éditer, la modifier ?
    Je vois bien son contenu de code en visionnant le code source de cette page, et il n'est pas satisfaisant. En effet il ne reprend pas dans son début :
    * les mots clés,
    * la description,
    * et le titre du site que j'ai défini dans la partie site de l'admin.
    Les infos qu'il possède -immédiatement après le DocType- sont celles d'un autre site personnel (j'ai procédé par copier/coller de certaines parties dont le template, puis modifiées ensuite). Ce qui peut expliquer les raisons de mon problème.

    Grand merci aux spécialistes qui pourraient me sortir de cette ornière !
    Dernière édition par lendrevi à 11/09/2019, 06h00

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X