Connexion au site souvent impossible

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • lendrevi
    a répondu
    Bonjour,

    Je viens enfin de corriger ce problème, après bien des errances.
    Au bout d'une vérification détaillée de tous mes plugins, je recouvre un fonctionnement correct des connexions/déconnexions. Mais à vrai dire, sans trop savoir où était le malaise !
    Merci beaucoup à RobertG, Lefabdu51, Roland_d_alsace pour mes contributions.
    Bon dimanche à vous tous !

    Laisser un commentaire:


  • roland_d_alsace
    a répondu
    Hello.

    +1 avec RobertG

    N'as tu pas une extension de sécurité de style Akeeba admintools (bien que les messages ne correspondent pas) ?

    C'est tout à fait le type de blocage d'une appli de sécurité, selon le parametrage que tu as donné (maxi x connections en y secondes avec la même IP donc quel que soit l'identifiant, bon mot de passe ou non).

    Je connais le système de cache de Joomla, il n’intervient pas sur les requêtes unitaires à la DB.

    Sinon voici aussi quelques pistes de recherche :
    • Regarde dans ton dossier cache, en supprimant les sous dossier individuellement (au lien de tout supprimer en vrac), pour trouver lequel provoque ce blocage, cela peut aussi mettre sur une piste.
    • Vérifie quels type de plugin authentication, system et users hors Joomla qui sont actifs.
    • Si tu es développeur, avec ton IDE, faire une recherche du fichier .ini contenant le message exact pour voir quelle extension provoque ce blocage.
    Dernière édition par roland_d_alsace à 14/09/2019, 09h54

    Laisser un commentaire:


  • lefabdu51
    a répondu
    salut,
    une question, ce sont touts les clients devant se connecter sur un domaine, ou seulement certains ?

    il faudrais tester avec le module de connexion standard et voir si cela persiste.

    Et si cela persiste, desactive touts tes caches. Verifies que tes extensions n embarque pas leur propre système de cache.

    Et teste pour voir si cela pose soucis.

    Cela peut aussi être du à un probleme d'expiration de session..tu te deco et reco dans la meme session avec deux id differents.
    Pas sur que ca marches.
    Ceci expliquerais le pourquoi du 1er log ko.

    Laisser un commentaire:


  • lendrevi
    a répondu
    Envoyé par RobertG Voir le message
    Bonjour,

    Pour moi, un tel blocage doit venir d'un système de protection du site, qui interdirait l'IP en cas de mauvaise identification répétée. As-tu une telle protection ?
    Ce qui n'est pas normal, c'est que ça bloque l'identification initiale avec identifiant et mot de passe corrects.

    En ce qui concerne le cache de Joomla!, il y a longtemps que je ne l'utilise plus, l’optimisation étant réalisée avec JCH Optimize Pro, cache inclus.
    Je n'ai pas l'expérience de Xtremecache chez O2switch, mais il y a aussi Litespeed qui peut être activé par nom de domaine chez eux, et l'installation du plugin LSCache améliore bien les performances.
    Bonjour RobertG,

    Je comprendrais éventuellement s’il y avait erreur de saisie, mais ce phénomène se produit même sans la moindre erreur. Simplement en se déconnectant, puis en se reconnectant avec un autre identifiant.
    certes, je conviens qu’un client standard ne rencontrera pas ce cas de figure, n’ayant que son propre identifiant unique.
    Mais le problème peut fort bien se poser pour une secrétaire qui peut se connecter en son nom propre, mais aussi avec l’identifiant de son patron.
    Je connais Litespeed, mais sans amélioration notable. Je l’ai désinstallé.
    J’ai souvent utilisé le module de connexion BT login, sans problème particulier.
    Je n’ai pas de système de protection particulier.
    Quant à JCH Optimize, je ne l’utilise que dans sa version gratuite.
    Dernière édition par lendrevi à 13/09/2019, 19h01

    Laisser un commentaire:


  • RobertG
    a répondu
    Bonjour,

    Pour moi, un tel blocage doit venir d'un système de protection du site, qui interdirait l'IP en cas de mauvaise identification répétée. As-tu une telle protection ?
    Ce qui n'est pas normal, c'est que ça bloque l'identification initiale avec identifiant et mot de passe corrects.

    En ce qui concerne le cache de Joomla!, il y a longtemps que je ne l'utilise plus, l’optimisation étant réalisée avec JCH Optimize Pro, cache inclus.
    Je n'ai pas l'expérience de Xtremecache chez O2switch, mais il y a aussi Litespeed qui peut être activé par nom de domaine chez eux, et l'installation du plugin LSCache améliore bien les performances.

    Laisser un commentaire:


  • lendrevi
    a crée un sujet [RÉGLÉ] Connexion au site souvent impossible

    Connexion au site souvent impossible

    Mon environnement : J 3.9.11, hébergement O2switch, module connexion BT login

    Bonjour,

    Fréquemment, une tentative de connexion avec un identifiant & un mot de passe tout à fait corrects débouche sur un message en rouge stipulant que les données ne conviennent pas, ou bien que le compte n'a pas été activé. Et bien plus grave encore, l'apparition de ce message bloque complètement le client (s'il possède plusieurs identifiants, aucun n'est alors accepté).
    Il me faut intervenir dans l'admin du site pour nettoyer les caches et débloquer la situation !

    Côté "cache" :
    1. dans la partie "serveur" j'ai choisi : fichier, vide, 3600, oui, cache conservateur,
    2. j'ai installé "cache cleaner" avec nettoyage automatique après toute mise à jour,
    3. et sur les conseils d'O2switch, j'ai activé dans Cpanel le système de cache "Xtremcache".

    Imaginant que ce 3ème point pouvait être en conflit avec le cache de Joomla, je l'ai désactivé : sans un meilleur résultat.

    Help !!!
    Dernière édition par lendrevi à 15/09/2019, 07h28

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X