Read more sur tags

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Read more sur tags

    Bonjour,

    Sur un de mes sites (3.9.10), les URL's des tags sont non SEF.
    Lorsque l'on clique sur le titre d'un article qui est en vue d'élément tagué, l'URL liée est en mode non sef (?view=article&id=18:monarticle&catid=8) alors que si l'on accède à cet article par ailleurs (menu, catégorie...) l'url est bien sef...

    Merci d'avance pour votre aide,
    Dernière édition par IomIom à 07/12/2019, 11h44
    Merci,

    Iom Iom.

  • #2
    Bonjour,

    Si vous avez une url à partager, ça pourrait aider à bien visualiser le problème
    Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

    Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles (date à préciser suite aux reports "COVID-19"). Évènement à ne pas rater ! Pour patienter, nous organisons des joomladays virtuels. Plus d'infos sur https://www.joomladay.fr

    Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

    Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

    Commentaire


    • #3
      Mais déjà une première idée : avez-vous créé un menu (même caché) qui pointe vers les Tags ? Alors vous lui donnez l'alias que vous voulez et c'est ça qui devrait apparaître dans l'url...
      Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

      Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles (date à préciser suite aux reports "COVID-19"). Évènement à ne pas rater ! Pour patienter, nous organisons des joomladays virtuels. Plus d'infos sur https://www.joomladay.fr

      Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

      Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

      Commentaire


      • #4
        Bonjour,

        Merci pour votre réponse. Oui, il y a bien un menu qui pointe vers "Éléments taggés". C'est vraiment incompréhensible... Lorsque l'on clique sur le titre d'un article et qu'il est affiché via le menu "blog", cela fonctionne parfaitement...
        Merci,

        Iom Iom.

        Commentaire


        • #5
          bon, sans lien vers le site (la page blog, la page tag), difficile d'en dire plus
          Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

          Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles (date à préciser suite aux reports "COVID-19"). Évènement à ne pas rater ! Pour patienter, nous organisons des joomladays virtuels. Plus d'infos sur https://www.joomladay.fr

          Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

          Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

          Commentaire


          • #6
            Bonjour,

            Oui, bien sûr, voici le lien : http://p.lavirvee.fr/tags
            UT : yooth
            PWD : yoohelpp

            Merci d'avance !
            Merci,

            Iom Iom.

            Commentaire


            • #7
              Effectivement, je vois le pb et je vais le décrire pour ceux qui nous lisent :
              Si on clique sur l'article "redimensionner une image"
              - depuis http://p.lavirvee.fr/blog l'url est bien SEF
              - depuis http://p.lavirvee.fr/tags/design l'url est non-SEF

              Je viens de tester sur un de mes sites et je n'ai pas de problème.
              Pouvez-vous essayer avec le template de base Protostar ?
              (Je suspecte que votre template a "oublié" une ligne de code sur l'override de la page Tags)
              Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

              Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles (date à préciser suite aux reports "COVID-19"). Évènement à ne pas rater ! Pour patienter, nous organisons des joomladays virtuels. Plus d'infos sur https://www.joomladay.fr

              Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

              Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

              Commentaire


              • #8
                Bonjour,

                Merci pour votre réponse.
                Je viens de positionner Protostar, le problème est identique.
                Merci,

                Iom Iom.

                Commentaire


                • #9
                  Et il n'y a aucune extension "sef" du genre sh404sef ou autre sur le site ?
                  Sinon, essayez de changer l'ordre des menus et de mettre Tags avant Blog (toujours sur Protostar).

                  (et si vous avez encore un instant, vous pouvez essayer le template Astroid de JoomDev. c'est sur celui-là que j'ai testé et que ça fonctionne)
                  Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

                  Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles (date à préciser suite aux reports "COVID-19"). Évènement à ne pas rater ! Pour patienter, nous organisons des joomladays virtuels. Plus d'infos sur https://www.joomladay.fr

                  Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

                  Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

                  Commentaire


                  • #10
                    Non, aucune extension...
                    Le fait de modifier l'ordre du menu ne change rien...
                    Savez-vous éventuellement quelle procédure je devrais suivre afin de réinstaller la couche "tags" de Joomla! ?
                    Merci,

                    Iom Iom.

                    Commentaire


                    • #11
                      J'ai trouvé ! (mais pas solutionné le problème...).
                      Lorsque l'on passe en routage "Héritage", cela supprime le problème.
                      Mais... l'on se retrouve avec des numéros d'ID dans les articles...
                      woluweb aime ceci.
                      Merci,

                      Iom Iom.

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins

                      Partenaire de l'association

                      Réduire

                      Hébergeur Web PlanetHoster
                      Travaille ...
                      X