Fatal error: Cannot use Joomla\String\String

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Fatal error: Cannot use Joomla\String\String

    Bonjour,

    Un ami rencontre un problème avec son site et m'a demandé mon aide. Débutant sur Joomla, je me tourne à mon tour vers vous.

    Ce message d'erreur s'affiche sur son site :
    Fatal error: Cannot use Joomla\String\String as String because 'String' is a special class name in /homepages/2/d272296617/htdocs/libraries/vendor/joomla/registry/src/Format/Json.php on line 12

    Sauriez-vous d'où vient cette erreur et comment la régler ?

    Je vous remercie par avance pour votre aide.
    Dernière édition par grainofsand à 07/03/2020, 18h45

  • #2
    Bonsoir et bienvenu,
    la première des choses est de vérifier la version de Joomla et la version de php sur le serveur.
    Un lien vers le site en question peut nous mettre sur plus de piste que le message d'erreur ...
    Cette année, le JoomlaDay FR aura lieu à Bruxelles mais les dates du 15 et 16 mai 2020 sont reportées. Plus d'infos sur https://www.joomladay.fr

    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

    Commentaire


    • #3
      Bonjour et merci pour votre réponse,

      La version de Joomla est 3.4.1 et la version de PHP était 5.2 (oui vous avez bien lu). Je l'ai passé à 7.3 mais le problème persiste.

      Dernière édition par grainofsand à 07/03/2020, 18h45

      Commentaire


      • #4
        Envoyé par grainofsand Voir le message
        Bonjour et merci pour votre réponse,

        La version de Joomla est 3.4.1 et la version de PHP était 5.2 (oui vous avez bien lu). Je l'ai passé à 7.3 mais le problème persiste.

        Voici l'adresse du site : http://www.larcheologue.com/
        Passer en version 7.3 (php) n'est pas une bonne idée tant que le site est en 3.4.1 avec certainement des extensions qui n'ont pas suivies non plus !
        Remets php 5.4 ou 5.5 par exemple, voir si ça change quelque chose.
        La priorité est de faire évoluer Joomla en même temps que la version de php
        Cette année, le JoomlaDay FR aura lieu à Bruxelles mais les dates du 15 et 16 mai 2020 sont reportées. Plus d'infos sur https://www.joomladay.fr

        Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

        Commentaire


        • #5
          Bonjour,

          Joomla 3.4.1 date de 2015 et n'est plus maintenu depuis 4 ans.

          Ce qui est bizarre est que votre erreur vient d'un appel à une librairie Joomla 3.9. Avez-vous mis à jour une extension récemment ?

          D'autre part, mettez à jour votre site : nous sommes en version 3.9.15 (la version 3.9.16 sort mardi prochain).

          Pascal
          If anything can go wrong, it will...
          If I can help, I will ..https://conseilgouz.com

          JoomlaDays, reporté. Plus d'infos sur https://www.joomladay.fr

          Commentaire


          • #6
            Pour info : https://docs.joomla.org/Portal:Upgrading_Versions/fr

            Pascal
            If anything can go wrong, it will...
            If I can help, I will ..https://conseilgouz.com

            JoomlaDays, reporté. Plus d'infos sur https://www.joomladay.fr

            Commentaire


            • #7
              Le problème c'est que même en repassant à la version 5.5 de PHP, dès que je veux mettre à jour Joomla, le message d'erreur apparaît .

              Commentaire


              • #8
                Envoyé par pmleconte Voir le message

                Ce qui est bizarre est que votre erreur vient d'un appel à une librairie Joomla 3.9. Avez-vous mis à jour une extension récemment ?

                Pascal
                Possible qu'une mise à jour ait été faite avant qu'on me refile le bébé mais du coup je ne sais pas du tout quelle extension. Il y a un moyen de les désactiver le temps de faire les mises à jour Joomla et PHP ?

                Commentaire


                • #9
                  Envoyé par grainofsand Voir le message

                  Possible qu'une mise à jour ait été faite avant qu'on me refile le bébé mais du coup je ne sais pas du tout quelle extension. Il y a un moyen de les désactiver le temps de faire les mises à jour Joomla et PHP ?
                  Tu es sur que c'est un "bon ami" ? Parce que refiler un site en vrac sans savoir ce qu'il s'est passé pour en arriver là ,... il ne te fait pas un cadeau là.
                  Si tu as accès a l'administration du site, tu as la liste de toutes extensions installées normalement avec leurs versions respectives, Il va te falloir mener l'enquête

                  Que se passe t'il si tu remets php 5,2 sur le serveur ? Comme avant

                  Tu as aussi la possibilité de faire intervenir l'hébergeur qui normalement a des sauvegardes. Ou demande a ton ami s'il en a fait une lui même et de quand elle date ?
                  Dernière édition par manu93fr à 03/03/2020, 23h29
                  Cette année, le JoomlaDay FR aura lieu à Bruxelles mais les dates du 15 et 16 mai 2020 sont reportées. Plus d'infos sur https://www.joomladay.fr

                  Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                  Commentaire


                  • #10
                    Bonjour,

                    Sauf erreur de ma art, toutes les versions de Joomla! 3 exigeaient PHP 5.3.1 puis plus tard 5.3.10 au minimum (c'est cette version qui est exigée pour la 3.4.1), donc le site en 3.4.1 ne peut pas tourner sous PHP 5.2 (je suis d'ailleurs surpris qu'un hébergeur continue à proposer une version si ancienne).
                    Ceci dit, à part restaurer une sauvegarde des fichiers et de la base datant d'avant ce problème, si l'hébergeur en a car je crains que l'ami en question n'en ait pas fait, la réparation risque fort d'être complexe, surtout pour quelqu'un qui n'a pas l'habitude de Joomla!

                    Mais comme déjà dit, il serait bon de savoir ce qui a été fait pour faire apparaître cette erreur.
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                    Commentaire


                    • #11
                      Bonjour à tous et merci pour vos interventions.

                      Alors le problème est apparu suite à une tentative d'installation d'Akeeba backup. Cependant quand je vais dans "gestion des extensions" il ne semble pas s'être installé. J'ai tenté d'aller voir dans la BDD pour le désactiver mais je ne trouve rien non plus.

                      Commentaire


                      • #12
                        Si c'est ça, c'est qu'il a dû installer une partie de ses fichiers. Mais je suis perplexe devant le message d'erreur qui, comme déjà évoqué, semble correspondre à une incompatibilité ente une extension et une version trop récente de Joomla!

                        Pas de moyen de restaurer une sauvegarde ?
                        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                        Commentaire


                        • #13
                          La version de Joomla est elle aussi obsolète, vous pensez qu'elle pourrait être quand même trop récente pour une extension ?

                          Commentaire


                          • #14
                            Tant que tu n'auras pas un site fonctionnel, tu risques fort de te retrouver avec le même bazar si tu tentes autre chose que ce qu'il faudrait.
                            Il y a la possibilité d'écraser avec la dernière version de Joomla!, de passer par la fonction "découvrir" et celle de vérification de la base de données, mais c'est sans garantie, surtout s'il n'y a pas de sauvegarde.

                            As-tu accès à l'administration ou pas ?
                            Le site est-il personnel ou pro ? Si pro, demande à ton ami d'investir dans une extension de transfert de données type JMigrator, qui te permettra d'importer dans un site vierge les données du site actuel. Si perso et avec accès à l'administration, tu peux passer par J2xml sur le site actuel et exporter les articles et membres pour les importer dans un site neuf.
                            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                            MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                            Commentaire


                            • #15
                              A propos de l'erreur, elle semble liée à PHP 7, donc obligation de revenir à 5.6
                              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X