Barre d'outil Joomla inaccessible.

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Barre d'outil Joomla inaccessible.

    Bonjour

    Ma barre d'outil Joomla est inaccessible.

    Plus accès au menu "System Utilisateur Menu Contenu Composants Extension et Aide".

    Non accessible aussi le panneau latéral "Panneau d'administration" et tout ce qui en découle.

    ma Version Joomla 3.9.16.


    Ce problème étant survenu une première alors que je manipulais les ACL j'ai pensé avoir fait une annerie. Je ddébute.

    j'ai n'ai pu faire autrement que de repartir avec une réinstallation vierge de Joomla.

    et de reconstruire mon site. Grrrr.


    Sans backup à l'époque j'ai mis en place cette précaution "élémentaire".


    Ce jour sans qu'il me semble avoir fait une manipulation extraordinaire je me retrouve dans la même situation.


    A nouveau plus de barre outil visible.


    Fort de mes sauvegardes j'ai restauré à une dates antérieures "opérationnelle" mais à ma grande incompréhension demeure.


    Des restaurations à J-1, J-2 redonne vie a la base aux utilisateurs mais la barre outil toujours non accessible ?????

    donc plus possible de faire évoluer le site.

    En cherchant sur le forum une solution à mon problème j'ai vu que "manu93fr" préconisait de corriger la table #__modules dans PhpAdmin.

    Il se trouve que ma table est correctement renseigné avec "1".


    Note : Je précise que j'ai purgé au passage les historiques de navigation des navigateurs.


    Le mystère reste entier


    Merci de vos suggestions ?

  • #2
    Hello.
    Tu parles de l'admin pour le SU ?
    Mets des copies d'écran cela sera peut-être plus parlant.
    A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
    Rejoignez le Joomla Users Groupe Alsace...
    roland_d_alsace va-t-il devenir roland_du_grand_est ?

    Commentaire


    • #3
      Merci de ton intérêt.

      L'image que je ne voudrais plus voir.....pour compléter la description de mon problème

      Commentaire


      • #4
        Et il s'agit bien de l'admin pour le super User

        Commentaire


        • #5
          Bonjour,

          Si vous regardez dans la console de votre explorateur (ctrl maj i ou F12 sous Chrome), avez-vous des messages d'erreurs ?

          Pascal
          If anything can go wrong, it will...
          If I can help, I will ..https://conseilgouz.com

          Commentaire


          • #6
            Pas expert en la matière mais ne me semble pas .

            Commentaire


            • #7
              En regardant votre capture écran (un peu petite),
              - votre version PHP semble incorrecte : minimum php 7.0
              - votre menu semble caché sous l'écran principal : il me semble, en zoomant un maximum, voir le haut des lettres (en haut à droite).

              Avez-vous installé récemment un plugin ? un composant ou autre lié à l'administration ?

              Pascal
              If anything can go wrong, it will...
              If I can help, I will ..https://conseilgouz.com

              Commentaire


              • #8
                Tu es sûr de ne pas avoir supprimé par mégarde la ligne 207 dans ton template d'admin : /admionistrator/template/isis/index.php qui doit contenir ceci :
                Code:
                <jdoc:include type="modules" name="menu" style="none" />
                A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                Rejoignez le Joomla Users Groupe Alsace...
                roland_d_alsace va-t-il devenir roland_du_grand_est ?

                Commentaire


                • #9
                  Envoyé par pmleconte Voir le message
                  En regardant votre capture écran (un peu petite),
                  - votre version PHP semble incorrecte : minimum php 7.0
                  - votre menu semble caché sous l'écran principal : il me semble, en zoomant un maximum, voir le haut des lettres (en haut à droite).

                  Avez-vous installé récemment un plugin ? un composant ou autre lié à l'administration ?

                  Pascal
                  +1 avec Pascal (il fallait le voir, il a de bons yeux le Pascal !!)

                  Essaie de récupérer le template d'admin Isis d'une nouvelle install de joomla de la même version (tous les fichiers de /administrator/template/isis)

                  A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                  Rejoignez le Joomla Users Groupe Alsace...
                  roland_d_alsace va-t-il devenir roland_du_grand_est ?

                  Commentaire


                  • #10
                    1)

                    J'ai controlé /admionistrator/template/isis/index.php la ligne 207 identique à ligne proposée.

                    Jusqu'à présent je ne m'étais pas penché sur les fichiers source. Ci joint trace du fichier index.

                    La découverte du CMS Joomla me comblait largement.

                    J'essayai de comprendre les ACL et ma dernière manip : un test de modification de la catégorie "spécial"

                    2)
                    Le PHP est effectivement la Version de PHP : 5.6.40. Une évolution vers 7.0 m'agréerait toutefois je n'ai pas encore trouvé comment.

                    J'ai découvert Joomla au travers de mon NAS Synology et plein d'interrogation dans tous les domaines.

                    En base l'installation de Joomla et PhpAdmin m'impose la version.

                    Je découvre aussi PhpAdmin et n'ai pas encore la solution en vue.

                    Je ne doute pas qu'à terme la version 7.0 s'impose mais jusqu'à présent la version 5.6.0 semblait bien digéré.


                    Je confirme votre impression. Il semble que la fenêtre recouvre la barre d'outil.

                    J'ai installé des plungins ( Icalend, AcMailing ) mais presque une semaine avant que le probleme survienne.


                    3)
                    J'ai bien vu que les images jointes étaient difficile à exploiter. Dans l'urgence je me suis contenté d'inclure le fichier image tel que proposé par l'éditeur du forum.

                    Si astuce pour agrandir je suis preneur.


                    4)
                    Question : Si le problème se site au niveau du fichier index pourquoi le fichier backup a priori sain et rechargé réagirait il ainsi lui aussi.


                    Dans l'expectative et si pas solution je peux repartir avec une version antérieure sans solliciter le site immédiatement pour voir si l'évolution néfaste découle de la première consultation.



                    Je n'ai pas assez de compétence pour décortiquer le fichier index. J'apprécie donc vos sollicitudes.

                    Gilbert

                    Commentaire


                    • #11
                      si tu as acces à l'onglet utilisateurs, vas dans utilisateurs et regardes en dessous du super utilisateur, tu as un lien qui t affiches les droits pour cet utilisateur.
                      c est le lien rapport des droits avancés.
                      Et la tu verras le resultats de tes manipulation.
                      Si tu vois du rouge c est que c est non autorisé.
                      Pour le super utilisateur, tout doit etre en vert si je ne me trompes pas.

                      Vu que tu déclares avoir modifié les ACL, c est pour ca que je te signales ce lien.

                      Pour acceder aux modules (peut etre qu il est en acces non autorisé ou que tu l as désactivé)
                      http://mondomaine.fr/administrator/i...on=com_modules.
                      Choisit d afficher les module administration( admin) et non site (visiteurs).

                      Pour tes backups; pense akeeba... et kickstart pour les restaurations.... ca te feras gagner du temps.
                      Dernière édition par lefabdu51 à 26/03/2020, 22h14
                      Un site pour comparer des solutions : https://comparatifs-informaticien51.joomla.com
                      un site personnel, sur Joomla, linux, windows et Powershell : https://informaticien51.joomla.com/

                      Commentaire


                      • #12
                        Hello.

                        Hier soir, il me semblait bien que j'avais déjà traité cette situation, donc ce matin, après quelques tests voici ma réponse.

                        Il y a plusieurs manip que tu as pu faire, soit au niveau des modules, soit au niveau des droits d'accès.
                        Il va donc falloir aller vérifier tout cela.

                        Premier point, soit tu as soit désactivé, soit changé les niveaux d'accès du module :
                        • Menu Administration ou Menu Principal (le 2 dénominations existent)
                        Il faut donc passer en admin, puis dans l'url de ton navigateur colle cette url derrière ton nom de domaine :
                        Code:
                        /administrator/index.php?option=com_modules
                        Tu devrais alors avoir accès à la gestion des modules.

                        Sélectionne "Administration" au lieu de "site" dan la barre des filtres et cherche "Menu Administration" ou "Menu Principal" (généralement id = 12)

                        Vérifie s'il est actif, si non active-le.
                        S'il est actif rentre dans la fiche du menu et vérifie que le niveau d'accès est bien "accès spécial".

                        S'il est bien sur "accès Spécial", il faut passer au 2ème point et aller dans la gestion des utilisateurs.

                        Pour cela colle ceci dans la barre d'adresse de ton navigateur après ton nom de domaine :
                        Code:
                        /administrator/index.php?option=com_users&view=levels
                        Clique sur le niveau d'accès "Accès Spécial", et vérifie que "Super Utilisateur" est bien coché.

                        Ceci devrait rétablir l'affichage des menus dans ton admin
                        Dernière édition par roland_d_alsace à 27/03/2020, 09h10
                        A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                        Rejoignez le Joomla Users Groupe Alsace...
                        roland_d_alsace va-t-il devenir roland_du_grand_est ?

                        Commentaire


                        • #13
                          Bonjour à tous

                          En accédant à l'onglet Utilisateur ( administrator/index.php?option=com_users&view ) j'ai vu que j'avais crée pour test de compréhension d'ACL un utilisateur qui n'était ni actif ni activé. Le super user lui ayant tous les droits.

                          Ce nouvel utilisateur ( c'était peu être ma dernière action avant que le problème surgisse ) n'avait pas de classe d'action défini. J'ai tenté de rectifié mais sans avoir la possibilité de valider ma tentative reste vaine et reste figé sur la dernière action.

                          lien résultat ( administrator/index.php?option=com_users&view=user&layout=edit&i d=739 )

                          Merci pour ton conseil.











                          Commentaire


                          • #14
                            Envoyé par Onys2600 Voir le message
                            Bonjour à tous

                            ....

                            Merci pour ton conseil.
                            Regarde pour post juste avant : https://forum.joomla.fr/forum/joomla...96#post2014896
                            , et vérifie bien tous les points.

                            J'étais en train de le compéter pendant que tu plaçais ta réponse (il est donc plus récent que ta réponse).

                            Puis tiens nous au courant du résultat.
                            A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                            Rejoignez le Joomla Users Groupe Alsace...
                            roland_d_alsace va-t-il devenir roland_du_grand_est ?

                            Commentaire


                            • #15
                              Pour info. Reparti d'une sauvegarde J-3 tous les fichiers index.php sont identiques.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X