Problème réception mails intempestifs envoyé a partir site sur adr admin du site

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème réception mails intempestifs envoyé a partir site sur adr admin du site

    Bonjour à tout le monde,

    Je me permets de venir vous exposer un probleme.
    J'ai effectué une mise à jour vers la version Joomla 3.9.26 la semaine dernière, et depuis ce samedi, je reçois des MSG en provenance du site de l'asso où je travail.
    J'ai reçu 2 e-mails en alemand, je n'y ai pas preter attention, j'ai pensé à une erreur.
    hier soir entre 21h et 22h30 j'ai reçu pas moins d'une dizaines de mails d'adresses @... .de ou @... .fr ou encore .at ...

    L'entête du Mail est l'entête que j'ai programmé dans la partie administration / Serveur du site

    Le contenu varie
    --------------------------------------------------
    Ceci est un message expédié via https://<L'adresse du site de l'association>/ par :
    Lei <xxxxx@web.de>


    Nutzen Sie das Potenzial der Kryptowährung und verdienen Sie innerhalb von 24 Stunden 15.000 € In 10 Minuten anfangen zu verdienen
    https : //script.google.com/macros/s/<Suite de caractèresalphanumétiques genre : W0K3jG9z03lLxoX910g/exec?4265914 où je n'ai recopié qu'une partie !!!)
    --------------------------------------------------
    Certains messages étant en Français avec des messages a caractère Khummmm por*no

    J'ai un formulaire sur le site réalisé avec le composant : "CONVERT FORM"
    J'ai pensé que ce composant était en cause, et j'ai donc désactivé ce composant et tous ses plugs
    Je recevais toujours les mails leur fréquence est variable 21:49 21:50 22:02 22:16 22:19 22:21 22:26 22:43 23:02 23:04

    La seule chose qui a arrêté l'envoi des mails par le site, c'est l'arrêt de l'envoi des mails dans la console d'administration du site (configuration / serveur / envoi de mail / NON)

    Les e-mails étaient envoyé via PHP MAIL

    Le site est hébergé sur 1and1/IONOS et la version du PHP est : 7.4 (référencée sur dans les informations de Joomla 7.4.16)

    Quelqu'un pourrait-il me donner des pistes pour trouver l'origine du problème.

    Cordialement

    Merci d'avance pour vos pistes.

    Thierry
    Dernière édition par titi_ihs à 03/05/2021, 13h23

  • #2
    Bonjour,

    Le problème est fréquent, et la seule méthode est de protéger les formulaires avec un captcha, ce que tu n'as pas dû faire.
    Il n'y a pas de lien avec la mise à jour.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      Effectivement, je n'ai pas activé le captcha. Je vais m'y appliquer dès que je serai au bureau.
      Je ne l'avais pas installé, car en bas du formulaire, j'ai une case à coché qui doit impérativement être cochée pour que la demande puisse être envoyée.

      Cependant, je ne pense pas que cela règle mon problème, car quand j'envoie un message à partir du formulaire, le sujet de l'E-mail reçu commence par : "Une personne vous a contacté le {date} sur le site [Nom du site de l'Asso]"

      Et là, il s'agit d'un message (que je pense être système) qui reprend le texte paramètré dans Configuration / Serveur / Nom de l'expéditeur

      Demain, haut les coeurs, j'installerai le captcha, et je réactiverai l'envoi des mails via le site.
      Ensuite, je repasserai pour dire si ça à marché.

      Merci pour cette piste.
      Thierry

      Commentaire


      • #4
        Tes messages ne sont probablement pas envoyés via le formulaire dont tu parles, mais par celui standard de Joomla!
        Vérifie qu'il n'y ait aucun contact actif, les mails peuvent partir même sans que tu aies un lien de menu pour.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Bon, alors, voilà ou j'en suis ce midi.
          Je me suis inscris sur Google pour récupérer les 2 Clés captcha que j'ai installé sur le formulaire (convert form) ainsi que dans le composant re-captcha de joomla.

          J'ai ensuite été vérifier ce que tu me disais hier, et effectivement, lors de la création initiale du site, j'avais tenté de réaliser un formulaire directement avec Joomla, sans composant, mais, cela ne me plaisait pas au niveau de la mise en forme. Bien que je tente de rester fidèle aux outils de bases afin de ne pas dépendre de composants tierces, j'ai opté pour la facilité et craqué sur CForm. (Je précise que je n'ai aucune base de développement web, donc, pour moi un CSS c'est super beau, pleins de belles couleurs quand on utilise un bon éditeur, mais à part cela ).

          J'avais donc créé 5 contacts pour expérimenter (dont 2 avec des adresses e-mails perso pour les tests les autres contacts sans adresses)

          Ces contacts n'ont pas été nettoyés, et il est fort possible que les e-mails viennent de là.

          J'ai à présent désactivé tous ces contacts qui ne me servent plus a rien. Et j'ai réactivé l'envoi des e-mails par le site.

          Cela fait +-40 min que c'est réactivé, et toujours pas de msg étrange venant du site dans ma boite.

          Cependant, les messages précédents ne sont jamais arrivés en journée, et cela s'est passé majoritairement le WE. Je vais donc tenir cela à l'oeil, et reviendrai lundi afin de confirmer (ou pas) la résolution de ce problème. J'espère pouvoir passer le sujet à Règlé.

          Quoi qu'il en soit, encore merci ! (et pour la rime, au plus tard à Lundi !)

          Thierry

          Commentaire


          • #6
            Bonjour,

            Comme promis, je reviens ce lundi avec une bonne nouvelle. (Enfin, pour moi en tous les cas.)
            La solution proposée par RobertG était la bonne.
            J'ai supprimé tous les contacts dont je ne me servais pas dans le composant [FICHE DE CONTACT] de Joomla. La réception intempestive de mail a immédiatement cessé !

            Merci donc, à RobertG pour son expertise.

            Bon, j'aurais du me douter que la solution avait de grande chance de fonctionner avec ses plus de 28000 posts.
            Je marque donc, ce problème comme Règlé.

            Bonne continuation
            Thierry

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X