Bug suite à envoi Formulaire de contact

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Bug suite à envoi Formulaire de contact

    Bonjour,

    Je rencontre un problème après la création du formulaire du Composant Fiche de contact.

    En effet tout semble se dérouler normalement lors de la création du formulaire et il est bien envoyé.

    Cependant il n'est pas distribué.

    Voici le message que je reçois lorsque je me suis envoyé un message de test :

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es)
    failed:

    monadresse@laposte.net:

    SMTP error from remote server for MAIL FROM command, host: smtpz4.laposte.net (194.117.213.1) reason: 550 5.5.0 SPF: 212.227.126.135 is not allowed to send mail. LPN007_401


    Avez-vous une solution à me proposer pour régler ce problème.

    Par ailleurs je me demande quand même si c'est la meilleure solution que d'utiliser ce formulaire proposer en natif par Joomla.

    En effet il ne comporte pas de captcha et je crains d'être inondé de mails à plus ou long termes.

    Je suis preneur de toutes vos suggestions

    Remerciements

  • #2
    Re : Bug suite à envoi Formulaire de contact

    Bonsoir,

    Ci-après une discussion sur votre erreur LPN007_401 https://forums.mozfr.org/viewtopic.php?t=122294 qui a peut-être la solution au niveau du paramétrage de vos envois.

    Dans ce message, les paramètres https://support.mozilla.org/fr/kb/pa...#w_laposte-net

    Je ne comprends pas votre problème captcha: il est inclus dans la version de base Joomla. Il suffit d'activer le plugin.

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    JoomlaDays à Bruxelles les 15 et 16 mai 2020, on s'y voit ? plus d'infos sur https://www.joomladay.fr

    Commentaire


    • #3
      Re : Bug suite à envoi Formulaire de contact

      Merci,

      Je vais regarder ces deux solutions.

      Commentaire


      • #4
        Re : Bug suite à envoi Formulaire de contact

        En fait, c'est la même solution, le 2éme message donne les paramètres dont on parle dans le 1er.

        Pascal
        If anything can go wrong, it will...
        If I can help, I will ..https://conseilgouz.com

        JoomlaDays à Bruxelles les 15 et 16 mai 2020, on s'y voit ? plus d'infos sur https://www.joomladay.fr

        Commentaire


        • #5
          Re : Bug suite à envoi Formulaire de contact

          Bonjour,

          1. Vérifier la configuration du site et l'envoi d'e-mail.

          Dans Joomla 3.5, vous avez une option de test pour les e-mail depuis la configuration du site,
          onglet serveur : http://prntscr.com/ar08xi

          Je conseille d'avoir une adresse d'expedition identique à l'adresse du nom de domaine style
          contact @ nomdusite.com

          Evitez gmail, laposte, free et autres...

          Si votre hébergeur ou registrar ne peut vous offrir un serveur de messagerie, vous pouvez également prendre une solution externe comme zoho mail (l'équivalent de google app mais avec une offre gratuite : https://www.zoho.com/mail/ que j'utilise perso! ) ou un service de relais SMTP comme tipimail ( https://fr.tipimail.com ), mailjet ( https://fr.mailjet.com/transactional ), sendinblue... Tous ces services ont des offres gratuites qui seront amplement suffisant !

          2. Vérifier l'adresse de l'utilisateur (donc votre adresse destinataire du formulaire, celui qui est défini dans votre compte utilisateur ou dans la fiche de contact).

          3. Normalement, vous ne devez pas avoir d'erreur. Pour vérifier si les mails envoyés sont correctement configurés et ne partent pas en indésirable, remplacer temporairement l'adresse destinataire par celle fourni par ce site :
          http://www.mail-tester.com/ le temps de vérifier que les conditions soient parfaitement réunies.

          Ce service est créé à l'origine pour tester l'envoi de newsletter mais il fonctionne pour tester les emails transactionnels. Ainsi vous aurez un rapport sur l'envoi des messages, le mieux étant d'obtenir un 10/10 !

          Au besoin, il faudra définir spf et dkim de votre nom de domaine (voir les discussions sur le sujet...)

          4. Vous aurez compris que l'importance n'est pas l'adresse destinataire (peu importe l'adresse défini dans les contacts et dans votre compte) mais l'adresse d'expedition et la méthode d'envoi : phpmail, sendmail, smtp ( dans la configuration du site ). La configuration de votre nom de domaine a également de l'importance pour valider l'envoi des emails depuis votre site.

          5. Note pour l'histoire des captcha :

          Oui le recaptcha de Google proposé par Joomla est plutôt simple et efficace :
          https://www.google.com/recaptcha/intro/index.html

          mais je préfère eviter et bloquer immédiatement les spams sans utiliser de captcha !
          Sur la plupart de mes sites, ils sont détectés dès que ces parasites se connectent via leur adresse ip... et si cela ne suffit pas, on surveille également les noms et adresses mail en les comparant sur des serveurs de références (des bases de données contenant les ip, mails et noms de spammeurs comme projecthoneypot, stopforumspam...

          Via l'extension gratuite spambotcheck :
          http://extensions.joomla.org/extensi...y/spambotcheck
          Sincèrement, je ne reçois quasiment aucuns mails de spams provenant d'inscriptions ou de formulaires même natifs.
          Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

          Commentaire


          • #6
            Re : Bug suite à envoi Formulaire de contact

            Merci daneel pour toutes ces explications,

            Je devrais pouvoir m'en sortir (enfin j'espère!)

            Je ne m'y attellerais qu'à partir de demain soir car d'ici là je suis bien chargé.

            Commentaire


            • #7
              Re : Bug suite à envoi Formulaire de contact

              Bonjour,

              J'ai bien avancé grâce à vos conseils, daneel et pmleconte.

              Mes messages partent bien et arrivent également bien à destination.

              Paramètrage d'envoi et de réception donc OK.

              Par contre je vous communique le lien de la page : http://www.velo18.net/index.php/2013-10-23-13-16-49 où pourrez constater le problème que je n'arrive pas à résoudre.

              Si vous essayez d'envoyer un message sous mon identité : Jean-Jacques Morice vous verrez que le texte du message est écrit en noir sur un fond noir (en fait la couleur des pages du site par défaut).

              J'ai beau chercher je ne vois pas où modifier cela.

              Avez-vous une solution à me proposer.

              Si vous essayer d'envoyer un message à un de mes voisins sur la même page vous constaterez qu'il est géré par un fournisseur indépendant de Joomla.

              J'aime bien son interface plus complet (possibilité d'envoyer des pièces jointes entre autres)

              Est-il possible d'arriver au même résultat avec Joomla?

              Mon hébergeur est 1and1 et il m'offre une protection contre les spams et les virus.

              Dans ce cas est-il vraiment nécessaire de chercher à installer un captcha?

              Vous voyez, il me reste encore du chemin à parcourir.

              Mais j'avance, pas très vite, mais j'avance.

              Merci de votre aide

              JJM

              Commentaire


              • #8
                Re : Bug suite à envoi Formulaire de contact

                Bonsoir,

                C'est un autre problème et cela n'a rien à voir avec l'envoi mais simplement réaliser une modification css.

                Le mieux étant d'éditer ton fichier .css de ton template et d'ajouter à la fin :

                Code HTML:
                #jcemediabox-popup-content  input {background: #fff; color: #555; padding: 4px;}
                Si le problème de css est toujours là, il te suffit nous indiquer le problème dans le forum concerné (gestion des templates, css & bootstrap) et de désactiver jch_optimise (pour que ce soit plus simple pour trouver le fichier css).

                De ce fait, je t'invite à considérer le sujet du problème d'envoi de formulaire comme [réglé].
                ( http://forum.joomla.fr/announcement.php?f=40 )
                Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                Commentaire


                • #9
                  Re : Bug suite à envoi Formulaire de contact

                  Merci pour tout

                  A bientôt sur un nouveau post.

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins

                  Partenaire de l'association

                  Réduire

                  Hébergeur Web PlanetHoster
                  Travaille ...
                  X