Erreur 404 avec nouvel article

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • lesoutier
    a répondu
    Re : Erreur 404 avec nouvel article

    Si c'est réglé merci de l'indiquer :
    http://forum.joomla.fr/announcement.php?f=230

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Voilà, avec en parallèle l'aide de Flexicontent, vu que c'est avec ce composant que je travaille, une solution a été trouvée, elle pourra peut-être aider d'autres personnes qui rencontrent ce problème.

    Le soucis vient de MijoSEF qui n'est pas 100% compatible avec le dernière version de Flexicontent.

    Ce qu'il faut faire, désactiver Mijo pour Flexicontent, de cette façon il reste opérationnel pour le reste du site.

    Lorsqu'une nouvelle page est créée, il faut directement après aller sur le front end et cliquer sur le lien de cette page dans la catégorie associée , dans mon cas je dois le faire pour les 4 catégories de races, et de cette façon le lien SEF se crée manuellement.

    Il est important de cliquer sur le lien dans la catégorie principale, si on clique par l'intermédiaire d'un autre lien, cela génère l'erreur 404.

    Un grand merci à tous ceux qui ont répondu et tenté de trouver une solution.

    Bonne soirée.
    Cordialement.
    Francis

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Je vérifie votre réponse et je vais tester Xenu

    Laisser un commentaire:


  • PhilJ
    a répondu
    Re : Erreur 404 avec nouvel article

    Bonjour,


    Je renouvelle ma suggestion : installez une extension générant un plan de site ('OS Map' par exemple).

    Autre idée : testez votre site avec XENU (http://home.snafu.de/tilman/xenulink.html), logiciel pour Windows.

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Rebonjour tout le monde

    Voilà, j'ai fais une restauration complète de Joomla et fais les dernières mises à jour.

    J'ai créé les nouvelles catégories pour les standards et créé les premiers standards dans les autres langues.
    Je tiens à préciser que l'ensemble du site est en français, ces pages sont uniquement dans d'autres langues pour les visiteurs étrangers éventuels.

    La page avec le standard français et qui fonctionne est
    https://www.milouchouchou.com/les-ra...ointer-anglais

    La page en anglais, qui ne fonctionne pas est
    https://www.milouchouchou.com/les-ra...nglish-pointer

    La page en allemand, qui ne fonctionne pas est
    https://www.milouchouchou.com/les-ra...ischer-pointer

    Par contre, la page en espagnol fonctionne
    https://www.milouchouchou.com/les-ra...pointer-ingles

    Et la page en neerlandais fonctionne aussi
    https://www.milouchouchou.com/les-ra...andais/pointer

    Pourtant, toutes ces pages sont bien présentes
    Catégories connexes: Les races FCI en anglais (1) Les races FCI en allemand (1) Les races FCI en espagnol (1) Les races FCI en neerlandais (1)

    Je ne comprends vraiment pas d'où peut provenir cette erreur, ou alors c'est tellement évident que je passe à côté

    Je ne continue pas les autres standards car le problème sera aussi présent.

    Bonne journée et en espérant que quelqu'un aura plus de chance que moi

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Je viens d'effacer toutes les url dans MijoSEF afin qu'il les régénère, je pense qu'il va y passer la nuit, mais je ne sais pas si j'ai bien fait de faire ça

    Laisser un commentaire:


  • PhilJ
    a répondu
    Re : Erreur 404 avec nouvel article

    Également : la page /formulaires-de-contact est inaccessible pour cause de redirection incorrecte :-\

    Laisser un commentaire:


  • PhilJ
    a répondu
    Re : Erreur 404 avec nouvel article

    Envoyé par milouchouchou Voir le message
    [...] Voici un des liens où on peut rencontrer cette erreur
    A l'examen, la page indiquée comporte 36 liens défectueux (liens vers des pages 404) : 'Les albums photo', 'Imprimer', 'Les races FCI' + les équivalents dans 3 autres langues + les liens à proximité des drapeaux + tous les liens des races les plus visitées + tous les liens des races les moins visitées.

    MyjoSEF est peut-être en cause, ou bien des saisies d'URL incorrectes ?

    Afficher un plan du site permettrait peut-être de mieux comprendre ce qui se passe...

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Un lien vient de fonctionner correctement, reste le Nederland qui affiche toujours une 404

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Bonsoir lefabdu51

    Je joint un printscreen, tu verras dans le fond 4 drapeaux, ce sont les liens qui génèrent la fameuse 404.

    Je vais voir tes liens et je reviens après.

    Il ne s'agit pas d'un site multilingue, l'ensemble du site est en français, ce sont juste des standards de races en d'autres langues, cela peut être utile aux visiteurs étrangers.

    Et pourquoi cela fonctionne-t-il avec certaines autres pages ? Je suis certain de l'orthographe des liens grrrrrrrrrrrrr
    Fichiers joints
    Dernière édition par milouchouchou à 26/10/2016, 20h12

    Laisser un commentaire:


  • lefabdu51
    a répondu
    Re : Erreur 404 avec nouvel article

    Envoyé par milouchouchou Voir le message
    Bonsoir lesoutier

    Non cette page s'affiche très bien, ce sont les 4 liens avec un drapeau sur la droite qui donnent un 404
    Exemple https://www.milouchouchou.com/les-ra...cocker-spaniel

    Tous les caches sont vidés, même plusieurs fois.
    Bon, je n ais aucun drapeau sur ce lien : https://www.milouchouchou.com/les-ra...paniel-anglais

    Donc soit tu as supprimé les dits drapeaux, soit le bug est plus grave que prevu......

    Vu la seconde url qui renvoies vers une erreur 404, je t invites a suivre les liens ci dessous :

    https://cinnk.com/joomla/3/le-livre-...te-multilingue

    http://multilingual.demojoomla.com/fr/

    Laisser un commentaire:


  • milouchouchou
    a répondu
    Re : Erreur 404 avec nouvel article

    Bonsoir lesoutier

    Non cette page s'affiche très bien, ce sont les 4 liens avec un drapeau sur la droite qui donnent un 404
    Exemple https://www.milouchouchou.com/les-ra...cocker-spaniel

    Tous les caches sont vidés, même plusieurs fois.

    Laisser un commentaire:


  • lesoutier
    a répondu
    Re : Erreur 404 avec nouvel article

    La page indiquée devrait être en 404 ? Chez moi elle s'affiche très bien. Sans doute un problème de cache. Pense à bien vider tous les caches (navigateur, Joomla, éventuellement serveur).

    Laisser un commentaire:


  • milouchouchou
    a crée un sujet [RÉGLÉ] Erreur 404 avec nouvel article

    Erreur 404 avec nouvel article

    Bonjour tout le monde

    Je rencontre un problème assez étrange, plus exactement une erreur 404 lorsque je cliques sur le lien d'un nouvel article.
    Cet article est bien créé et publié, sur le panneau d'accueil de l'administration, il est bien renseigné aussi.
    Je n'ai jamais rencontré ce problème auparavant.

    Voici ma configuration :
    PHP exécuté sur Linux aiglos.fr.planethoster.net 2.6.32-673.26.1.lve1.4.18.el6.x86_64 #1 SMP Fri Oct 21 11:58:14 EDT 2016 x86_64
    Version de la base de données 5.5.5-10.1.18-MariaDB
    Interclassement de la base de données latin1_swedish_ci
    Database Connection Collation utf8mb4_general_ci
    Version de PHP 5.6.26
    Serveur web LiteSpeed
    Serveur web pour interface PHP litespeed
    Version de Joomla Joomla! 3.6.4 Stable [ Noether ] 21-October-2016 16:33 GMT
    Version de la plateforme Joomla! Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
    Navigateur Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

    J'utilise MyjoSEF 1.5.5 et Flexicontent 3.1.0
    Mon template est Putity III, si je bascule vers Protostar, le problème reste pareil.

    Voici un des liens où on peut rencontrer cette erreur, il suffit de cliquer sur un des liens des standards en langue différente Ce lien est un article initial que j'ai mis à jour.
    https://www.milouchouchou.com/les-ra...paniel-anglais

    Si vous avez une solution, je suis preneur.

    D'avance un grand merci
    Bien à vous
    Francis

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X