Pas d'affichage du site et pas d'accès à l'administrateur

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Pas d'affichage du site et pas d'accès à l'administrateur

    Bonjour,
    Mon site Joomla (3.3.6) a été hacké (création d'utilisateurs frauduleux pour faire du spam).
    J'ai repéré les fichiers incriminés (avec aesecure quickscan), je pense avoir correctement nettoyé tout ce petit monde.
    En local, le site fonctionne. Mais après le transfert chez OVH, plus d'affichage comme si le template avait disparu, et il est impossible d’accéder à l’administrateur (page blanche). J'ai verifié chez OVH si le site était bloqué, pas de blocage. J'ai vérifié les droits également.
    J'ai remarque que la table 'templates styles' possède deux enregistrements avec le code du template (cf image)
    Cliquez sur l'image pour l'afficher en taille normale

Nom : copie-table.jpg 
Affichages : 1 
Taille : 93,4 Ko 
ID : 1824541
    Je suis un peu perdu
    Une idée ?
    Dernière édition par luxojr à 10/01/2017, 11h38

  • #2
    Re : PAs d'affichage du site et pas d'accès à l'administrateur

    Bonjour

    Envoyé par luxojr Voir le message
    J'ai repéré les fichiers incriminés (avec aesecure quickscan), je pense avoir correctement nettoyé tout ce petit monde.
    Non, non, attention : QuickScan n'est pas exhaustif. N'était-ce pas assez clairement indiqué dans la documentation et dans l'interface ?

    Si tu "n'as nettoyé que" ce que QuickScan a repris, comprends bien qu'il doit rester des bestioles ailleurs.

    Envoyé par luxojr Voir le message
    Mais après le transfert chez OVH, plus d'affichage comme si le template avait disparu, et il est impossible d’accéder à l’administrateur (page blanche). J'ai verifié chez OVH si le site était bloqué, pas de blocage. J'ai vérifié les droits également. Je suis un peu perdu
    Plus d'affichage cela veut dire quoi ? Pas blanche ? Si oui, active le rapport d'erreur de ton site (édite le fichier /configuration.php et met le rapport d'erreur sur maximum). Réaffiche ensuite ton site, tu devrais alors avoir l'affichage d'un message d'erreur, de type fatal. Copie/colle le message ici.

    Pour en revenir sur ton hack : n'avais-tu pas un backup sain que tu aurais pu remonté ? C'est la solution la plus facile lorsque tu possèdes un tel backup.

    Bonne journée et bon nettoyage
    Christophe (cavo789)
    Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
    Mes logiciels OpenSource : https://www.avonture.be

    Commentaire


    • #3
      Re : PAs d'affichage du site et pas d'accès à l'administrateur

      Merci pour tes réponses.
      C'est bien une page blanche pour l'accès à l'administrateur.
      A quoi corresponde mettre au 'maximum' le rapport d'erreur, c'est cela : public $error_reporting = 'maximum';

      Commentaire


      • #4
        Re : Pas d'affichage du site et pas d'accès à l'administrateur

        Il faut indiquer public $error_reporting='6135';
        Christophe (cavo789)
        Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
        Mes logiciels OpenSource : https://www.avonture.be

        Commentaire


        • #5
          Re : Pas d'affichage du site et pas d'accès à l'administrateur

          Même en indiquant ta consigne, rien de nouveau, toujours une page blanche pour l'administrateur.

          Commentaire


          • #6
            Re : Pas d'affichage du site et pas d'accès à l'administrateur

            Tu as dû faire trop de ménage...

            Uploade à nouveau les fichiers natifs de Joomla sur ton FTP et écrase la copie qui y existerait. N'uploade toutefois pas le dossier /installation
            Christophe (cavo789)
            Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
            Mes logiciels OpenSource : https://www.avonture.be

            Commentaire


            • #7
              Re : Pas d'affichage du site et pas d'accès à l'administrateur

              Aspirateur trop puissant ;-)))
              Quand tu parles de fichiers natifs, c'est une version 'neuve' de Joomla ou l'archive qui fonctionne sur ordinateur que je dois transférer.

              Commentaire


              • #8
                Re : Pas d'affichage du site et pas d'accès à l'administrateur

                Neuve.

                Prends le temps de consulter mon document suivant : https://slides.aesecure.com/slides/s..._5-3_a_la_main vu qu'il s'agit de ce que tu as fait : nettoyer à la main ton site
                Christophe (cavo789)
                Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
                Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                Mes logiciels OpenSource : https://www.avonture.be

                Commentaire


                • #9
                  Re : Pas d'affichage du site et pas d'accès à l'administrateur

                  Merci pour le slide, j'avais déjà le powerpoint que vous avez rédiger
                  Une nouvelle question : comment installer une version 'neuve' de joomla et récupérer les données (textes, images, template) de mon site en 'difficulté', j'ai un peu de mal à comprendre.
                  Merci d'avance.

                  Commentaire


                  • #10
                    Re : Pas d'affichage du site et pas d'accès à l'administrateur

                    En écrasant les fichiers tu ne modifies pas la base de données ni tes propres images.

                    Fait donc comme je l'ai mentionné plus haut et cela fera ce que tu viens de demander.
                    Christophe (cavo789)
                    Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
                    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                    Mes logiciels OpenSource : https://www.avonture.be

                    Commentaire


                    • #11
                      Re : Pas d'affichage du site et pas d'accès à l'administrateur

                      Bonjour,
                      Merci pour ces renseignements.
                      Je résume notre entretien.
                      Si j'ai bien compris, il faut que j'installe la dernière version de Joomla sur mon poste, supprimer le dossier installation. Puis transférer cette nouvelle version chez mon hébergeur. Comme tu dis, pas de problèmes pour les images et la base de données, mais qu'en est-il du template.
                      Bien à toi.

                      Commentaire


                      • #12
                        Re : Pas d'affichage du site et pas d'accès à l'administrateur

                        Non, il ne faut pas que tu "installes", mais seulement que tu décompresses le pack pour pouvoir transférer les fichiers, sans le dossier "installation".
                        Quel template utilises-tu ? Si c'est un template livré avec Joomla!, il sera remplacé par la version standard, sinon, il ne risque rien.
                        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                        Commentaire


                        • #13
                          Re : Pas d'affichage du site et pas d'accès à l'administrateur

                          J'ai fait l'installation à partir de la nouvelle version de Joomla (dézipper et copie des dossiers sauf le dossier 'installation')
                          J'ai toujours un écran blanc pour l'administrateur et du texte brut en accès au site.
                          Et la base de données dans tout cela, peut-elle être incriminer, comment faire pour vérifier ?
                          Et la version de PHP,est-ce une piste ? (local : 5.4.10, OVH : 5.4.45)
                          Je ne comprends plus rien (((((
                          Dernière édition par luxojr à 16/01/2017, 10h43

                          Commentaire


                          • #14
                            Re : Pas d'affichage du site et pas d'accès à l'administrateur

                            Bonjour à tous,
                            Je reviens vers vous pour vous signaler que j'ai tenté d'autres copies de mon site local (fonctionne en local mais sur le serveur d'OVH)
                            Dans ce post j'ai d&jà expliqué ma situation (lire les posts ci-dessus).
                            Quelqu'un a une nouvelle idée...
                            Merci d'avance.

                            Commentaire


                            • #15
                              Re : Pas d'affichage du site et pas d'accès à l'administrateur

                              Il est curieux qu'avec ton rapport d'erreur au maximum, tu n'aies aucune erreur apparue et seulement une page blanche.
                              Si une copie propre du site fonctionne en local, le plus simple serait peut-être d'en faire une sauvegarde avec Akeeba backup, de supprimer ce que contient le dossier du site sur le serveur OVH, puis de restaurer ta sauvegarde avec kickstart.
                              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X