Balise span non reconnue dans l'editeur TinyMCE de Joomla

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Balise span non reconnue dans l'editeur TinyMCE de Joomla

    Bonjour à tous et toutes,

    Lorsque j'utilise la balise span dans l'éditeur de texte par défaut de Joomla(TinyMCE), il ne le reconnais pas (il ne l'applique pas au texte) et la balise elle-même disparait dans le code source après avoir valider le code dans l'éditeur de texte. J'utilise la version 3.7.3 de Joomla.

    Bien à vous,
    Dolnar
    Yes We Can...Change The Web With JOOMLA...

  • #2
    Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

    J'utilise uniquement TinyMCE dans l'éditeur de newsletters d'Acy car bizarrement JCE me fait des trucs bizarres et je colle des dizaines de balise span dans le code de mes newsletters que je rédige totalement manuellement dans l'éditeur de code Tiny sans problème. Je bascule ensuite du mode code en mode affichage et réciproquement sans que cela ne change rien dans mes span.
    "Si vous n’êtes pas impliqués émotionnellement dans ce que vous créez, laissez tomber."
    https://www.graphiquedesign-bf.com/

    Commentaire


    • #3
      Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

      tu as peut être un filtre au niveau de tes groupes utilisateurs, as tu regardé de ce coté la?
      Plus c'est simple pour l'utilisateur, et plus c'est complexe pour le développeur, et vice versa

      Commentaire


      • #4
        Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

        @Klarann18, moi, je n'ai qu'un utilisateur sur le cms joomla, j'ai pas créé un autre utlisateur. Et cet utilisateur est un admin.
        Yes We Can...Change The Web With JOOMLA...

        Commentaire


        • #5
          Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

          Quelqu'un saurait ce qu'il y a avec l'éditeur? Il fonctionnait bien avant. Est-ce la nouvelle version de Joomla qui est en cause?
          Yes We Can...Change The Web With JOOMLA...

          Commentaire


          • #6
            Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

            Je crois qu'il y a un problème sur les listes blanches dans l'édition du contenu depuis la 3.7.3
            Exemple mes balises link ont disparue de mes articles depuis cette MAJ.

            Voir "Paramètres des filtres de texte" dans la config et pourtant je suis en No filter sur les "super admin"
            Faites du bruit, JOOMLA is the best ...
            Quel pieds ce truc, j'en découvre tous les jours ...

            Commentaire


            • #7
              Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

              Bug Fixe dans la version 3.7.3 de Joomla
              Calendar fixes #16794
              Fix frontend menus of menu type "main" or "menu" and backend main menu #16577
              Tags: Respect Browser Page Title in view Tagged Items #16773
              Adding thumbs file names in Media Manager #16769
              Remove PHP memory_limit from max upload size calculation #16741
              Fix custom fields without a fieldgroup not being displayed #16705
              Update tinymce to 4.5.7 #16042
              Visit GitHub for the full list of bug fixes.

              Il y a eu une mise à jour de l'éditeur TinyMCE 4.5.7
              Yes We Can...Change The Web With JOOMLA...

              Commentaire


              • #8
                Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

                Quand j'entre la balise span sans l'attribut style :
                <span>Mon texte...</span>
                Là l'éditeur TinyMCE ne garde pas les span.
                Mais si j'entre la balise span avec l'attribut style:
                <span style="color: orange;">Mon texte...</span>
                Il retient les balises dans l'éditeur. Très étrange...
                Yes We Can...Change The Web With JOOMLA...

                Commentaire


                • #9
                  Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

                  Quel est l'intérêt d'avoir une balise span sans aucun attribut ?
                  Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
                  C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
                  Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

                  Commentaire


                  • #10
                    Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

                    J'ai définit dans ma feuille de style que mes balise span seront orange par défaut sans attribut. Pour éviter de l'appliquer sur chaque pages créés.
                    Yes We Can...Change The Web With JOOMLA...

                    Commentaire


                    • #11
                      Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

                      Ce n'est pas l'utilisation normale de span qui est une balise "vide" (sans signification sémantique). Tu devrais dans tes css créer une class orange où tu définis les paramètres à ta guise et utiliser la balise sous la forme <span class=orange>ton texte</span>. Ce serait plus logique et si un jour tu as besoin de texte vert tu n'auras qu'à créer la class vert.
                      Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
                      C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
                      Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

                      Commentaire


                      • #12
                        Re : Balise span non reconnue dans l'editeur TinyMCE de Joomla

                        Envoyé par dolnar Voir le message
                        J'ai définit dans ma feuille de style que mes balise span seront orange par défaut sans attribut. Pour éviter de l'appliquer sur chaque pages créés.
                        Dans ce cas je te conseille plutot de mettre à minima une classe du genre <span class="orange"></span> car imaginons que tu veuilles pour une raison ou une autre appliqué un style différent à un endroit et que l'éditeur te met une balise span tu vas te retrouver systématiquement avec ton texte orange.

                        EDIT : désolé je n'avais pas lu le post précédent...
                        Dernière édition par klarann18 à 07/07/2017, 09h29
                        Plus c'est simple pour l'utilisateur, et plus c'est complexe pour le développeur, et vice versa

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X