Joomladay francophone 2019 à Paris, les 8 et 9 mars 2019

Changement php et JCH optimize qui fait maintenant ralentir mon site

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Changement php et JCH optimize qui fait maintenant ralentir mon site

    Bonjour,
    Tout d'abord, voici quelques infos de base:

    mon site : http://www.elemiahvoyance.com
    Php 7.2
    Version joomla : 3.9.1.
    Hébergeur: nuxit
    A jour normalement au niveau de tout les plugins ainsi que mon template ricochet de rocket.

    - Depuis le passage en php 7.2, avant j'étais en 5.6, je rencontre des soucis avec jc optimize et je pense le cache de joomla de façon générale.
    J'ai la version pro du logiciel. Quand je lance le plugin mon site rame et à du mal à se lancer et quand je consulte le code source pour le voir apparaître j'ai l'impression qu'il n'ai pas actif.

    Avant le passage php 7.2, JCH fonctionnait très bien, était actif et optimisé parfaitement mon site.

    - Quand je le désactive, mon site refonctionne normalement sans problème de rapidité.
    La différence est incroyable entre le moment où je l'active (page qui met de nombreuses secondes à apparaître ) et sans ( quasiment instantanés).

    Une aide ou un début du pourquoi du comment ?
    Je précise que mes connaissances en informatiques sont limitées. J'ai moi même crée ce site mais je suis loin d’être calée en tout donc par avance: mes excuses !

    Merci par avance !

  • chabi01
    a répondu
    Effectivement, ce n'est pas Joomla qui est en faute ici
    Tu aurais les mêmes soucis avec n'importe quel autre CMS (voire pire d'ailleurs !).
    Sinon, si tu dis que tu as également un problème avec le cache, oui, cela semble être alors le même souci

    Cordialement,

    Laisser un commentaire:


  • cavo789
    a répondu
    Bonsoir

    Envoyé par EleeSaS Voir le message
    Je ne désespère pas même si je peste contre joomla alors que je lui suis fidèle depuis le début !!
    Je ne comprends pas... Si je mets un additif dans mon réservoir d'essence et que ma voiture commence à tousser; est-ce le constructeur de ma merveilleuse voiture qui est à blâmer ?

    Dans ton historique ci-dessus où Joomla est-il en faute ? En plus, tu dis toi-même "Quand je désactive le plugin, mon site refonctionne sans souci.

    (je comprends que tu puisses râler, c'est un sentiment compréhensible toutefois la victime est mal ciblée ;-) )

    Bonne soirée.
    Dernière édition par cavo789 à 10/01/2019, 19h56

    Laisser un commentaire:


  • EleeSaS
    a répondu
    Déjà merci beaucoup pour ton investissement et ton retour.
    Je dois donc vérifier les droit d'écriture sur php que dois je voir marquer je sais en principe ou c'est mais que doit il vraiment y avoir marqué ?
    J'ai envoyé un message à mon hebergeur pour le safe mode car je ne peux pas le modifier moi même il doit être sur off et safe gide aussi c'est bien ça ?
    J'attend ensuite pour jc optimizer de voir avant ce que donne les changements.
    Pense tu que mon problème de ne pas pouvoir utiliser le cache conservateur de joomla peut aussi avoir un rapport car dès que je le met mon site rame énormement ?

    Merci d'avance pour ton aide et je te tiens au courant de l'évolution.
    Je ne désespère pas même si je peste contre joomla alors que je lui suis fidèle depuis le début !!

    Laisser un commentaire:


  • chabi01
    a répondu
    J'ai vérifié le site de test directement en Super Admin pour vérifier rapidement le souci : JCH ne fonctionne effectivement pas. Même lancé, il ne combine pas les fichiers.
    Au niveau de la vérification, j'ai vu également que 2 paramètres étaient en place sur le serveur et qu'il faudrait voir à changer (je ne sais pas si cela vient de là) : le Safe Mode est sur "on" est le Safe Mod GID est également sur "on"...
    Autre erreur détectée : la version 5.3 étant installé, celle ci ne trouve pas un fichier "ini". Même en réinstallant la 5.3, l'erreur persiste. En installant la version 5.2.8 (la précédente), l'erreur disparait mais le problème demeure.
    Autre point : penser à saisir la clé de mise à jour du plugin, sans celle-ci, le plugin peut très bien refuser de fonctionner.
    Je pense que le souci vient du Safe Mode qui est activé sur l'hébergement et qui bloque les exécutions...
    J'ai testé la version 5.3 sur un autre hébergement : aucun souci de fonctionnement. Il est donc vraisemblable que tout le souci viennent des paramétrages serveur et pas du site..

    Autre possibilité : un problème de droits d'écriture (vraisemblable) indiqué via le message "
    Joomla\CMS\Cache\Storage\FileStorage::_deleteFolde r JFolder::delete : impossible de supprimer le répertoire. Chemin : /xxx/xxxxxx/www/joomla39/cache/plg_jch_optimize
    "
    Ce souci apparait alors si je saisis une clé de mise à jour (et donc que le plugin fonctionne "normalement"). En supprimant la clé, le message ne s'affiche plus, ce qui laisse supposer que le plugin cesse de bosser sans sa clé.

    Donc :
    - saisir la clé de fonctionnement de la version pro
    - vérifier les droits d'écriture, les chemins cache, sessions, tmp
    - vérifier sur l'hébergement les paramètres (voir avec l'hébergeur si nécessaire).

    Cordialement,

    Laisser un commentaire:


  • EleeSaS
    a répondu
    j'ai installé un site test et j'ai mis jch optimize et je ne le vois pas actif.

    Dernière version joomla et php 7.2.
    Lien du site : http://joomla39.elemiahvoyance.com/

    Sans erreur donc on voit bien qu'il n'est pas actif ou vraiment je n'y comprend plus rien lol

    Laisser un commentaire:


  • chabi01
    a répondu
    Oulala ! La base et le préfixe des tables, ce sont 2 choses différentes ! Tu devrais faire une mise à plat de tout ton système : relever exactement toute la configuration et vérifier qu'il n'y a pas des mélanges malheureux...
    Cordialement,

    Laisser un commentaire:


  • EleeSaS
    a répondu
    Alors petit retour sur mon problème après quelques test. je me suis rendu compte que quand je met le cache joomla mon site rame énormement alors que si je n'en met aucun il fonctionne vite !
    De plus dans mes réglages du serveur sur joomla je me demande si je n'ai ps une erreur, je m'explique

    dans la rubrique nom de la base j'ai mis elemiahvoyance
    alors que sur mon serveur nom de la base c'est elemiahvoyance_j3

    dans préfixe j'ai bien _j3 sur joomla et sur le serveur c'est pareil

    Laisser un commentaire:


  • chabi01
    a répondu
    Hello,
    Remettre en route JCH sur un site qui contient des erreurs ne va rien accélérer : JCH ne corrige pas les erreurs mais combine les fichiers CSS et Javacript ensemble pour éviter de multiples appels c'est tout... Il faut avant d'activer JCH corriger les multiples erreurs existantes...

    Cordialement,

    Laisser un commentaire:


  • EleeSaS
    a répondu
    Non les articles ne sont pas du copier coller de word . que veut dire image récupéré base 64 lol je n'y connais pas grand chose
    J'ai remis en route le plugin pour faire constater le ralentissement et qu'il ne s'active pas dans le code source

    Laisser un commentaire:


  • RobertG
    a répondu
    Le contenu des articles est-il un copier-coller de documents Word ? Il y a des tas d'images récupérées en base64 dans le code-source de la page d'accueil, très longue à charger alors que JCH Optimize ne semble pas actif.
    Je pense qu'il y a un problème au niveau du serveur, pour expliquer une telle lenteur.

    Laisser un commentaire:


  • chabi01
    a répondu
    Pour compléter, je ne suis pas sur que ce soit JCH en cause : je viens de relever 28 erreurs à répétition de type "syntax error" dans le site !
    Ouvre une console Firebug, et charge cette page : http://www.elemiahvoyance.com/le-mardi/17h-18h#tab1-9
    A partir de là, il y a dans tous les cas un souci sur le site et JCH ne pourra pas fonctionner si il y a à la base des erreurs...
    Cordialement,

    Laisser un commentaire:


  • chabi01
    a répondu
    Bonjour,
    Avec l'accord de l'auteur, j'ai commencé la traduction de la documentation de JCH.
    Il est normal dans un premier temps d'avoir un délai au moment du chargement initial du plugin (au moment où il génère le cache des fichiers combinés). Ceci dit, une FirstTimeByte à 29 secondes, y a un vrai souci.
    Ceci étant dit, je dis cela en visitant ton site : la console ne montre pas le fichier combiné de JCH, le plugin ne semble donc pas activé...

    Vérifie en partant de cette page : https://xlformation.com/tutoriels/12-jch-optimize.html
    Tu as les premiers chapitres (il m'en reste 3 à terminer) et tu as la procédure expliquée pour le paramétrage et la recherche d'erreurs.

    Cordialement,

    Laisser un commentaire:


  • EleeSaS
    a répondu
    Envoyé par pmleconte Voir le message
    Bonjour et bienvenue,

    Au niveau du plugin JCH Optimize, il faut nettoyer son cache après une grosse mise à jour telle que la vôtre : onglet 'options de base", section "Réglages divers", bouton "Nettoyer le cache".

    Peut-être une piste ?

    Pascal
    Bonjour,

    J'ai effectué cette idée mais malheureusement toujours le même problème !

    Laisser un commentaire:


  • EleeSaS
    a répondu
    Envoyé par cavo789 Voir le message
    Bonjour

    Tu mentionnes avoir une licence Pro et tu es parvenu à clairement identifier que si JCH est actif, c'est très lent, s'il n'est pas actif, la vitesse est normale ==> est-ce que ta licence te donne accès à un support chez eux car si c'est le cas, à ta place, c'est bien là-bas que j'irai poster ma question ;-)

    Bonne journée.
    Bonjour,
    Oui en effet j'ai commencé par là mais personne ne réponds. J'ai ouvert un ticket et je suis toujours dans l'attente....
    Dernière édition par cavo789 à 08/01/2019, 18h38

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X