mon robots.txt provoque une erreur 500 ?!

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] mon robots.txt provoque une erreur 500 ?!

    Bonjour,

    Je n'ai pourtant rien changé, et je m'aperçois pourtant que quand j'essaie d'accéder à mon robots.txt, ça renvoie une erreur 500...
    Est-ce que ça pourrait être un problème de permissions ?
    Je ne les ai pas changées, mais je vois, dans WinSCP, les droits suivants :
    rw-
    rw-
    rw-
    Ne devrais-je pas avoir le X coché aussi ?
    Octal: 0644

    Bizarre...
    Je suis certaine d'avoir accédé sans problème à mon robots.txt le week-end dernier, quand je cherchais à comprendre pourquoi une partie de mes pages n'étaient plus indexées (elles le sont désormais)

    Merci d'avance pour vos lumières

    EDIT 15:42

    Quand j'essaie d'accéder à mon robots.txt avec Firefox, j'ai une fenêtre qui s'ouvre disant :
    Le site https://www.mondomaine.fr demande un nom d’utilisateur et un mot de passe. Le site indique : « Restricted Area »
    Bon sang mais qu'est-ce qui peut donner la consigne de demander un mot de passe pour accéder à ce fichier ?
    Ahhhhhhh.... Je crains que ce soit aeSecure, qui, de mémoire, a une sécurité "empêcher les curieux de fouiner dans le robots.txt"
    Sauf qu'empêcher Google d'y accéder, ce n'était pas le but...
    ... et que n'ayant plus d'accès à mon interface aeSecure, je ne peux pas changer ce paramètre !

    Différence entre Firefox et Chrome :
    Chrome envoie juste une erreur 500, sans davantage d'explication
    Firefox demande un login et, si on refuse de répondre, renvoie une erreur 401 Unauthorized Ce fichier requiert une autorisation

    cavo789 une idée ?
    SimonG es-tu là ??
    Dernière édition par FlodAriege à 05/05/2019, 14h48
    Flo, Ariège

    Il n'y a que celui qui a honte d'apprendre qui a peur de demander

  • #2
    As-tu tenté de simplement renommer ton .htaccess pour voir si ça supprime ce blocage ainsi que celui de l'accès à l'interface aeSecure ?

    644 est normal pour les fichiers. La demande d'identification en front-end est quant à elle vraiment étonnante...
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Envoyé par RobertG Voir le message
      As-tu tenté de simplement renommer ton .htaccess pour voir si ça supprime ce blocage ainsi que celui de l'accès à l'interface aeSecure ?

      644 est normal pour les fichiers. La demande d'identification en front-end est quant à elle vraiment étonnante...
      As-tu tenté de remettre une version d'aeSecure ou cas où ton actuelle serait corrompue ?

      Envoie moi un accès FTP à ton site et l'URL de celui-ci via mon interface send.avonture.be et je tâcherai de regarder.
      Christophe (cavo789)
      Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
      Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
      Mes logiciels OpenSource : https://www.avonture.be

      Commentaire


      • #4
        Envoyé par RobertG Voir le message
        As-tu tenté de simplement renommer ton .htaccess pour voir si ça supprime ce blocage ainsi que celui de l'accès à l'interface aeSecure ?

        644 est normal pour les fichiers. La demande d'identification en front-end est quant à elle vraiment étonnante...
        Non, je n'ai pas tenté ça, car la dernière fois que je me suis retrouvée sans htaccess, j'ai complètement perdu accès au site.
        Et puis je me dis (et Christophe semble d'accord) que si le htaccess était en cause, je n'aurais pas accès à mon back-end et/ou à mon front-end.

        Par contre, avant de te répondre, je suis quand même allée vérifier mon htaccess en détail (comparaison avec une version antérieure).
        Et ce faisant, je me suis dit 'tiens, et si je cherche "robots", qu'est-ce que je vais trouver ?"

        Ben...
        ... j'ai trouvé la protection aeSecure 2.7 contre les curieux :
        Code:
        <IfModule mod_rewrite.c>
          Block curious who try to get access to the robots.txt file from an url.
         RewriteEngine On
         RewriteRule robots.txt$ /aesecure/setup.php?r=1 [L]
        </IfModule>
        ... que je me suis empressée de commenter.
        (je restais bloquée en mode 'j'ai pas d'accès à aeSecure donc je ne peux pas désactiver cette sécurité" sans penser que je pouvais très bien intervenir au niveau du htaccess).

        Et donc...
        Problème réglé : robots.txt revenu

        Merci, une fois de plus, pour ta contribution, tu m'as aidée à trouver la solution (à plusieurs on est plus intelligents !!)

        (par contre, reste à savoir pourquoi cette protection aeSecure provoque un comportement aberrant qui empêche Google de le lire, mais ça c'est un autre problème)
        Flo, Ariège

        Il n'y a que celui qui a honte d'apprendre qui a peur de demander

        Commentaire


        • #5
          Envoyé par FlodAriege Voir le message

          Non, je n'ai pas tenté ça, car la dernière fois que je me suis retrouvée sans htaccess, j'ai complètement perdu accès au site.
          Et puis je me dis (et Christophe semble d'accord) que si le htaccess était en cause, je n'aurais pas accès à mon back-end et/ou à mon front-end.

          Par contre, avant de te répondre, je suis quand même allée vérifier mon htaccess en détail (comparaison avec une version antérieure).
          Et ce faisant, je me suis dit 'tiens, et si je cherche "robots", qu'est-ce que je vais trouver ?"

          Ben...
          ... j'ai trouvé la protection aeSecure 2.7 contre les curieux :
          Code:
            Block curious who try to get access to the robots.txt file from an url.
           RewriteEngine On
           RewriteRule robots.txt$ /aesecure/setup.php?r=1 [L]
          ... que je me suis empressée de commenter.
          (je restais bloquée en mode 'j'ai pas d'accès à aeSecure donc je ne peux pas désactiver cette sécurité" sans penser que je pouvais très bien intervenir au niveau du htaccess).

          Et donc...
          Problème réglé : robots.txt revenu

          Merci, une fois de plus, pour ta contribution, tu m'as aidée à trouver la solution (à plusieurs on est plus intelligents !!)

          (par contre, reste à savoir pourquoi cette protection aeSecure provoque un comportement aberrant qui empêche Google de le lire, mais ça c'est un autre problème)
          Logique car ton interface retourne une erreur 500 (reste à comprendre pourquoi et c'est toute la discussion avec ton fichier d'erreur non généré par ton hébergeur).

          Si tu commentes le code l'interface n'est plus appelée. Le problème t reste toujours lié à ton erreur 500...
          Christophe (cavo789)
          Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
          Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
          Mes logiciels OpenSource : https://www.avonture.be

          Commentaire


          • #6
            Envoyé par cavo789 Voir le message
            Logique car ton interface retourne une erreur 500
            Qu'est ce qui est logique ?
            Que mon robots.txt - qui contenait la directive 2.7 - renvoie une erreur 500 à cause de mon interface aesecure qui elle-même est en erreur 500 ? C'est ça ?

            Envoyé par cavo789 Voir le message
            (reste à comprendre pourquoi et c'est toute la discussion avec ton fichier d'erreur non généré par ton hébergeur).
            Il semble que les erreurs osient en fait reportées à l'intérieur du fichier des accès.
            Comme je l'indique dans le post sur le error logs, j'ai des lignes comme celle-ci dans ce fichier :

            Code:
            11.111.111.1 - - [04/May/2019:14:56:13 +0200]
            "GET /favicon.ico HTTP/1.1" 404 1549 www.mondomaine.fr "
            https://www.mondomaine.fr/aesecure/setup.php?xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
            "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.108 Safari/537.36" "-"
            Envoyé par cavo789 Voir le message
            Si tu commentes le code l'interface n'est plus appelée. Le problème t reste toujours lié à ton erreur 500...
            Tout ce que j'ai commenté, c'est l'instruction concernant le robots.txt
            avant que je commente, le robots n'était plus accessible à personne, ni à moi, ni à Google
            après que je j'ai commenté les lignes consacrées au robots.txt dans le htaccess, le robots.txt a réapparu

            mais bien sûr ça ne change rien à mon problème avec aesecure...
            Flo, Ariège

            Il n'y a que celui qui a honte d'apprendre qui a peur de demander

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X