restauration d'un nouveau site joomla 4

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] restauration d'un nouveau site joomla 4

    Bonjour,
    Voilà ce que j'essaye de faire et le problème que je rencontre. Il doit y avoir qui cloche dans ma démarche mais je ne vois pas.
    J'ai créé un site joomla 4 en local. J'en ai fait une sauvegarde akeeba.
    J'ai le même site public (version joomla 3) sur ovh, et je souhaite remplacer l'ancien site par le nouveau.
    J'ai créé un répertoire sur le serveur ovh que j'ai appelé "wwwa". J'ai copié dans ce répertoire les fichiers kickstart, fr-FR.kickstart.ini et le fichier .jpa
    J'ai renommé le répertoire actif "www" en "wwwb" puis j'ai renommé le répertoire "wwwa" en répertoire "www".
    Sous Mozilla, je mets en barre d'adresse "http://"lenomdusite"/kickstart.php
    La restauration commence alors par l'extraction des fichiers qui se passe bien. Ensuite viennent les écrans pour la configuration de la base de données.
    J'ai beau mettre les informations attendues (nom de la base, mot de passe etc) l'installation se termine immanquablement par une erreur.
    Cela fait trois fois que j'essaie et je ne progresse pas.
    Avez-vous une idée de l'erreur que je reproduis systématiquement ? Dois-je détruire l'ancienne base de données ?
    Merci d'avance

  • #2
    Bonjour,

    Quel est le message d'erreur ? Si les infos n'étaient pas correctes, dès la tentative d'écriture dans la base, tu aurais un blocage disant que l'accès est impossible.
    Ensuite, sais-tu quelle est la version de PHP par défaut sur ton serveur ? Pour celle de MySQL, je ne sais plus si on peut la connaître dans le Manager.
    Autre point : la base ne serait-elle pas saturée par les tables de l'ancienne version ? Vérifie dans ton Manager quelle est la taille à laquelle tu as droit et quelle est la place qui reste pour le nouveau site.
    Enfin, as-tu mis de côté une sauvegarde de l'ancien site ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      Il me semble que c'est un problème d'accès à la base de données.
      quand je renommé les répertoires, l'ancien site fonctionne normalement.
      demain je vais refaire l'opération, le transfert de la sauvegarde est longue

      Commentaire


      • #4
        Bonjour RobertG,
        J'ai refait un essai de restauration, l'erreur qui en découle est :
        "unable to connect to the database : could not connect to MySQL"
        J'ai vérifié les versions de php, il y a une différence entre les versions. J'ai donc corrigé mon nouveau site pour aligner les versions de php, j'ai refait une sauvegarde et je suis en train de la télécharger sur le serveur OVH. Cela va prendre du temps, dès que je le pourrai je réessayerai la restauration. En attendant je croise les doigts.
        Bonne journée

        Commentaire


        • #5
          Bonjour,

          Cela voudrait donc dire que les informations d'accès à la base de données sont incorrectes. Vérifie notamment dans ton Manager la valeur de "serveur" à utiliser pour ta restauration.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

          Commentaire


          • #6
            Qu'est-ce que tu appelles la valeur de "serveur" ?

            Commentaire


            • #7
              Celui de base de données, que tu vois dans ton manager et qui est référencé sous host dans le fichier de configuration.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #8
                Bonjour,
                Je viens de refaire un essai avec la version de php modifiée, et en mettant les informations relevées sur le manager du site local (voir ci-dessous). J'ai toujours la même erreur au moment de l'installation de la base sur le serveur ovh. Cliquez sur l'image pour l'afficher en taille normale

Nom : base.jpg 
Affichages : 33 
Taille : 63,9 Ko 
ID : 2034503

                Commentaire


                • #9
                  Ces informations sont celles de ton serveur local, elles ne peuvent pas fonctionner sur ton serveur OVH.

                  Il faut que tu ailles dans ton Manager OVH dans la section base de données récupérer le nom du serveur, qui n'est en aucun cas "localhost", celui de la base et de l'utilisateur (qui sont identiques) et le mot de passe que tu trouveras dans le fichier configuration.php de l'ancien site si tu ne l'as pas mémorisé ailleurs.
                  Si ta formule d'hébergement te le permet, tu peux aussi créer une nouvelle base de données et donc utiliser ses propres caractéristiques de connexion, avant de supprimer plus tard l'ancienne.
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                  MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                  Commentaire


                  • #10
                    J'ai essayé ce que tu m'as dit de faire, sans succès. Voici quelques copies d'écran :
                    écran tiré d'ovh manager : Cliquez sur l'image pour l'afficher en taille normale

Nom : base ovh.jpg 
Affichages : 28 
Taille : 37,0 Ko 
ID : 2034517

                    écrans de la restauration :
                    Cliquez sur l'image pour l'afficher en taille normale

Nom : etape6.jpg 
Affichages : 25 
Taille : 54,6 Ko 
ID : 2034518Cliquez sur l'image pour l'afficher en taille normale

Nom : base.jpg 
Affichages : 25 
Taille : 63,9 Ko 
ID : 2034519Cliquez sur l'image pour l'afficher en taille normale

Nom : etape6 erreur.jpg 
Affichages : 28 
Taille : 105,2 Ko 
ID : 2034520

                    Commentaire


                    • #11
                      l'écran "base de données n'est pas bon, j'ai mis les informations d'ovh en place :
                      Mysqli
                      lechodelollecho
                      lechodelollecho
                      lechodelollecho
                      un mot de passe que j'ai pris dans le fichier configuration.php
                      et j'ai essayé deux préfixes, le premier tiré de la base localhost, le second après le message d'erreur tiré de la base ovh (zjtzc_)
                      sans succès donc

                      Commentaire


                      • #12
                        Si je me fie aux infos d'OVH dans la capture écran le nom du serveur hôte devrait être
                        Code:
                        lechodelollecho.mysql.bd
                        et non
                        Code:
                        lechodelollecho
                        Je préfère éclairer que briller.” - “J'ai peut-être l'air froid, mais je suis pas givré.- "ça dépend ça dépasse"
                        Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
                        Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

                        Commentaire


                        • #13
                          Le préfixe n'a pas d'importance (il sera affecté aux nouvelles tables), mais il doit se terminer par un trait de soulignement.
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                          Commentaire


                          • #14
                            Bien vu Dolmenhir ! Je me trompais dans l'écriture du nom de l'ancienne base avant l'écran d'extraction. Maintenant cela fonctionne. Merci beaucoup pour votre aide. Je passe le sujet en réglé

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins

                            Partenaire de l'association

                            Réduire

                            Hébergeur Web PlanetHoster
                            Travaille ...
                            X