Page en double : Google n'a pas choisi la même URL canonique que l'utilisateur

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #16
    Bonjour,
    Merci pour ces précisions qui me confortent dans mon choix : je vais tenter, ce week-end, de mettre en place tout cela
    Je suis content, google m'a d'ores et déjà validé énormément d'url suite à la précédente procédure mise en place au sein du .htaccess : il en reste une dizaines en cours encore marquées comme non validées, mais le plus gros est passé

    A bientôt donc pour vous tenir au courant,
    Encore un grand merci,
    Pierre

    Commentaire


    • #17
      Bonjour,
      Comme convenu, j'ai réalisé les opérations suivantes à l'instant :
      1) robot.txt : ouverture avec notepad++, mise en place en fin de fichier de la ligne "sitemap: https://www.pierbiau.com/index.php?o...xml&tmpl=c omponent&id=3&format=xml" (sans les guillemets), encodage en UTF8 (No Bom), remise ad hoc via ftp (sauvegarde préalable de l'ancien fichier avant les modifications)
      2) .htaccess : mise en place du code "RewriteCond %{REQUEST_URI} ^/sitemap.xml
      RewriteRule .* https://www.pierbiau.com/index.php?o...xml&tmpl=c omponent&id=3&format=xml​" (sans les guillemets), en dessous d'un RewriteEngine On déjà existant en fin de fichier, encodage en UTF8 (No Bom), remise ad hoc via ftp (sauvegarde préalable de l'ancien fichier avant les modifications)

      Tout s'est bien passé, le site fonctionne en "frontal"
      3) Téléchargement et installation de sitemapcache 1.0.7 > installation ok, mais ensuite la MAJ ne peux pas s'appliquer en version gratuite (si j'ai bien compris ce que j'ai lu en anglais), dont voici la capture d'écran :

      Cliquez sur l'image pour l'afficher en taille normale

Nom : sitemap cache maj.jpg 
Affichages : 33 
Taille : 121,5 Ko 
ID : 2063041

      Dois-je comprendre que la version 1.0.7 de ce plugin fonctionne tout de même, et qu'elle joue son rôle, ou bien dois-je partir sur une autre extension ?
      Cordialement,
      Pierre

      Fichiers joints

      Commentaire


      • #18
        Envoyé par Pierre débutant Voir le message
        Dois-je comprendre que la version 1.0.7 de ce plugin fonctionne tout de même, et qu'elle joue son rôle, ou bien dois-je partir sur une autre extension ?
        Cordialement,
        Pierre
        Ce plugin fonctionne (il ne répond plus au support de la version "gratuite" ) mais tu peux oublier cette extension de cache du plan de site, elle n'est pas intéressante dans ton cas.
        J'ai tendance à aller parfois trop loin dans mes explications. Désolé.

        Pour le reste, j'ai des doutes dans ton écriture dans le htaccess car si je tape l'url https://www.pierbiau.com/sitemap.xml
        je ne tombe pas sur le plan de site xml mais sur la page d'accueil du site... Tu as peut être mis un espace dans l'url vers le xml en effectuant un copie coller du forum,
        le forum a tendance à modifier les chemins en glissant des espaces ou en effectuant des raccourcis... A surveiller !


        Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

        Commentaire


        • #19
          Bonjour,

          Ce plugin fonctionne (il ne répond plus au support de la version "gratuite" ) mais tu peux oublier cette extension de cache du plan de site, elle n'est pas intéressante dans ton cas.
          J'ai tendance à aller parfois trop loin dans mes explications. Désolé.​
          Du coup, je peux quand même conserver ce plugin qui fonctionne, même s'il ne répond plus au support de la version gratuite, cela rajoute tout de même une sécurité supplémentaire.

          Pour le reste, j'ai des doutes dans ton écriture dans le htaccess car si je tape l'url https://www.pierbiau.com/sitemap.xml
          je ne tombe pas sur le plan de site xml mais sur la page d'accueil du site​
          Je viens de vérifier, dans le .htaccess, "lettre après lettre" l'ensemble du texte recopié : pas d'erreur d'espace... Tout correspond en tout point.
          Dans robot.txt, j'ai bien écrit la même "phrase", en laissant un espace juste après les 2 points de Sitemap: (comme c'est le cas d'après ce que j'ai observé)
          Dans .htaccess et dans robot.txt, les urls sont bien soulignées en entier, tel que l'est un lien url, je n'ai pas d'espace qui le "scinde".
          Voici des captures d'écran :
          .htaccess :
          Cliquez sur l'image pour l'afficher en taille normale

Nom : htaccess03.07.2024.jpg 
Affichages : 30 
Taille : 71,3 Ko 
ID : 2063050
          robot.txt :

          Cliquez sur l'image pour l'afficher en taille normale

Nom : robot.txt03.07.2024.jpg 
Affichages : 29 
Taille : 17,2 Ko 
ID : 2063051
          Par contre, je ne sais pas s'il y a un lien, mais avant ces opérations de rajout de programmation, l'url https://www.pierbiau.com/sitemap.xml​ renvoyait à la page d'acceuil, pas au plan de site, contrairement à l'url que je copiais dans le presse papier au format xml depuis le plugin Osmap https://www.pierbiau.com/component/o...d=3&format=xml

          Voilà tout de ce que j'y comprends
          Fichiers joints

          Commentaire

          Annonce

          Réduire
          Aucune annonce pour le moment.

          Partenaire de l'association

          Réduire

          Hébergeur Web PlanetHoster
          Travaille ...
          X