Affichage de type Blog Page accueil sur 2 colonnes

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Affichage de type Blog Page accueil sur 2 colonnes

    Bonjour à tous,
    Après avoir testé en local la migration de mon site de J3 vers J4 je viens de franchir le pas en prod.
    Je rencontre toutefois un petit soucis d'affichage différent en fonction du navigateur. Avec Firefox la page d'accueil s'affiche bien comme je le désire avec 1 article en pleine largeur, puis 2 sur 2 colonnes, alors qu'avec Chrome les articles sont tous sur 1 seule colonne et à partir du deuxième il y a une colonne vide sur la droite.
    J'utilise le Template Cassiopea que je n'ai pas modifié si ce n'est la couleur par défaut et celles du bandeau + pied de page.
    Une idée de la cause?
    Merci d'avance
    Dernière édition par zebulon437 à 19/05/2022, 07h10

  • #2
    bonjour,

    pas le temps d'analyser le pourquoi du comment, mais si tu changes
    masonry-2
    par
    columns-2
    dans le menu de type blog correspondant, ça résout le problème...
    Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

    Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles les 20 et 21 mai 2022. Évènement à ne pas rater ! Plus d'infos sur https://www.joomladay.fr

    Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

    Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

    Commentaire


    • #3
      Bonjour Woluweb et merci pour la réponse rapide,
      Je ne trouve pas ou modifier ce paramètre? J'ai essayé de modifier Introduction des articles pas de changement, j'ai ensuite essayé Nombre de colonnes, pas mieux...

      Commentaire


      • #4
        Bonsoir,
        Je viens d'essayer de remplacer masonry-2 par columns-2 dans les 5 occurrences trouvées dans les fichiers
        1. media\templates\site\cassiopeia\css\template-rtl.css Ligne 12531
        2. media\templates\site\cassiopeia\css\template-rtl.min.css Ligne 7
        3. media\templates\site\cassiopeia\css\template.css Ligne 12531
        4. media\templates\site\cassiopeia\css\template.min.c ss Ligne 7
        5. media\templates\site\cassiopeia\scss\blocks\_modif iers.scss Ligne 234
        Cela n'a pas résolu mon soucis même en vidant le cache de Chrome.
        Ai je raté quelque chose?

        Commentaire


        • #5
          non non, c'était pas dans les fichiers css mais dans la configuration du menu de type blog a priori

          Voir mon explication ici : https://slides.woluweb.be/cassiopeia...og-view-layout

          masonry-2 ne vient pas par hasard.
          tu as configuré qqch ?
          c'est bien le cassipeia natif, sans aucune modification ?
          pas d'extension qui vient modifier qqch ?

          Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

          Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles les 20 et 21 mai 2022. Évènement à ne pas rater ! Plus d'infos sur https://www.joomladay.fr

          Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

          Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

          Commentaire


          • #6
            Envoyé par woluweb Voir le message
            non non, c'était pas dans les fichiers css mais dans la configuration du menu de type blog a priori
            Je n'arrive pas a trouver où se situe la configuration du menu de type Blog dans l'admin

            Ces explications sont bien au dessus de mon niveau de compétences.... du coup je ne suis pas plus avancé

            masonry-2 ne vient pas par hasard.
            tu as configuré qqch ?
            c'est bien le cassipeia natif, sans aucune modification ?
            Je n'ai rien changé au cassiopea natif si ce n'est modifier les couleurs à l'aide d'un fichier user.css dont voici le contenu:

            Code:
            :root {
            --cassiopeia-color-primary: #cdd422;
            }
            
            
            
            .footer {
            background-image: none!important;
            }
            
            .header {
            background-image: none!important;
            }
            
            /*couleur bandeau*/
            .container-header {
            background: #431c5d;
            }
            /*couleur Bas*/
            .container-footer {
            background: #e05915;
            }

            pas d'extension qui vient modifier qqch ?
            , au niveau des extensions du site j'utilise :
            • LM custom site pour publier mon tag google analatycs en position debug
            • ChronoForms7 pour le formulaire de contact
            • Cookie Ck pour la gestion du RGPD

            Je ne sais pas si ça peut jouer mais j'utilise également quelques extensions coté admin, si besoin je peux t'en donner la liste...
            merci de passer du temps à aider un boulet comme moi ^_^


            Commentaire


            • #7
              En relisant tes explications je pense avoir trouvé où modifier ce paramètre, par contre si c'est bien le bon endroit cela ne semble pas fonctionner. J'ai toujours dans chrome les articles 2 et 3 l'un en dessous de l'autre.

              Commentaire


              • #8
                Bon, ce qui est bizarre c'est que columns-2 n'apparaît nulle part dans ton HTML
                Mais masonry-2 continue à apparaître dans le HTML

                Code:
                <div class="blog-items  masonry-2">
                COmme les captures d'écran sont
                - miniatures
                - et ne prennent pas tout l'écran
                je ne peux pas le confirmer, mais j'ai l'impression que ce n'est pas le bon élément de menu qui est édité...
                Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

                Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles les 20 et 21 mai 2022. Évènement à ne pas rater ! Plus d'infos sur https://www.joomladay.fr

                Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

                Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

                Commentaire


                • #9
                  Bonjour,
                  Pas pu m'occuper du site depuis 2 jours, trop de boulot à coté....

                  Je faisais les tests sur mon environnement Local, ce qui explique que tu ne retrouvais pas columns-2 sur mon site en ligne
                  je viens de le faire sur le site en ligne, coté affichage sur Chrome aucun changement

                  Dans le HTML on retrouve maintenant ça :

                  Code:
                  <div class="blog-items columns-2 masonry-2">
                  pour ce qui est des impressions d'écran en voici de l’écran complet, je te les ai mises sur mon site car je n'arrive pas à les agrandir sur le forum
                  https://unionpourvisan.fr/images/Ima...007_34_51-.png
                  https://unionpourvisan.fr/images/Ima...nistration.png
                  Dernière édition par zebulon437 à 14/05/2022, 06h41

                  Commentaire


                  • #10
                    J'ai fini par trouver ou était le problème...
                    Dans les paramètres des Articles j'avais mis 2 dans le champ nombre de colonnes de l'onglet Blog/Epinglés. Je viens de le supprimer puis de mettre columns-2 dans le paramètre classe d'article de l’affichage de type Blog du menu comme conseillé par Marc plus Haut et maintenant cela fonctionne
                    j'ai bien mes articles sur 2 colonnes dans Chrome

                    Merci pour les pistes données

                    Commentaire


                    • #11
                      super, content que ce soit résolu !
                      Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

                      Le prochain JoomlaDay FR présentiel aura lieu à Bruxelles les 20 et 21 mai 2022. Évènement à ne pas rater ! Plus d'infos sur https://www.joomladay.fr

                      Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter la base de connaissance : https://kb.joomla.fr

                      Ce forum, vous l'aimez ? Il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ, l'association francophone des utilisateurs de Joomla : https://www.joomla.fr/association/adherer

                      Commentaire


                      • #12
                        moi aussi ^_^ voire plus

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins

                        Partenaire de l'association

                        Réduire

                        Hébergeur Web PlanetHoster
                        Travaille ...
                        X