JOOMLA 1.x (=mambo 4.5.3) c'est prévu ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • JOOMLA 1.x (=mambo 4.5.3) c'est prévu ?

    Bonjour à tous.

    D'abord un grand bravo pour cet outil superbe que je viens de découvrir.

    Depuis 5/6 semaines, je "joue" avec Mambo 4.5.2 pour apprendre et je suis enthousiasmé.

    En parcourant les forums, j'ai lu que mambo 4.5.3 devait sortir en octobre. Je suppose que pour joomla c'est aussi prévu.

    Je ne voudrais pas commencer un site en joomla 1.03 si quelques jours/semaines après il faut le migrer.

    Avez-vous des infos sur la sortie prochaine d'une version 1.1 ?

    Encore bravo pour le travail accompli.

    Obibi Kenowan (la force n'est pas toujours avec moi!)
    Obibi Kenowan
    (La Force n'est pas toujours avec moi !)
    Etienne Audfray Sculpteur http://www.audfray.com
    Armand Petersen Sculpteur http://www.armand-petersen.fr

  • #2
    Salut,

    Mambo 4.5.3 va peut-être sortir bientôt, mais dans quel état Tous les core développeurs ont laissé tomber Mambo pour Joomla!

    Concernant Joomla! et les dates de release en général, une feuille de route (roadmap) existe, mais les dates sont plus données à titre indicatif. Les développeurs sont des bénévoles qui prennent sur leur temps libre pour améliorer Joomla!...

    En résumé, si tu veux un truc stable avec tout plein d'add-ons comptatibles mais risque de ne plus évoluer, choisis Mambo, sinon choisis Joomla!

    Les migrations sur les versions de maintenance (1.0.2 vers 1.0.3) sont un simple remplacement de fichiers, les migrations sur des versions mineures (1.0 vers 1.1) sont moins simples, mais je n'imagine pas que les développeurs n'aient pas tout prévu pour que cela se passe bien. Les seuls problèmes seront plutôt à regarder du côté de la portabilité des composants d'une version à l'autre...
    Dernière édition par hornos à 19/10/2005, 09h22
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
    http://www.lapatagonie.com : juste pour vous dépayser un peu...

    Commentaire


    • #3
      Ajout et precision : dernier stable 4.2.2

      Bonjour
      4.2.2 est a l'utilisation la meilleure version de mambo niveau stabilite.
      Question 1.0.3 et 4.2.3 les deux sont instables.

      Le fait de developper benevolement n'excuse pas le manque de professionnalisme au niveau des test. les deux deux versions ci dessus ont tellemnt de problemes inherent que j'en viens a me demander si je ne vais pas debugguer moi meme ( ce que je refuse a faire pour rester compatible).....

      Les test de regression sont une notion fondamentale de tout developpement...

      A+++
      Celui qui ferme sa porte aux erreurs la ferme aussi aux verites
      Un endroit à connaitre : www.madagascarnet.net
      info :www.iis-madagascar.com
      www.pagesjaunes-madagascar.com

      Commentaire


      • #4
        Envoyé par plgervais
        4.2.2 est a l'utilisation la meilleure version de mambo niveau stabilite.
        Question 1.0.3 et 4.2.3 les deux sont instables.
        La dernière version stable de Mambo est la 4.5.2.3 !!! La version 4.5.3 est une version alpha (même si elle est porte le nom de beta), ce n'est donc pas une version à utiliser pour un site normal !

        Joomla! 1.0.3 instable ? Ah bon ???

        Commentaire


        • #5
          @ plgervais :

          Idem, J 1.03 me parait plutôt très stable en fait. Ce qui est aussi logique, si l'on considère qu'il s'agit de mambo 4.5.2.3 auquel on a apporté quelques corrections de bugs et correctifs de sécurité ? par exemple, la gestion des sessions sur le B.E. a toujours posé des pb avec Mambo, alors que là ça à l'air de plutôt bien marcher.

          Ce qui peut poser pb, ça peut être certains composants, mais enfin ça à l'air d'être pas si mal que ça. Par exemple je viens de transférer un site qui utilise 404SEF, j'avais un peu peur, mais ça marche sans souçis. Idem pour mosCe par exemple pour parler des gros composants. Les composants qui ne modifient pas de fichiers de Mambo/Joomla ont l'air OK

          Pour les autres, comme Mambelfish, cela ne pose pas de pb non plus si l'on utilise le bon hack, celui de Joomla, au lieu de celui destiné à Mambo.

          Mais si tu as constaté des pb de stabilité, merci de m'indiquer où tu les as signalés (bug tracker ?), j'aimerais savoir dans quelles circonstances on rencontre ces pb avant de migrer d'autres sites vers J 1.0.3.

          Par avance merci
          Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

          Commentaire


          • #6
            Droit d'accès

            Hello
            Concernant la stabilité il n'y a pas de doute (j'espère)
            Par contre j'ai installé la 1.0.3 stable fr et mon (plutot mes) problèmes sont les suivants :
            No soucis pour l'install a part les mises en garde (normales) de l'installateur.
            Par contre après install, GROS soucis :
            Installation de modules, temlates, compsants, mod sans problèmes ... mais il ne faut pas avoir besoin de vouloir les "customiser", ce qui est mon cas !
            Et là .......... BIG BIG problème !!!!!!!!!!!!!
            IMPOSSIBLE de mettre quoique ce soit par FTP sur les répertoires créés par l'installateur de Joomla (erreur 550 par FTP !)
            Les droits créés sur le dossiers ne le permettent pas. (owner of directories is : APACHE) donc rien à faire ! même la suppression est impossible (par FTP ou depuis Joomla) !
            Install = oui mais extrèmement rigide aucune mise à jour possible
            Merci si quelqu'un à une réponse à ce problème (qui est important je trouve)
            ++
            Dernière édition par Bifrons à 06/11/2005, 20h43

            Commentaire


            • #7
              Oui c'est un pb important, dont on parle souvent. En fait, d'après ce que j'ai compris, le problème se trouve à l'origine dans la configuration de ton hébergeur, et l'installateur Joomla (c'était exactement la même chose avec Mambo FYI) ne parvient pas toujours à corriger ce problème.

              Pour info, tu as installé comment ? la voie normale, par FTP et procèdure d'installation ? ou bien installation automatique depuis le panneau de contrôle de ton hébergeur ?

              Les solutions que j'ai vues utilisées (je n'ai pas ce problème moi-même - je suis chez Céléonet !) :
              - demander à ton hébergeur de te rendre la propriété des fichiers
              - dans Joomla, Configuration générale du site / Onglet Serveur:

              dans Création de fichiers, mettre les droits à 777, puis faire Appliquer aux fichiers existants
              Faire de même pour la Création de répertoires

              Le fait de passer tous les droits à 777 te redonne accès à tous les fichiers, tu peux les modifier ou les effacer, bien que tu n'en sois pas le propriétaire.
              Le problème bien sur c'est qu'ils sont accessibles à tous le monde au passage.
              Donc une fois les modifs faites, il faut refaire la même manip en sens inverse, avec 644 pour les fichiers, et 755 pour les dossiers (sauf pour certains fichiers et dossiers particuliers, comme /images/stories ou les dossiers de téléchargements type Docman ou Remository, il doit y avoir également pas mal de cas particuliers).
              Tu peux aussi faire le changement de permissions (passage en 777) à partir de mamboexplorer je crois, puis revenir avec les permissions originales. Cela te permet d'être plus sélectif et de n'agir que sur les fichiers que tu veux modifier!

              Bon courage

              NB : il y a pas mal de posts à ce sujet en anglais sur Joomla.org
              Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X