comment activer les logs d'erreur chez 1&1

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #16
    Je n'ai pas fait attention aux divers noms de sites qui utilisent tes images. Celui sur lequel je suis arrivé vendait des sacs à main !

    Pour ce qui est des mails, la question qui m'a toujours ennuyée a été le sort de ceux qui arrivent au moment du changement de DNS et, en fonction de la propagation, peuvent arriver chez l'un ou l'autre des hébergeurs. Ce qu'il m'est donc arrivé de faire, c'est de faire une redirection chez l'hébergeur d'origine vers une adresse alternative. Il me semble qu'avec des modification de certains paramètres pour les serveurs de mail, on peut gérer plus simplement, mais je ne m'y suis pas vraiment intéressé.
    Lorsqu'on gère depuis un webmail, il faut à mon avis importer en IMAP les mails distants dans un logiciel type Outlook ou Thunderbird et ensuite changer les paramètres du serveur et du mot de passe (si on l'a changé) pour renvoyer les mails vers le webmail du nouvel hébergeur. C'est long...
    FlodAriege likes this.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #17
      Bonjour,

      Je viens encore de faire une batterie d'autres essais, consistant à :
      - supprimer les point-virgules du code indiqué par 1&1 (car je n'en voyais pas dans le php.ini "normal")
      - inclure ou pas "kunden" dans l'adresse absolue du fichier error.log
      - placer ou pas un fichier error.log vide à l'endroit indiqué dans le php.ini
      - modifier le php.ini inclus dans le dossier qui contient le site à la racine de l'hébergement pour y inclure les commandes conseillées par 1&1
      - ne mettre que error_reporting=E_ALL et non error_reporting = E_ALL | E_STRICT
      - placer le php.ini :
      /
      /dossiercontenantlesite (dans ce cas, c'est la version "enrichie" du php.ini "normal" qui est utilisée)
      /dossiercontenantlesite/aesecure
      - situer le error.log :
      /
      /dossiercontenantlesite

      .... et RIEN de tout cela n'a fonctionné....

      J'ai soumis le problème à l'assistance 1&1: je reviendrai ici vous donner la solution (si un jour je l'ai....)
      A moins que quelqu'un ici, un ou une expert-e ès PHP nous dise comment faire pour obtenir ce satané error.log quand on est hébergé chez 1&1.

      PS: pour moi il n'y a plus d'urgence, j'ai résolu autrement mon problème d'erreur 500.
      Flo, Ariège

      Il n'y a que celui qui a honte d'apprendre qui a peur de demander

      Commentaire


      • #18
        Bonjour

        Je t'avais proposé de m'envoyer les données de ton site afin que je puisse m'y connecter et jeter un oeil... je n'ai rien reçu.

        Super si tu as résolu le souci d'accès à l'interface (je serais curieux de savoir ce qui a été fait du coup).

        Bonne journée.
        Christophe (cavo789)
        Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
        Mes logiciels OpenSource : https://www.avonture.be

        Commentaire


        • #19
          Bonjour

          Envoyé par cavo789 Voir le message
          Je t'avais proposé de m'envoyer les données de ton site afin que je puisse m'y connecter et jeter un oeil... je n'ai rien reçu.
          Ah mince, je n'avais pas compris !!
          C'est vraiment super de ta part, rien ne t'oblige à proposer ça!
          Je ne pensais pas te demander ça tant que je n'avais complètement épuisé tous les autres recours possibles (mais là c'est vrai que j'étais bien arrivée au bout...)

          Envoyé par cavo789 Voir le message
          Super si tu as résolu le souci d'accès à l'interface (je serais curieux de savoir ce qui a été fait du coup).
          J'ai mis toutes les infos dans le post dédié mais les voici:

          L'adresse du fichier .htpasswd indiquée dans le .htaccess du dossier aesecure était obsolète (depuis le 16/12).
          Elle correspondait en effet à l'adresse qui était valable avant que je restaure (le 16/12) une sauvegarde sur un nouveau dossier dans mon hébergement, que j'ai exploité en sous-domaine pour mener des tests jusqu'à début avril.
          Le 7 avril, j'ai fait pointer mon domaine vers ce sous-domaine pour le mettre en production.
          J'accédais alors parfaitement bien à aesecure, puisque j'ai réglé quantité d'option ce jour-là et les suivants (et j'en ai pris note, ce qui me permet d'être affirmative et précise dans les dates).
          Puis j'ai perdu accès à l'interface, beaucoup plus récemment (27/04).

          J'ai corrigé l'adresse indiquée et tout est rentré dans l'ordre, mais je ne comprends pas comment l'interface a pu fonctionner entre le 16/12 et le 26/04, si l'adresse de ce fichier y était obsolète ??!
          C'est la toute première fois que j'accède au .htaccess de aeSecure (auquel je n'avais jamais osé toucher, d'ailleurs quand j'ai perdu l'accès j'ai mis plus de 10 jours avant de m'y résoudre).
          Je suis donc certaine à 100% de ne pas être à l'origine de ça.

          En fait j'ai constaté deux bizarreries dans mes fichiers après que mon site ait été mis hors ligne par mon hébergeur suite à une attaque (pas bien méchante l'attaque a priori, puisque c'était un envoi de spam depuis mon index.php) :
          # des lignes avaient disparu dans mon .htaccess (mais comme celui-là ça m'arrive de le modifier, j'ai pensé que j'avais fait une mauvaise manip [1] )
          # et donc, ce .htaccess du dossier aesecure qui était obsolète


          Bonne journée.

          [1] Détail des lignes qui avaient disparu :
          (642 et suivantes) :

          Code:
          #AESECURE_BLOCKROBOTSTXT_START
          #aeSecure 2.7
          <IfModule mod_rewrite.c>
           # Block curious who try to get access to the robots.txt file from an url.
           RewriteEngine On
           RewriteRule robots.txt$ /aesecure/setup.php?r=1 [L]
          </IfModule>
          qui s'était transformées en :

          Code:
          #AESECURE_BLOCKROBOTSTXT_STAR
          
          
          T
          ... comme si quelqu'un avait mis ses gros doigts sur le clavier sans faire du tout attention. Bizarre. Mais bon, rien ne me permet de dire que ce n'est pas moi qui ai fait ça, même si je trouve ça vraiment très surprenant. Disons que j'ai dû travailler trop tard un soir et m'endormir sur le htaccess.

          Flo, Ariège

          Il n'y a que celui qui a honte d'apprendre qui a peur de demander

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins

          Partenaire de l'association

          Réduire

          Hébergeur Web PlanetHoster
          Travaille ...
          X