Erreur 404 uniquement sous i.e 5 et 6

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Erreur 404 uniquement sous i.e 5 et 6

    Bonjour,

    J'ai une erreur 404 uniquement sous Joomla internet explorer 5 et 6.
    Le site marche très bien sous internet explorer 7 et 8 et sous Firefox et Safari.

    Je pensais que cela pouvais venir d'un module menu que j'ai installé pour ce site
    c'est : Lx menu mais quand je le désactive cela ne marche toujours pas sous i.e 5 et 6.
    Peut-être faut-il que je le désinstalle?

    Car tout mes autres sites marchent très bien sous tout les navigateurs!
    Et il n'y a que celui là qui me fait ça et c'est le seule ou j'ai installer ce menu!

    Ou peut-etre est-ce parce-que j'ai fait une mise à jour,
    de Joomla 1.5.x vers Joomla 1.5.22!

    Je vous remercie d'avance,
    Cordialement,
    Edith Bonamy

  • #2
    Malgré mon age avancé, je n'ai aucun souvenir de IE5 (bon c'est vrai aussi qu'avec l'age, la mémoire c'est plus forcément ça). Mais déja quand on sait que IE6 est sorti en même temps que Windows XP, on imagine bien que IE5 est vraiment un dinosaure.
    En tout cas, je ne pense pas que la mise à jour vers J! 1.5.22 soit en cause.
    Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
    C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
    Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

    Commentaire


    • #3
      Erreur 404 uniquement sous i.e 5 et 6

      Bonjour,

      Merci pour votre réponse.
      Je suis bien d'accord avec vous en ce qui concerne l'age de i.e 5 et 6! .
      Cependant cela reste important que le site puisse également fonctionné sous i.e 5 et 6.

      Cordialement,
      Edith Bnoamy

      Commentaire


      • #4
        Si seulement un ange pouvait m'aider!

        Merci d'avance,
        Edith

        Commentaire


        • #5
          Salut,

          Tu peux oublier ie5.5, plus aucun site n'est créé de nos jours en fonction de ce dinosaure (qui date de l'époque ou les navigateur étaient vendus en boîte en magasin... c'est à dire la préhistoire).

          IE6 effectivement c'est plus problématique (même si c'est aussi un dinosaure). Tu peux donner l'adresse du site ?

          Commentaire


          • #6
            Ah un ange!

            Bonjour kursus,

            Merci pour ton intérêt.
            Voici l'adresse du site http://web-redac.com/
            Je trouve cela vraiment bizarre car si il ne fonctionne pas sous i.e 6 il ne devrait pas fonctionner sous i.e7 et 8 ?

            J'espère que tu pourras me sauver de ce cauchemars!

            Commentaire


            • #7
              Essaye d'éditer ton index.php et de supprimer les lignes

              <!--[if lt IE 7]>
              <script type="text/javascript">
              document.location.href='IEURL';
              </script>
              <![endif]-->

              Commentaire


              • #8
                Bonjour,

                Possible de désactiver temporairement tous les paramètres SEO ??

                Cordialement,
                Joël

                Commentaire


                • #9
                  Bonjour Jovdev et Kursus,

                  J'ai dans un premier temps désactiver les paramètres SEO mais j'ai toujours le même problème.
                  Ils sont encore désactivés afin que vous puissiez voir!
                  Je vais essayer en supprimant ces lignes:

                  <!--[if lt IE 7]>
                  <script type="text/javascript">
                  document.location.href='IEURL';
                  </script>
                  <![endif]-->

                  Cordialement,
                  Edith

                  Commentaire


                  • #10
                    Bonjour Kursus,

                    Je n'arrive pas à voir ou ce trouve cette ligne de code dans mon fichier index.php
                    Pourrais-tu me donner la numéro de la ligne?

                    <!--[if lt IE 7]>
                    <script type="text/javascript">
                    document.location.href='IEURL';
                    </script>
                    <![endif]-->

                    Merci d'avance,
                    Edith

                    Commentaire


                    • #11
                      Edition > rechercher > document.location.href='IEURL';

                      devrait suffire.

                      Commentaire


                      • #12
                        Erreur 404 uniquement sous i.e 5 et 6

                        Est-ce que je peux t'envoyer mon fichier index.php en pièce jointe directement via ton adresse mail car le site ne prend pas ce type de fichier on dirait et que
                        je ne trouve pas non plus en mode recherche!

                        Merci d'avance et de ton intérêt!

                        Commentaire


                        • #13
                          Ok poste le !

                          Commentaire


                          • #14
                            <?php echo '<?xml version="1.0" encoding="utf-8"?'.'>'; ?>
                            <?php defined( '_JEXEC') or die( 'Direct Access to this location is not allowed.' ); ?>
                            <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>"
                            lang="<?php echo $this->language; ?>" dir="<?php echo $this->direction; ?>">
                            <head>
                            <link rel="stylesheet" href="templates/<?php echo $this->template ?>/css/template_css.css" type="text/css" />
                            <jdoc:include type="head" />
                            <script type="text/javascript">

                            function MM_reloadPage(init) { //reloads the window if Nav4 resized
                            if (init==true) with (navigator) {if ((appName=="Netscape")&&(parseInt(appVersion)==4)) {
                            document.MM_pgW=innerWidth; document.MM_pgH=innerHeight; onresize=MM_reloadPage; }}
                            else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH) location.reload();
                            }
                            MM_reloadPage(true);

                            </script>

                            <title>web-redac</title>

                            <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
                            <link href="css/template_css.css" rel="stylesheet" type="text/css">

                            <?php
                            if(file_exists($mosConfig_absolute_path."/modules/mod_lxmenu/css_lxmenu.css")){
                            ?>
                            <link href="<?php echo $mosConfig_live_site; ?>/modules/mod_lxmenu/css_lxmenu.css" rel="stylesheet" type="text/css"/>
                            <?php
                            }
                            ?>


                            </head>
                            <body bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">

                            <table width="840" height="541" border="0" align="center" cellpadding="0" cellspacing="0" id="Tableau_01">
                            <tr>
                            <td colspan="8" class="bordhaut">&nbsp;</td>
                            </tr>
                            <div id="menuprincipal">
                            <tr>
                            <td rowspan="7" class="bordgauche">&nbsp;</td>
                            <td class="logo"><jdoc:include type="modules" name="logo"/></td>
                            <td colspan="2" class="espacedroit_logo">&nbsp;</td>
                            <td colspan="3" class="menuprincipal"><jdoc:include type="modules" name="top"/></td></div>
                            <td rowspan="7" class="borddroit">&nbsp;</td>
                            </tr>
                            <tr>
                            <td colspan="6" class="espacebas_logomenu">&nbsp;</td>
                            </tr>
                            <tr>
                            <td class="user1"><jdoc:include type="modules" name="user1"/></td>
                            <td rowspan="4" class="espacedroitusers">&nbsp;</td>
                            <td colspan="4" rowspan="3" align="left" valign="top" class="corpdepage"><jdoc:include type="component" /><jdoc:include type="message" /></td>
                            </tr>
                            <tr>
                            <td class="user2"><jdoc:include type="modules" name="user2"/></td>
                            </tr>
                            <tr>
                            <td align="center" valign="middle" class="user3"><jdoc:include type="modules" name="user3"/></td>
                            </tr>
                            <tr>
                            <td class="user4"><jdoc:include type="modules" name="user4"/></td>
                            <td colspan="2" class="user5"><jdoc:include type="modules" name="user5"/></td>
                            <td class="menubas"><jdoc:include type="modules" name="menubas"/></td>
                            <td class="lienlogo"><jdoc:include type="modules" name="lienlogo"/></td>
                            </tr>
                            <tr>
                            <td colspan="6" class="bordbas">&nbsp;</td>
                            </tr>
                            <tr>
                            <td>
                            <img src="images/spacer.gif" width="27" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="242" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="19" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="1" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="56" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="382" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="83" height="1" alt=""></td>
                            <td>
                            <img src="images/spacer.gif" width="30" height="1" alt=""></td>
                            </tr>
                            </table>
                            <!-- End Save for Web Slices -->
                            </body>
                            </html>

                            Commentaire


                            • #15
                              Bon effectivement ça n'apparaît pas, c'est sûrement un plugin qui rajoute le code. Tu as installé quelque chose en rapport avec la compatibilité navigateurs ?

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X