Traduction pour Joomla! 4

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #16
    Non, hélas, la traduction semble toujours en cause dans la mesure où je n'ai pas eu de problèmes avec le pack néerlandais. Le problème n'est donc pas réglé pour moi.

    Il serait bon que d'autres fassent à leur tour des tests avec ces versions de la 4 et de la traduction française avec Akeeba backup et d'autres extensions aussi.
    La proposition de JM de réutiliser les fichiers localise.php de la version 3 m'a semblé régler le problème, mais il faudrait multiplier les tests.
    J'ai reproduit après installation et utilisation de LazyDbBackup et de LDBchecker, mais une fois ces extensions désactivées, le problème a persisté, il m'a fallu les désinstaller pour retrouver un affichage normal, tout comme ça a été le cas avec Akeeba backup.

    Ah non, je viens de vérifier les infos système puis de revenir sur le panneau d'administration, et de nouveau il est désorganisé (J! 4 beta 8 dev de ce matin, pack FR d'hier soir, PHP 8, aucune extension ) !
    Dernière édition par RobertG à 10/05/2021, 12h48
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #17
      Envoyé par RobertG Voir le message
      Non, hélas, la traduction semble toujours en cause dans la mesure où je n'ai pas eu de problèmes avec le pack néerlandais. Le problème n'est donc pas réglé pour moi.
      Une petite question pour mieux comprendre. Tu dis que la version néerlandaise ne pose pas de problème mais tu as exactement les mêmes conditions ?

      C'est juste que si tu active la version française et que tu utilise une traduction française de composant tiers comme akeeba qui n'est pas correct sous joomla 4, alors le problème ne vient pas du travail de traduction des fichiers core de joomla 4 mais de la traduction d'akeeba (qui n'est plus géré par son auteur). Quand tu teste avec la version néerlandaise, tu utilise également la traduction d'akeeba en néerlandais ? elle est disponible sous joomla 4 ?

      C'est juste pour chercher au bon endroit ! De plus, tant que la version de joomla est en beta, il est difficile de faire des tests approfondis.
      Logiquement, il faudrait tester en indiquant si cela fonctionne uniquement sans la traduction des extensions tout simplement.

      Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

      Commentaire


      • #18
        Mes premiers essais (serveur Premium Performance Nuxit, PHP 8) ont été en effet avec des extensions, dont Akeeba backup, avec leur traduction : beta 4 beta 8 dev + pack de langue francophone datant de la semaine dernière + Akeeba backup puis LazyDbBackup et LDBchecker. Si je laisse l'administration en anglais, tout fonctionne correctement. Si j'active le français, le panneau d'administration se désorganise. J'installe le pack néerlandais pour cette version 4, je définis la langue comme étant celle par défaut et je navigue : le panneau d'administration s'affiche correctement.

        J'ai recommencé ce matin avec un tout nouveau site, en n'installant que la version pro d'Akeeba backup sans son pack de langue française et j'ai reproduit l'anomalie d'affichage.
        J'ai ensuite recommencé de zéro avec seulement l'installation de LazyDbBackup et LDBchecker (avec leur fichiers de langue française) et le phénomène est réapparu. Et même leur désinstallation ne ramène pas à la normale le panneau d'administration.

        Je rappelle que ça ne semble se produire qu'avec PHP 8. A l'instant, j'étais donc sur le site comportant uniquement le noyau et le pack francophone, mais avec le panneau anormal, malgré la désinstallation des extensions. Je suis alors revenu en PHP 7.4 et le panneau s'affiche correctement. Je repasse en PHP 8 et l'erreur réapparaît.
        J'installe le pack néerlandais, je change l'administration pour cette langue et le panneau d'administration redevient correct.
        J'installe le pack Akeeba backup, RAS ; je le paramètre, je fais une sauvegarde, je reviens au panneau d'administration, il s'affiche correctement. Je remets l'administration en français et rebelote.
        Je reviens en PHP 7.4 et les choses rentrent dans l'ordre.

        J'en conclus donc provisoirement que le phénomène est lié au pack francophone ET à PHP 8. Maintenant, je ne sais pas pourquoi ce problème n'est apparu qu'après installation d'extensions. Il faudrait que je recommence sans extensions, en passant par diverses pages avant de revenir sur ce panneau.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #19
          Hello RobertG,
          Attention, les modifications faites dans Crowdin ne sont pas immédiatement disponibles en téléchargement, la mise à jour du pack téléchargeable se fait uniquement 2 ou 3 fois par jour sauf erreur... Il est donc possible que celui que tu as téléchargé hier soir était toujours celui qui te posait problème.

          Après 2 soirées de dures labeurs, je viens enfin de finir les adaptations et validations des dernières chaînes des fichiers langue FR de la version J4.
          Je vais faire des tests demain soir sur PHP 8 sur un autre serveur après avoir laissé le temps à Crowdin de mettre à jour du pack téléchargeable, la version de J4 que j'utilise pour mes tests avec les fichiers chargés dans le site directement depuis Crowdin grâce au plugin spéciale est sur un serveur qui a d'autres sites, je ne vais donc pas le passer en PHP 8 au risque de provoquer des erreurs.

          Questions
          Quand tu actives le débogage de langue, vois-tu un signalement d'erreur sur la page d'accueil de l'admin ?
          As-tu ressayé avec le fichier localise.php de J3 pour voir si cela corrige l'erreur ? Si oui il suffit de regarder ce qu'il y a de différent dans ce fichier.

          Peux-tu me dire où tu télécharge ce que tu dis être la dernière version à jour de la traduction FR d'Akeeba Backup ? Comme le dit Daneel, Nicolas l'auteur a malheureusement cessé il y a longtemps déjà de réceptionner les packs de langue et je n'ai pas pu mettre à jour celui qui est encore dispo sur son site.

          PS : j'avais repéré hier soir cette mauvaise traduction "Remplacer les fichiers" que j'avais validée car non vue dans son contexte, ce qui semble confirmer que le pack que tu as téléchargé n'avait pas encore été mis à jour
          Dernière édition par sarki à 11/05/2021, 00h51
          Communauté Suisse-Romande : www.joomlaromand.ch
          Support FR de l'éditeur JCE : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

          Commentaire


          • #20
            Encore une dernière chose par rapport à ta remarque sur les pluriels :
            Je dois dire que je n'ai rien compris à cette gestion "plural" : https://github.com/joomla/joomla-cms/pull/29029
            Des chaînes ont en effet été modifiées dans des fichiers à cause de cela, j'ai encore fait des corrections à ce sujet, mais je doute que ce soit cela qui peut créer cette désorganisation qui semble plus lié à une erreur JavaScript ou CSS

            Des erreurs qui se créent après des actions sur le site j'ai également vu ça récemment avec JCE, mais je n'ai pas réussi à trouver la source et la dernière mise à jour a corriger le problème.
            Communauté Suisse-Romande : www.joomlaromand.ch
            Support FR de l'éditeur JCE : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

            Commentaire


            • #21
              Bon, j'ai installé cette beta 8 sur un autre serveur et je confirme le problème, tout est ok avec PHP 7 et ça bogue avec PHP 8
              Après différents tests dont le remplacement du localise.php de J3 qui ne résout rien je vais m'arrêter pour aujourd'hui, l'heure d'aller dormir un moment
              Je vais au moins pouvoir chercher de mon côté...
              En réinstallant la BD j'avais la même erreur, puis j'ai vu que j'avais encore le fichier d'Akeeba dans le cache, en le supprimant cela refonctionnait, je me suis donc dit que cela venait de ce fichier en cache, mais après réinstallation d'Akeeba et un nouveau backup j'avais de nouveau le problème, et je n'ai pas pu le résoudre en supprimant le nouveau fichier mis en cache...
              Je tacherai de faire de nouveaux tests d'ici la fin de la semaine, je ne vais pas pouvoir regarder cela avant.
              Communauté Suisse-Romande : www.joomlaromand.ch
              Support FR de l'éditeur JCE : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

              Commentaire


              • #22
                Envoyé par sarki Voir le message
                Questions
                Quand tu actives le débogage de langue, vois-tu un signalement d'erreur sur la page d'accueil de l'admin ?
                As-tu ressayé avec le fichier localise.php de J3 pour voir si cela corrige l'erreur ? Si oui il suffit de regarder ce qu'il y a de différent dans ce fichier.

                Peux-tu me dire où tu télécharge ce que tu dis être la dernière version à jour de la traduction FR d'Akeeba Backup ? Comme le dit Daneel, Nicolas l'auteur a malheureusement cessé il y a longtemps déjà de réceptionner les packs de langue et je n'ai pas pu mettre à jour celui qui est encore dispo sur son site.

                PS : j'avais repéré hier soir cette mauvaise traduction "Remplacer les fichiers" que j'avais validée car non vue dans son contexte, ce qui semble confirmer que le pack que tu as téléchargé n'avait pas encore été mis à jour
                OK Mihàli pour les mises à jour Crowdin. Ce décalage est gênant pour qui veut tester.

                La seule erreur sur les fichiers que m'a signalée le site, je l'ai signalée plus haut (message 5).

                Je ne crois pas avoir parlé de dernière version de la traduction d'Akeeba backup, la mienne date de longtemps et ces tests (sauf les deux premiers) ne l'ont plus utilisée, on ne peut donc pas l'incriminer. Il y a en effet bien longtemps que je n'ai plus trouvé de traductions cautionnées par Nicolas. Celle que j'utilise en version 3 est une version récupérée en janvier 2020 sur le site joomlatranslate.com et que j'ai eu la flemme de corriger.

                Ce que je pense au vu du message d'erreur, c'est qu'en PHP 7.4 soit le tableau revenant vide est toléré, soit il ne revient pas vide, alors qu'en PHP 8 il revient systématiquement vide et ne peut donc pas être interprété
                array_unshift(): Argument #1 ($array) must be of type array, null given
                J'ai eu des erreurs similaires bien que non bloquantes avec des variables de LDBchecker, lorsque sous PHP 8 je tentais d'interroger le dossier de stockage des sauvegardes de la base pour connaître la date de la dernière et qu'il n'y en avait pas encore, m'obligeant à gérer cette situation, alors que PHP 7.x ignorait l'erreur.

                Je suis reparti ce matin d'un site neuf avec nouvelle récupération du pack de langue.
                Je confirme que l'utilisation de localise.php de la 3 n'a pas d'effet, mon erreur l'autre soir venait du fait que je testais sur du PHP 7.4 (sans pouvoir changer la version à cause d'autres sites sur le même serveur).

                Le débogage de langue sur la page du paneau d'administration me signale ces erreurs (les deux dont j'ai parlé plu haut plus celle du fichier update)
                • /administrator/language/fr-FR/plg_quickicon_phpversioncheck.ini:14
                • /administrator/language/fr-FR/plg_quickicon_phpversioncheck.ini:16
                • /administrator/language/fr-FR/plg_sampledata_blog.ini:13
                • /administrator/language/fr-FR/plg_sampledata_blog.ini:14
                • /administrator/language/fr-FR/com_joomlaupdate.ini:58
                • /administrator/language/fr-FR/com_joomlaupdate.ini:60
                • /administrator/language/fr-FR/com_joomlaupdate.ini:64
                • /administrator/language/fr-FR/com_joomlaupdate.ini:66
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire


                • #23
                  Me demandant pourquoi seul le panneau d'administration était concerné, je suis allé voir les modules : en désactivant celui proposant l'installation des exemples, les choses sont rentrées dans l'ordre.
                  Reste donc à trouver ce qui, dans ce module ou plutôt dans les fichiers d'exemples, déclenche l'erreur en PHP 8.

                  Complément : lorsque l'inspecteur de Firefox est activé, j'ai dans la console (en anglais comme en français) ces erreurs sur la page du panneau d'administration lorsque le module d'installation des exemples est activé :
                  Error: Promised response from onMessage listener went out of scope content.js:118:22

                  Error: Promised response from onMessage listener went out of scope 2 network.js:842:2
                  En français, il y a en plus le rapport de l'erreur 500.

                  Après réactivation, puis désactivation du module d'installation d'exemples, malgré le vidage du cache, le pa,,eau restait désorganisé. J'ai dû désactiver et réactiver les modules "latest actions" et "privacy dashboard" pour retrouver un panneau normal !
                  Dernière édition par RobertG à 11/05/2021, 09h51
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                  MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                  Commentaire


                  • #24
                    Bon, eh bien ça ne semble pas avoir de rapport seulement avec ce module d'exemples. Réactivé, si le anneau est désorganisé, il me suffit par exemple de désactiver le module "latest actions" pour retrouver un panneau correct, et sa réactivation ne désorganise pas de nouveau !
                    Très curieux, ce phénomène !
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                    Commentaire


                    • #25
                      Merci pour ces informations complètes, je vais continuer progressivement à corriger les fichiers langues en analysant progressivement l'ensemble et les sites exemples.
                      Certaines données ont été récupérées de la version J3 et il se peut qu'elles ne soient pas compatibles avec la version J4.
                      Toutefois ce bogue que tu as remonté est surprenant en effet, je vais encore vérifier que les fichiers langue ne contiennent aucune erreur susceptible de les provoquer, puis je remonterai l'erreur. Je le ferai de toute façon car il se peut qu'elle se produise avec d'autres langue.
                      @+
                      Communauté Suisse-Romande : www.joomlaromand.ch
                      Support FR de l'éditeur JCE : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

                      Commentaire


                      • #26
                        J'ai corrigé les erreurs que tu as signalé sur les fichiers langue, ce n'était que des sauts de ligne inutiles qui les provoquaient, mais malheureusement cela ne corrige pas le bogue, cela corrige par contre les erreurs qui se signalaient dans le module "Latest Actions" donc c'est déjà une bonne chose.
                        Je vais prendre le temps demain de remonter l'erreur.
                        Merci encore pour ton signalement
                        Communauté Suisse-Romande : www.joomlaromand.ch
                        Support FR de l'éditeur JCE : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

                        Commentaire


                        • #27
                          Merci à toi !
                          Ce que j'ai constaté en continuant à bosser sur ce site test, c'est que lorsque le panneau se désorganisait, il me suffisait de désactiver un module d'administration, latest action comme je l'ai dit, mais il me semble aussi avoir corrigé en le faisant avec privacy et celui des exemples, il faudrait que je réessaie.
                          Je ne sais pas ce que cette désactivation peut avoir comme impact sur cette erreur pour la corriger !
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                          Commentaire


                          • #28
                            localise.php dans le paquet 4.0 est incomplet.
                            Il lui manque
                            Code:
                            else
                            {
                            return array('OTHER', 'MORE');
                            }
                            Jean-Marie Simonet / infograf768
                            Joomla co-fondateur. Joomla Production Working Group.
                            Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                            Commentaire


                            • #29
                              Avant de le modifier on a

                              Cliquez sur l'image pour l'afficher en taille normale

Nom : Screen Shot 2021-05-20 at 11.35.29.png 
Affichages : 136 
Taille : 182,9 Ko 
ID : 2027417

                              Après modification on a
                              Cliquez sur l'image pour l'afficher en taille normale

Nom : Screen Shot 2021-05-20 at 11.35.43.png 
Affichages : 132 
Taille : 155,4 Ko 
ID : 2027418

                              Jean-Marie Simonet / infograf768
                              Joomla co-fondateur. Joomla Production Working Group.
                              Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                              Commentaire


                              • #30
                                Merci JM !
                                Avec cette correction, j'ai quand même de nouveau l'affichage incorrect, il suffit que je désactive un module d'administration pour que le problème réapparaisse.
                                Par exemple, je désactive sample data, l'affichage est incorrect ; je le réactive, l'erreur disparaît !
                                Au cas où j'aurais fait une erreur en ajoutant le code que tu cites, j'ai carrément remplacé la fonction par celle de la version anglaise, sans succès.
                                Il faut absolument que je réactive un module d'administration pour que l'affichage revienne à la normale.
                                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                                Commentaire

                                Annonce

                                Réduire
                                1 sur 2 < >

                                C'est [Réglé] et on n'en parle plus ?

                                A quoi ça sert ?
                                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                                Comment ajouter la mention [Réglé] à votre discussion ?
                                1 - Aller sur votre discussion et éditer votre premier message :


                                2 - Cliquer sur la liste déroulante Préfixe.

                                3 - Choisir le préfixe [Réglé].


                                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                                2 sur 2 < >

                                Assistance au forum - Outil de publication d'infos de votre site

                                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                                UTILISER À VOS PROPRES RISQUES :
                                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                                Problèmes connus :
                                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                                Installation :

                                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                                et remplacer www. votresite .com par votre nom de domaine


                                Exemples:
                                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                                Télécharger le script fpa-fr.php dans: /public_html/
                                Pour executer le script: http://www..com/fpa-fr.php

                                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                                Télécharger le script fpa-fr.php dans: /public_html/cms/
                                Pour executer le script: http://www..com/cms/fpa-fr.php

                                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                                Voir plus
                                Voir moins

                                Partenaire de l'association

                                Réduire

                                Hébergeur Web PlanetHoster
                                Travaille ...
                                X