Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Accès back-end impossible - Avertissement PHP

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Accès back-end impossible - Avertissement PHP

    Bonjour,
    J’ai un site qui me donne des soucis, depuis quelque temps je n'ai plus accès au back-end et j'ai ce message d’erreur:

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/toukoul6/public_html/libraries/cms.php on line 59
    Error displaying the error page: Application Instantiation Error: Failed to start the session because headers have already been sent by "/home/toukoul6/public_html/libraries/cms.php" at line 59.


    À titre d’information le site est en PHP 7.x et l’accès en front-end se fait correctement.

    J’ai pu remarquer que si je repasse le site en PHP 5.6.x, l’avertissement disparaît et l’accès au back-end se fait à nouveau.

    Avez-vous une idée de quoi peut-il s’agir? J’ai lu certains articles à ce sujet sans jamais en venir à bout.

    Une piste à me donner?

    Merci
    Dernière édition par porcini à 29/10/2017, 16h56

  • #2
    Pour savoir ce qui provoque l'erreur (une extension non compatible PHP 7), repasse en 5.6 et active le débogage.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      ...merci Robert... alors en activant le débogage je reçois cet autre type de message:


      Warning: array_key_exists() expects parameter 2 to be array, null given in /home/toukoul6/public_html/libraries/cms.php on line 59

      Notice: Undefined variable: _SERVER in /home/toukoul6/public_html/libraries/joomla/application/web.php on line 1172
      Error displaying the error page: Application Instantiation Error: Failed to start the session because headers have already been sent by "/home/toukoul6/public_html/libraries/cms.php" at line 59.
      Notice: Undefined variable: _SERVER in /var/lib/sec/prepend.php on line 59


      ... ce qui me laisse perplexe c'est que le même site est dans un sous-domaine en PHP 7 ( c'est une réplique du site pour des test) et je n'ai aucun problème à me connecter au back-end
      Dernière édition par porcini à 29/10/2017, 17h45

      Commentaire


      • #4
        ... aucune idée?

        Commentaire


        • #5
          Reste en débogage activé et repasse en PHP 7 : s'il y a une erreur fatale, tu devrais avoir à l'écran la série d'actions qui l'ont précédé, ce qui devrait permettre de savoir ce qui bloque.
          A l'inverse, tente de passer error_reporting à "none" dans le fichier configuration.php pour voir si le masquage des erreurs a un effet positif.
          Ce qui m'étonne, c'est que tu ne vois que des "warning" et "notice" qui en principe n'empêchent pas les pages de s'afficher.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            ... rien à faire, j'ai toujours ces messages qui empêchent l'affichage du back-end

            J'étais tombé sur ce post il y a quelque temps, je viens de le retrouver... on parle de problème de cache (OpCache) ... une idée à ce sujet? Merci.
            joomla-cms - Home of the Joomla! Content Management System

            Commentaire


            • #7
              Bonjour,

              Que contient votre répertoire librairies/cms ? en version 3.8.x, il a uniquement 3 répertoires class,html et less. Est-ce le cas chez vous ?

              Pascal
              If anything can go wrong, it will...
              If I can help, I will ..https://conseilgouz.com

              Commentaire


              • #8
                Bonjour... oui en effet, mais pour ce site je suis encore en 3.7.5 et dans ce cas j'ai toute une série de dossiers dans le répertoire librairies/cms .... est-ce que le problème viendrait de là? ... mais alors je devrais avoir ce même problème sur d'autres sites ...

                Commentaire


                • #9
                  Bonjour,

                  J'assumais que vous étiez passé en 3.8. Dans cette version, il y a eu pas mal de "nettoyage" dans le répertoire librairies/cms pour se préparer à Joomla 4.0. Dans certains cas, le "nettoyage" est incomplet et des fichiers version 3.7 restent...

                  En version 3.7.5, le répertoire librairies/cms contient effectivement toutes les classes.

                  Quant au problème signalé sur github, avez-vous essayé les suggestions woluweb en désactivant opcache ?

                  Pascal
                  If anything can go wrong, it will...
                  If I can help, I will ..https://conseilgouz.com

                  Commentaire


                  • #10
                    Bonjour et merci pour le suivi... je viens de passer à la version 3.8.1, mais hélas le problème est toujours là... je vais contacter Marc (woluweb) et voir s'il a une piste à me donner (>

                    Commentaire


                    • #11
                      Bonjour, alors j'ai contacté Marc et il suffit d'effacer le dossier .opcache qui se trouve à la racine de l'hébergement (1 niveau plus haut que le dossier public html). Personnellement je l'ai renommé et ça marche aussi
                      woluweb likes this.

                      Commentaire

                      Travaille ...
                      X