Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

restauration akeeba non fonctionnelle

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] restauration akeeba non fonctionnelle

    Bonjour,
    J'ai fait une sauvegarde de mon site joomla (version 3.7.3) en local à l'aide de akeeba backup core 5.4.0.
    J'ai mis cette sauvegarde *.jpa sur une clé usb puis je l'ai copié sur le dossier de mon site de développement sur un autre PC avec son serveur en local.
    Les deux PC utilisent wampserver.
    J'ai ensuite décompressé à l'aide de kickstart core 5.3.1. puis fait l'installation.

    Toutes ces étapes se sont déroulées sans indication d'erreur. (Il a fallu exclure les répertoires tmp et cache à la sauvegarde pour pouvoir ensuite décompresser)

    En frontend de mon site restauré j'ai des tableaux concernant plusieurs lignes :

    Notice: Array to string conversion in C:\wamp64\www\hs2e\templates\protostar\error.php on line 124

    Et en backend : 0 syntax error, unexpected 'SELECT_FY_d6ca5ee73' (T_STRING), expecting ')'
    quelque soit le lien de menu cliqué.

    Bref je ne sais pas comment résoudre ce problème. Pouvez-vous m'aider ?

    Merci

  • #2
    Re : restauration akeeba non fonctionnelle

    Utilises-tu la même version de PHP sur les deux PC ?
    Modifie ton fichier configuration.php pour passer debug à "1" et error_reporting à "development", pour essayer de faire apparaître la cause de l’erreur.
    A voir la ligne concernée, ce serait un module en position 1, ce qui m'orienterait vers une incompatibilité entre un module et la version de PHP, mais ce n'est qu'une supposition.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Re : restauration akeeba non fonctionnelle

      Bonjour, je vous remercie pour votre aide.
      Ci-dessous ce que j'obtiens après application de vos consignes. Pour moi c'est du chinois...

      0 syntax error, unexpected 'SELECT_FY_d6ca5ee73' (T_STRING), expecting ')'
      Call stack
      # Function Location
      1 () JROOT\components\com_comprofiler\plugin\language\f r-fr\language.php:1377
      2 CBLib\Language\CBTxt::import() JROOT\libraries\CBLib\CB\Legacy\LegacyFoundationFu nctions.php:287
      3 cbimport() JROOT\libraries\CBLib\CB\Legacy\LegacyFoundationFu nctions.php:314
      4 cbimport() JROOT\modules\mod_cblogin\mod_cblogin.php:19
      5 include() JROOT\libraries\cms\module\helper.php:198
      6 JModuleHelper::renderModule() JROOT\libraries\joomla\document\renderer\html\modu le.php:93
      7 JDocumentRendererHtmlModule->render() JROOT\libraries\joomla\document\renderer\html\modu les.php:42
      8 JDocumentRendererHtmlModules->render() JROOT\libraries\joomla\document\html.php:486
      9 JDocumentHtml->getBuffer() JROOT\libraries\joomla\document\html.php:777
      10 JDocumentHtml->_renderTemplate() JROOT\libraries\joomla\document\html.php:552
      11 JDocumentHtml->render() JROOT\libraries\cms\application\cms.php:1116
      12 JApplicationCms->render() JROOT\libraries\cms\application\site.php:777
      13 JApplicationSite->render() JROOT\libraries\cms\application\cms.php:271
      14 JApplicationCms->execute() JROOT\index.php:49

      Commentaire


      • #4
        Re : restauration akeeba non fonctionnelle

        Si je lis bien, il y a un problème avec Community Builder. As-tu vérifié la version de PHP sur le nouvel ordinateur ?
        Chez Joomlapolis, on parle d'avoir testé sous PHP 7, mais pas sûr, si tu es en PHP 7.1, que ce soit compatible.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Re : restauration akeeba non fonctionnelle

          J'ai la version 5.6.25 pour le PC sauvegardé et la version 7.0.10 sur le PC restauré.
          Je vais repassé en version 7.0.10 sur le pc a sauvegardé et je retente une sauvegarde/restauration.

          Je vous tiens au courant.
          En tout cas merci pour votre aide et chapeau pour votre analyse

          Commentaire


          • #6
            Re : restauration akeeba non fonctionnelle

            Bon, je n'arrive plus à décompresser. Je suis repassé en 7.0.10 sur le PC à sauvegarder.
            Je fais ma sauvegarde, il n'y a pas de message d'erreur.
            Puis lorsque je décompresse sur le PC de restauration j'ai une erreur à 1/3 de la décompression (voir pièce jointe) :

            Commentaire


            • #7
              Re : restauration akeeba non fonctionnelle

              On ne voit pas la pièce jointe, il faut passer en mode avancé de l'éditeur pour l'insérer.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire


              • #8
                Re : restauration akeeba non fonctionnelle

                Le screen shot ci-dessous

                Cliquez sur l'image pour l'afficher en taille normale

Nom : erreur decompression.jpg 
Affichages : 1 
Taille : 27,4 Ko 
ID : 1806331

                Commentaire


                • #9
                  Re : restauration akeeba non fonctionnelle

                  Peux-tu refaire une sauvegarde sur le premier PC ?
                  Sinon, tu peux utiliser Akeeba Extract Wizard pour décompresser ton jpa et voir si c'est ton fichier de sauvegarde qui a un problème ou pas.
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                  Commentaire


                  • #10
                    Re : restauration akeeba non fonctionnelle

                    Bonjour,
                    J'ai fait une nouvelle sauvegarde que j'ai décompressé avec wizard. J'ai l'erreur "caractère non conforme dans le chemin d'accès". Il y a donc bien un problème avec la sauvegarde.
                    Pour valider la cause de problème, j'ai fait une restauration en local d'une autre archive jpa récupérée sur le net et cela fonctionne.
                    Y a-t-il quelque chose à paramétrer avant de faire une sauvegarde ?

                    Cliquez sur l'image pour l'afficher en taille normale

Nom : erreur decompression2.jpg 
Affichages : 1 
Taille : 34,6 Ko 
ID : 1806332

                    Commentaire


                    • #11
                      Re : restauration akeeba non fonctionnelle

                      Le message signale une incompatibilité sur un nom de dossier, probablement, dans le site d'origine : à toi de trouver lequel et de voir si tu peux corriger sans que le site se mette en erreur.
                      C'est sûrement ça qui empêchait la décompression par kickstart.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                      Commentaire


                      • #12
                        Re : restauration akeeba non fonctionnelle

                        Merci pour votre réponse. Bon je ne suis pas un as et je n'ai rien trouvé.
                        J'ai fait une autre sauvegarde et cette fois en zip. A la décompression voila les erreurs. Au vu des messages il doit y avoir autre chose qu'un nom de dossier ?
                        Cliquez sur l'image pour l'afficher en taille normale

Nom : erreur decompression3.jpg 
Affichages : 1 
Taille : 49,5 Ko 
ID : 1806333

                        Commentaire


                        • #13
                          Re : restauration akeeba non fonctionnelle

                          Étonnantes ces erreurs !
                          Tu peux essayer de copier le dossier non compressé sur une clé USB pour le transporter sur le nouveau PC et exporter/importer la base avec phpMyAdmin, puis corriger les infos de base de données et de chemins logs et tmp, éventuellement avec MoovJla.
                          Mais rien ne dit que tu n'auras pas ensuite de nouveaux soucis de sauvegarde...
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                          Commentaire


                          • #14
                            Re : restauration akeeba non fonctionnelle

                            Bonjour,
                            Merci RobertG pour ton aide. J'ai profité des vacances pour faire une installation "neuve" du site d'origine et Akeeba fonctionne correctement désormais.

                            Commentaire

                            Travaille ...
                            X