SSO - LDAP joomla 2.5

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • SSO - LDAP joomla 2.5

    Bonjour,

    Juste pour information j'ai trouvé tout ce qui me fallait pour gérer l'authentification de mes users depuis un "Active Directory" sur le site suivant :

    http://shmanic.com/tools/jmapmyldap/download.htm

    j'ai utilisé les librairies/plugins suivants :
    lib_jssomysite
    plg_system_jssomysite
    pkg_jssomysite_plugins
    plg_authentication_jmapmyldap
    plg_autologin.1.7.1
    plg_sso_http
    lib_jmapmyldap
    plg_user_jmapmyldap

    tout semble fonctionner correctement, la synchronisation des utilisateur n'est pas automatique, il faut qu'ils passent une première fois sur le site pour que leur compte soit activé.

    Enjoy
    zwaldo

  • #2
    Re : SSO - LDAP joomla 2.5

    Ton test m'intéresse ... par contre vu le résultat qui a-t-il de plus que le plugins natif dans Joomla ?
    Règlement du forum : http://forum.joomla.fr/faq.php
    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
    http://www.iwannaclick.org

    Commentaire


    • #3
      Re : SSO - LDAP joomla 2.5

      Bonjour,


      L'authentification automatique de mes users ne s'applique pas avec Authentification - LDAP :
      - Authentification - LDAP require une requete de recherche du type -> (sAMAccountName=[search])
      - Authentication - JMapMyLDAP require un User DN / Filter du type -> (sAMAccountName=[username])

      Avec la premiere methode (natif joomla 2.5) :
      Sous firefox, Chrome, Opéra les champs login /pwd de mes users sont pré-remplis mais pas validés (obligation de cliquer sur se connecter),

      Sous IE8 (navigateur de mes users) pas de champs pré-remplis. (je suppose encore dû à une négociation de paquets à mon avis, j'avais déjà eu des problème sous IE à cause du "SSPIPackage Negotiate" à déclarer obligatoirement pour la prise en compte de tous les clics sur des "<input type=submit>")

      Avec la seconde methode :
      mes users sont authentifiés et logués dès leur première connection peu importe le navigateur façon SSO.

      Je n'ai pas plus d'explications, mais pour moi ça fonctionne

      Commentaire


      • #4
        Re : SSO - LDAP joomla 2.5

        Hello !

        Je suis en train de tester avec un OpenLDAP et pour l'instant j'ai ce message d'erreur :

        Code:
        LDAP2: Could not get dn for username 'user'. Check User DN  parameter and the authenticating credentials. LDAP reported: Invalid  credentials
        Est ce que tu as commencé par le 1er plugin " JMapMyLDAP" avant de paramétrer les autres ?
        C'est ce que j'essaie de faire, mais je me dis que même s'il n'y a pas de création automatique d'utilisateur je devrais avoir un autre message d'erreur que celui ci...

        Mon paramétrage actuel :
        • Options and Flags
        • LDAP V3 Oui
        • Start TLS Non
        • Follow Referrals Non

        • Connection
        • Host ldap.mydomain.fr
        • Port 389

        • Credentials
        • Connect User : cn=trans,ou=system,dc=mydomain,dc=fr
        • Connect Password :xxxx

        • Binding
        • Use Search : oui
        • Base DN :cn=trans,ou=system,dc=mydomain,dc=fr
        • User DN / Filter : (uid=[search]) NE PAS OUBLIER LES ( ) !!!

        • Mapping Attributes
        • Map User ID : uid
        • Map Full Name : displayName
        • Map Email : mail



        Des idées ?
        Merci !

        Edit : cet outil pour débugguer:
        http://shmanic.com/tools/jmapmyldap/...bug-method.htm

        ça progresse, mais c'est pas encore ça...
        Dernière édition par crony à 16/02/2012, 20h56
        Enjoy J!

        Commentaire


        • #5
          Re : SSO - LDAP joomla 2.5

          Salut Crony,

          normalement cet outil fonctionne très bien (http://shmanic.com/tools/jmapmyldap/...bug-method.htm).


          Check User DN parameter and the authenticating credentials
          donc tu as un problème de DN.
          essai avec : (sAMAccountName=[username]) à la place de (uid=[search])
          sinon c'est que les domaines que tu as déclaré ne sont pas les bons (cn=trans,ou=system,dc=mydomain,dc=fr).

          Zwaldo

          Commentaire


          • #6
            Re : SSO - LDAP joomla 2.5

            Salut Zwaldo !

            Effectivement, j'avais fais quelques erreurs...
            Dans mon DN , je devais mettre :
            ou=People,dc=ledomaine,dc=fr

            Et pour le search :
            (unAutreAttributFeinteux=[username])

            Et maintenant ça tourne nickel ! Merci pour ta réponse !

            Pour ceux que ça intéressent le topic avec le dev en direct ici :
            http://forum.joomla.org/viewtopic.ph...50055#p2750055
            Enjoy J!

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X