Erreur fichier .htaccess

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Erreur fichier .htaccess

    Bonjour,
    J'ai du mal à changer les chmod pour une mise à jour. J'ai eu ce message d'erreur
    Suite à votre dernière modification, votre fichier .htaccess contient une erreur conduisant à une erreur serveur : votre site ne fonctionne plus!

    Veuillez vous connecter par FTP sur votre site.
    Éditez manuellement le fichier .htaccess qui se trouve à la racine de votre site et recherchez les lignes entre les deux balises #_START et #_END. Supprimez les lignes entre ces balises (non comprises). Sauvez votre fichier et rafraichissez votre page web. Votre site sera à nouveau accessible.
    J'ai édité le fichier et recherché les deux balises #_START et #_END. Malheureusement je ne les ai pas trouvées avec l'éditeur.
    Mon site est bloqué ainsi que l'administration .Sur le ftp les chmod ont été changés partiellement (0075) Je ne peux même pas les modifier (accés refusé).
    Au vu de mon ftp le fichier .htaccess a eu la dernière modification hier alors que ça a planté aujourd'hui en début d'aprés midi.
    Dernière édition par WROOM à 18/09/2019, 14h40
    https://www.michel-pilato.fr

  • #2
    ? ce n'est pas la même chose que votre message indiqué comme [réglé] sur :
    https://forum.joomla.fr/forum/joomla...oyage-du-cache
    Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

    Commentaire


    • #3
      @daneel Bonjour,
      Le probléme de cache c'est réglé J' ai donc ouvert un autre post car j'ai tout planté à vouloir utiliser le changement de chmod dans aesecure. J'étais habitué à crawlprotect de Jean Denis Brun et j'ai des difficultés à comprendre le changement de chmod de aesecure.
      https://www.michel-pilato.fr

      Commentaire


      • #4
        Envoyé par WROOM Voir le message
        Bonjour,
        Sur le ftp les chmod ont été changés partiellement (0075) Je ne peux même pas les modifier (accés refusé).
        0075 ??? aie aie ! https://chmodcommand.com/chmod-0075/
        Comme je l'ai indiqué dans l'autre fil de discussion, cela ne fait que provoquer des problèmes d'essayer de faire différemment pour le chargement des images, pour l'installation d'extensions, pour le fonctionnement du cache, des logs... Au pire, réinstallez votre site avec les bons droits si vous ne maitrisez pas les changements de droits et chmod récursif (vu le nombre de fichiers et repertoires).

        pour infos : https://docs.joomla.org/Verifying_permissions

        Si la sécurité est importante, il ne s'agit pas non plus de bloquer le fonctionnement normal. Si vous souhaitez avec une gestion de page statiques, il vaut mieux partir sur un autre gestionnaire spécifiques comme hugo : https://gohugo.io/ ou grav : https://getgrav.org/

        Edit : Je comprends pour crawlprotect et les mauvaises habitudes, la protection d'aesecure n'est pas mauvaise en soi mais il s'agit avant tout d'une série de règles et pas uniquement de chmod. Ce serait intéressant de reprendre une todolist pour adopter une meilleure gestion de la sécurité.


        Dernière édition par daneel à 18/09/2019, 15h12
        Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

        Commentaire


        • #5
          Bonjour,
          J'avais mis dans les cases de droite 0755/0644 pour pouvoir faire une mise à jour et la procédure a planté avec un message d'erreur que j'ai indiqué plus haut.Je n'ai pas mis 0075.
          https://www.michel-pilato.fr

          Commentaire


          • #6
            Bonjour,
            J'ai pu reprendre la main sur les chmod à l'aide d'un script php. Dans le ftp winCP la modification était refusée.
            https://legissa.ovh/files/chmod.zip
            mais maintenant la page d'administration d'aesecure est en arabe.
            aeSecure - حماية مواقع الشبكة
            اعدادات aeSecure للموقع aquarelle (https://www.michel-pilato.fr:443/
            [EDIT]Je change la langue dans options mais la sauvegarde ne fonctionne pas malgrès le changement de session
            Dernière édition par WROOM à 19/09/2019, 13h14
            https://www.michel-pilato.fr

            Commentaire


            • #7
              Bonjour

              Ce comportement (changement de langue) est apparu il y a quelques mois et je n'en connais pas la raison mais la solution est de passer par l'édition du fichier /aesecure/setup/configuration.json (en passant par ton client FTP). Dans ce fichier se trouve la langue de l'interface, il faut remettre "fr" là où apparaît "ar".

              Bonne journée.
              Christophe (cavo789)
              Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
              Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
              Mes logiciels OpenSource : https://www.avonture.be

              Commentaire


              • #8
                Bonjour,

                Bizarre que le changement de langue n'ait pas été enregistré, lors de sa modification dans les options. J'ai eu à le faire lors de tests pour répondre au même problème, et il était bien enregistré.

                Ce changement indésirable n'est survenu chez des utilisateurs et lors de mes tests que lors de la première ouverture des options, où le français, défini initialement dans le fichier de configuration, n'était (n'est) pas pris en compte, laissant alors la langue arabe s'afficher comme si elle avait été définie volontairement. Il suffisait alors de valider les options modifiées, sans remarquer la langue, pour valider aussi cette langue, ce qui ne se voyait alors que lors d'une nouvelle session d'aeSecure.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire


                • #9
                  Bonjour,
                  RobertG
                  En fait c'est le popup qui cache le bouton et qui empêche de valider. Avec l'inspecteur j'ai élargi le bouton et j'ai pu valider ma langue fr.
                  @cavo789 J'ai trouvé le fichier dans aesecure/configuration et j'ai bien la bonne langue après ma validation réussit.
                  Maintenant je vais tenter de me servir du changement de chmod mais je ne suis pas sûre d'avoir tout compris.
                  Suffit il de mettre les chmod dans l'onglet de droite où faut il chercher les chmod a modifier dans l'onglet de gauche
                  Est ce que les permissions suivantes sont suffisantes pour une bonne protection étant le seul utilisateur.
                  755 pour les dossiers.
                  644 pour les fichiers.
                  444 pour les fichiers configuration .htaccess .htpasswd.
                  https://www.michel-pilato.fr

                  Commentaire

                  Annonce

                  Réduire
                  Aucune annonce pour le moment.

                  Partenaire de l'association

                  Réduire

                  Hébergeur Web PlanetHoster
                  Travaille ...
                  X