Localhost -> https admin

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Localhost -> https admin

    Bonjour à tous.

    Il m'arrive quelque chose de bizarre…
    Afin de vérifier mon dernier Backup, je l'ai déployé en local. (Mamp Mac)

    Lorsque tout est fait, le site et ses liens fonctionnent.
    Je souhiate accéder à l'administration, je tape donc les mots magiques dans l'URL et j'arrive sur la fenêtre de connexion. Je place mes login et mot de passe et valide, je suis alors redirigé vers https://localhost… qui me file une erreur SSL_ERROR_RX_RECORD_TOO_LONG

    Bien sûr en local, je n'ai aucun htaccess à la racine, le SSL de Joomla!(configuration.php) est sur 0?

    J'ai cru que le plugin HTTP-Headers était responsable, je l'ai désactivé depuis phpMyAdmin mais rien n'y fait, je continue d'être redirigé vers https://localhost.

    Qu'est-ce qui peut provoquer cette redirection à votre avis ?
    Cordialement.
    __
    Eddy !!!
    Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

  • #2
    Bonjour,

    As-tu vidé ton cache de navigateur entretemps ? J'ai souvent eu de tels changements d'adresse qui persistaient après un premier incident résolu.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Tu as saisi quelque chose dans livesite ? Tu as recommencé l'installation une seconde fois avec le même problème ?
      "Si vous n’êtes pas impliqués émotionnellement dans ce que vous créez, laissez tomber."
      https://www.graphiquedesign-bf.com/

      Commentaire


      • #4
        As tu désactivé HTTPS dans Angie, lors de l'installation ? As tu demandé de remettre un .htaccess standard dans Angie lors de l'installation ?
        "Si vous n’êtes pas impliqués émotionnellement dans ce que vous créez, laissez tomber."
        https://www.graphiquedesign-bf.com/

        Commentaire


        • #5
          Salut les gars.

          Cache navigateur vidé, cookies virés, pas de htaccess redirecteur, pas de livesite (je ne le renseigne jamais), pas de SSL ni côté front, ni côté admin (public $force_ssl = '0'

          Je viens de retenter une nouvelle restauration, comportement identique.
          Je me suis aussi aperçu que si j'ouvre le front en localhost:8888/nomDuSite/, je suis redirigé vers l'index.html et non l'index.php… il faut que j'inscrive index.php manuellement pour y être redirigé.

          Bizarre autant qu'étrange.
          Cordialement.
          __
          Eddy !!!
          Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

          Commentaire


          • #6
            Fait un essai en demandant à Angie de restaurer un .htaccess standard pour éliminer cette piste ...
            "Si vous n’êtes pas impliqués émotionnellement dans ce que vous créez, laissez tomber."
            https://www.graphiquedesign-bf.com/

            Commentaire


            • #7
              J'ai fais quelques tests avec Angie de mon côté, sur différents serveurs, et, c'est la total cata, car, impossible de restaurer mes archives, quelque soit la provenance.
              J'ai peut être oublié d'ouvrir les yeux et de lire la documentation, mais, mes différents essais m'on fait abandonner cette méthode de restauration.

              Maintenant, je duplique les fichiers et la base de données, pour les réinstaller sur un environnement similaire.

              Commentaire


              • #8
                Curieux ! Pas de problème en ce qui me concerne, sauf bien sûr s'il y a eu un pépin au moment de la sauvegarde. Sinon, la restauration se passe sans erreur (attention au SSL, je me fais souvent piéger en oubliant de le désactiver quand je change de serveur).
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Je n'ai jamais eu moindre problème jusque là avec angie, en ligne ou en local, et le mode de restauration est le plus rapide que je connaisse… Les seules choses qui diffèrent entre ce temps et maintenant, c'est la mise en place des http Header, CSP (ces deux derniers désactivés sur la restauration) et la mise à jour de MAMP.

                  Concernant le SSL, je me suis bien entendu assuré qu'il soit désactivé, du moins dans le fichier configuration.php.

                  Sur le site en ligne, le https est forcé sur l'admin seulement via les paramètres joomla. le front se fait par htaccess. C'est bien ce qui semble se produire sur la restauration mais…
                  Cordialement.
                  __
                  Eddy !!!
                  Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                  Commentaire


                  • #10
                    Bonjour Eddy,

                    Utilises-tu Chrome ? Si oui, as-tu essayé avec un autre navigateur ?

                    Voir dans https://forum.joomla.fr/forum/joomla...8me-avec-uwamp

                    Pascal
                    Les JoomlaDays Paris 2019, c'était du 8 au 9 mars... J'y étais et vous ?

                    If anything can go wrong, it will...
                    If I can help, I will ..https://conseilgouz.com

                    Commentaire


                    • #11
                      Bonjour Pascal.

                      J'utilise principalement Firefox mais j'ai testé à l'instant avec Chrome et Safari… Même topo…
                      Il doit y avoir une coquille quelque part mais c'est vraiment bizarre, je n'ai jamais eu ça avant !
                      Cordialement.
                      __
                      Eddy !!!
                      Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                      Commentaire


                      • #12
                        Petite question bête: tu évoques un index.html ? en principe, il n'y en a pas. Donc, en as-tu un sur ta racine ? si oui, supprime-le.
                        Les JoomlaDays Paris 2019, c'était du 8 au 9 mars... J'y étais et vous ?

                        If anything can go wrong, it will...
                        If I can help, I will ..https://conseilgouz.com

                        Commentaire


                        • #13
                          Déjà supprimé, je sais pas ce qu'il faisait là… Il est aussi présent en ligne ! (aesecure peut-être ?)
                          Le front fonctionne maintenant sans ce html mais le back office est toujours inaccessible suite à la redirection vers https.

                          J'ai scanné le répertoire à la recherche de .htaccess, mais rien…

                          J'ai restauré une sauvegarde de base de donnée d'un autre site vers sa version locale et l'accès à l'admin se fait bien…
                          Cordialement.
                          __
                          Eddy !!!
                          Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                          Commentaire


                          • #14
                            Bonjour

                            Aesecure ne crée un fichier index.html qu'en l'absence d'un index.php et donc ni en racine ni dans /administrator.
                            Christophe (cavo789)
                            Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
                            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                            Mes logiciels OpenSource : https://www.avonture.be

                            Commentaire


                            • #15
                              C'est bien ce qui me semble bizarre.

                              Mais le gros problème reste. Je n'arrive pas à trouver la source de cette redirection vers l'admin en https...
                              Cordialement.
                              __
                              Eddy !!!
                              Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X