Migration j!2.5.28 vers joomla 3

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Migration j!2.5.28 vers joomla 3

    Bonjour,
    Je ne vois rien apparaître dans le menu: composants/mise à jour de joomla pour faire la mise à jour de joomla (administrator/index.php?option=com_joomlaupdate)

    J'utilises donc le 1er onglet pour faire une installation:
    administrator/index.php?option=com_installer

    La1ère migration des versions 2.5.6 -> 2.5.28 se fait sans problème

    Ensuite j'ai vu dans des tutos qu'il fallait d'abords mettre à jour vers 3.5 mais je n'ai pas trouvé de paquet sur la page de Joomla.fr
    https://www.joomla.fr/joomla/telecha...ld&task=search
    Je ne vois que la version du 12/07/2016 d'un paquet pour migration des versions 2.5 et -> 3.6 !!

    Je fais comme précédemment en téléchargeant Joomla_360-Stable-Update_Package_French_v1 mais j'ai un message d'erreur:
    JInstaller: :Install: impossible de trouver un fichier d'initialisation XML
    J'ai aussi téléchargé le paquet 3.5 sur https://downloads.joomla.org/fr/cms/joomla3/3-5-0 mais cela ne change rien!
    Je me demande ou trouver ce bon paquet de maj 2.5 -> 3.x ?
    @+
    Dernière édition par herve à 24/02/2021, 17h18
    Faciliter l'adoption du meilleur du Libre auprès du grand public https://clibre.eu/ - Connaissez-vous des communicants ... pour promouvoir joomla ? https://forum.joomla.fr/forum/th%C3%...mouvoir-joomla

  • #2
    Bonjour,

    Par où passes-tu pour l'installation de ces paquets ?
    C'est bien, pour la 3.5.0, ce pack Joomla! 3.5.0 Upgrade Package (.zip) que tu as récupéré ?
    Qu'as-tu paramétré dans les options du composant de mise à jour ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

    Commentaire


    • #3
      Bonsoir
      Ah je n'ai pas été clair !
      J’utilise le 1er onglet (administrator/index.php?option=com_installer ) pour faire l'installation car je n'ai aucune possibilité via le menu composants/mise à jour de joomla. J'ai essayé les différents paramètres: LTS, STS ... de la Configuration des mises à jour Joomla!
      J'ai fais 1ère migration des versions 2.5.6 -> 2.5.28 se fait sans problème

      J'ai ensuite cherché l'upgrade 2.5.28 -> 3.5 , pas trouvé sur joomla.fr
      J'ai trouvé joomla! 3.5.0 Upgrade Package (.zip) (This package is for performing updates from Joomla! 2.5 and previous 3.x releases to 3.5.0) sur https://downloads.joomla.org/fr/cms/joomla3/3-5-0
      J'ai à chaque fois le mesg :
      JInstaller: :Install: impossible de trouver un fichier d'initialisation XML
      Ah j'oubliais j'ai Retéléchargé et décompressé le fichier qui fait environ 10 mo comme l'indique:
      https://kb.joomla.fr/messages/instal...ion-xml-joomla
      Tout fonctionne correctement, je me demande quand même si c'est bien le fichier d'upgrade de 2.5.28 vers 3.5 !??


      Dernière édition par herve à 24/02/2021, 21h36
      Faciliter l'adoption du meilleur du Libre auprès du grand public https://clibre.eu/ - Connaissez-vous des communicants ... pour promouvoir joomla ? https://forum.joomla.fr/forum/th%C3%...mouvoir-joomla

      Commentaire


      • #4
        On n'installe plus les mises à jour de Joomla! par l'installateur d'extensions depuis belle lurette ! Dans la page du composant de mise à jour de Joomla! tu as un onglet pour l'installation manuelle.
        As-tu vidé le cache des mises à jour, vérifié la base, découvert si quelque chose est en souffrance, Je suis persuadé que si le site ne te propose pas de mise à jour c'est soit un mauvais paramétrage des options, soit une question de cache.
        As-tu essayé aussi de paramétrer sur "le prochain Joomla!" ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

        Commentaire


        • #5
          Bonjour,
          Eh oui je fais régulièrement les maj de jooml3.x
          Par contre j'ai réussi à récupérer ce joomla pour qu'il ne bascule pas sur un wp, il faut maintenant que je le migre depuis 2.5.28 et là cela fait ... très longtemps que je n'ai pas fais ou n'utilises plus cette version
          As-tu vidé le cache des mises à jour => OUI
          vérifié la base => OUI
          découvert si quelque chose est en souffrance =>NON . J'ai désactivé toutes les autres extensions et ancien template

          Je suis persuadé que si le site ne te propose pas de mise à jour c'est soit un mauvais paramétrage des options, soit une question de cache.
          As-tu essayé aussi de paramétrer sur "le prochain Joomla!" ? => là je ne comprends pas

          Moi je pense que cela vient du fichier et je ne comprends pas pourquoi il n'est pas clairement indiqué tout en bas de la page :
          Télécharger les anciennes version de Joomla en français : Version intégrale en FR, mise à jour depuis une version antérieure vers 3.8.7 en FR, fichier de langue FR.

          Il n'y a que j!3.6 !????

          Voilà les images , peut-être plus facile de se comprendre.
          Seule chose bizarre c'est que je ne peux faire le déverrouillage globale mais j'ai vérifié, réparé ... via phpmyadmin et il me semble que c'est plus un problème de fichiers ??

          Cliquez sur l'image pour l'afficher en taille normale

Nom : avo-maj258 .png 
Affichages : 140 
Taille : 84,7 Ko 
ID : 2024994

          Cliquez sur l'image pour l'afficher en taille normale

Nom : avo-maj258b .png 
Affichages : 99 
Taille : 99,0 Ko 
ID : 2024995
          Cliquez sur l'image pour l'afficher en taille normale

Nom : avo-maj258c .png 
Affichages : 98 
Taille : 112,8 Ko 
ID : 2024996
          Faciliter l'adoption du meilleur du Libre auprès du grand public https://clibre.eu/ - Connaissez-vous des communicants ... pour promouvoir joomla ? https://forum.joomla.fr/forum/th%C3%...mouvoir-joomla

          Commentaire


          • #6
            Bonjour,

            Tu n'as rien à déverrouiller, tout est à 0 sur ton image.
            Comme je l'ai dit, tu ne peux pas passer par l'installation d'extension pour mettre à jour Joomla!
            Je n'ai pas de site 2.5.28 pour tester, mais regarde si tu peux reconstruire la liste des sites de mise à jour. En général ça fonctionne lorsque la 3 ne propose pas de mise à jour alors qu'il y en a.
            Sinon, tu as la méthode ftp : sur un clone du site, écrase la version 2.5 avec un pack d'upgrade 3 puis mets à jour la base et découvre les nouvelles extensions et installe-les.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
            MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

            Commentaire


            • #7
              Bon, je viens d'installer une version 2.5.28 en local et je n'ai pas non plus d'offre de mise à jour, et je constate qu'il n'est pas possible d'installer en ajoutant le pack dans le composant de mise à jour.
              Il fut retrouver la doc... https://docs.joomla.org/Planning_for_Migration/fr
              https://docs.joomla.org/Joomla_2.5_to_3.x_Step_by_Step_Migration/fr

              La plupart du temps, j'ai fait ces migrations avec JMigrator, et je ne me souviens plus de la procédure standard !
              Dernière édition par RobertG à 25/02/2021, 11h24
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

              Commentaire


              • #8
                Re
                Merci d'avoir pris le temps de faire un essai
                Effectivement bizarre que je n'ai pas de proposition pour migrer automatiquement en 3.5.1
                Après je suis passé par le gestionnaire extension pour passer de 2.5.6 à 2.5.28, peut-être que cela a foutu le bordel !?
                Moi aussi j'ai fais il y a longtemps des migrations via FTP mais là je ne retrouve plus qq chose de clair la dessus.
                Je m'appuyais sur la bonne doc

                Bon j'ai posé la question aussi SP transfert Jmigrator car j'y ai déjà passé pas mal de temps, peu-être plus simple par une de ces extensions qui prend aussi en charge joomla4 !!
                Faciliter l'adoption du meilleur du Libre auprès du grand public https://clibre.eu/ - Connaissez-vous des communicants ... pour promouvoir joomla ? https://forum.joomla.fr/forum/th%C3%...mouvoir-joomla

                Commentaire


                • #9
                  Bonjour,

                  Je réveille cette discussion, ayant le même problème pour une migration de 2.5.28 vers la version 3.
                  Au départ, la question concerne un site Joaktree pour lequel on m'a consulté.

                  J'ai donc retrouvé, pour tests en local, une très vieille version (2.5.8) de Joomla avec mes données Joaktree. Après mise à jour en 2.5.28, même souci qu'ici : aucune solution de migration. L'utilisation d'une mise à jour par écrasement avec la version 3.5.1 de mise à jour me renvoie une page blanche pour l'administration.

                  Je repars donc sur un nouveau site 2.5.28, installation de la version 1.4.4 de Joaktree, en ligne cette fois, même souci.
                  Rapatriement en local de la version avant écrasement, écrasement par le pack de maj 3.5.1, erreur de mise à jour de base de données.

                  Utilisation de postupdate.php (https://gist.github.com/mbabker/d7bf...5a733607f89281) qui me passe bien en 3.5.1 mais malgré la structure de la base à jour, et malgré la doc qui dit qu'une fois en 3.5.1 le site proposera la mise à jour en version supérieure, rien !
                  L'effacement du cache propose maintenant le pack 3.6.5
                  Sauvegarde, passage de PHP 5.6 à 7.0 installation de la version supérieure d'Akeeba backup, nouvelle sauvegarde. Passage en 3.6.5, curieusement, malgré la mise à jour directe, il m'est demandé identifiant et mot de passe.
                  Le site propose maintenant la 3.10.12 ; mise à jour d'extensions, sauvegarde; mise à jour, je suis enfin en 3.10.12

                  Pour résumer
                  • sauvegarde du site 2.5.28
                  • écrasement par le pack 3.5.1
                  • la base ne s'est pas correctement mise à jour
                  • utilisation de postupdate qui la met bien en version 3.5.1
                  • mise à jour en 3.6.5 proposée : sauvegarde, mise à jour, confirmation par identifiant et mot de passe
                  • le système propose maintenant la 3.10.12 : vérification des mises à jour d'extensions, installation, mise à jour en 3.10.12
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                  MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr chez PHPNET, sites perso chez PlanetHoster + sites gérés chez PHPNET, PlanetHoster, Ionos et OVH

                  Commentaire

                  Annonce

                  Réduire
                  Aucune annonce pour le moment.

                  Partenaire de l'association

                  Réduire

                  Hébergeur Web PlanetHoster
                  Travaille ...
                  X