Probleme de certifica SSL et images non securisées

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Probleme de certifica SSL et images non securisées

    Salut

    Sur le forum il ma été signalé que mon site (voir en signature) avait un probleme de certificat SSL. Ca fait longtemps que j'avais mis le HTTPS mais je me suis souvenu que j'avais ajouté une exception dans mon Firefox pour mon site. A l’époque je ne m’étais pas penché sur le probleme de suite et j'ai un peu oublié. Effectivement, ça me dit que ça serait a cause d’éléments (comme les images) qui ne sont pas sécurisés. Je suis en train de refaire mon site, donc j'aimerais bien connaitre la raison, histoire de résoudre le probleme.

    Pour le HTTPS j'utilise Let's Encrypt (je suis chez o2switch).
    Mon site de photos du Pays Basque : nenex-argazkia.net

  • #2
    Bonjour,
    Votre site indique le msg suivant (sur Chrome) : NET::ERR_CERT_DATE_INVALID
    Donc je pense que simplement le Certificat SSL (Let's Encrypt en l'occurrence) est expiré.
    Dans l'Administration de votre Hébergement, vous pouvez sans doute le renouveler vous-même (ou contacter le support pour demander la procédure).

    Après, il n'est pas impossible que -par ailleurs- certaines images soient appelées sur votre site en http au lieu de https.
    Là il faut "simplement" identifier les endroits où ça se pose et le corriger "à la main".
    Voyez https://cinnk.com/joomla/3/tutoriels...on-site-joomla p.ex. pour un peu plus d'infos à ce sujet
    Présentations : slides.woluweb.be, ...
    Custom Fields / Automatiser la restauration de ses sites / Lightning Talks / Toutes les nouveautés au fil des sous-versions de Joomla! 3.x / Devenir un testeur Joomla / Akeeba Backup & Amazon S3 / Acymailing & ElasticEmail / ...
    Coordonnées complètes : www.woluweb.be

    Commentaire


    • #3
      Bonjour.

      Tous les liens vers Pixelliste (dont env. 80% sont en 404) sont en http !

      Woluweb, si on regarde les informations de sont certificat, il semble invalide et pourtant il débute aujourd'hui 26 août (???) et expire en novembre 2018.

      Cliquez sur l'image pour l'afficher en taille normale

Nom : image_34024.jpg 
Affichages : 1 
Taille : 73,7 Ko 
ID : 1986470
      Cordialement.
      __
      Eddy !!!
      Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

      Commentaire


      • #4
        c'est parce qu'il est maintenant en place
        Par contre, pas mal de mixed-content ...
        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
        Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

        Commentaire


        • #5
          Ben visiblement le certificat vient juste d'être installé et il ne l'était pas encore au moment où je suis allé voir le site lors de ma 1e réponse.
          Présentations : slides.woluweb.be, ...
          Custom Fields / Automatiser la restauration de ses sites / Lightning Talks / Toutes les nouveautés au fil des sous-versions de Joomla! 3.x / Devenir un testeur Joomla / Akeeba Backup & Amazon S3 / Acymailing & ElasticEmail / ...
          Coordonnées complètes : www.woluweb.be

          Commentaire


          • #6
            Il y a cet outil qui peut aider à débusquer les ressources non sécurisées https://www.jitbit.com/sslcheck/ et certainement d'autres !
            "Si vous n’êtes pas impliqués émotionnellement dans ce que vous créez, laissez tomber."
            https://www.graphiquedesign-bf.com/

            Commentaire


            • #7
              J'ai contacté o2switch qui a réglé le problème en suivant. Voici sa réponse concernant le problème :

              ...
              J'ai alors procédé pour nenex-argazkia.net

              The Let's Encrypt HTTP challenge failed: acme error 'urn:acme:error:unauthorized': Invalid response from http://nenex-argazkia.net/.well-know...Mq-33XwhZft1c: "<html> <head> <meta charset="utf-8"/></head> <meta name="robots" content="noindex, nofollow"> <meta"

              Cela indique une erreur d'accès du répertoire .well-know, destiné au test de réponse.
              J'ai donc rajouté, dans ce répertoire, un .htaccess comme proposé ici (bas de page) : https://faq.o2switch.fr/hebergement-...rtificat-ssl?s[]=let&s[]=encrypt

              Ensuite, j'ai refais la génération pour les deux domaines.
              Le tout a été actif & fonctionnel.
              Pour le renouvellement de Let’s Encrypt je reçois un mail mais il se fait automatiquement.

              GraphiqueDesign, j'ai utilisé l'outil que tu ma passé et en fait tous les problèmes (j'ai pas regardé le résultats pour toutes les pages car il y en as 149) viennent de l'image qui se trouve en haut du site et de certaines pages qui contienne une carte umap et dont l'url est encore en HTTP.

              Comme je suis en train de refaire le site l'image je ne la mettrait pas ou alors je la recup et je la met sur mon serveur et pour les cartes je vais soit chercher chez les CHATONS un site qui propose la même chose (avec umap) mais avec du HTTPS ou mieux m'installer umap sur mon propre serveur.

              Merci à tous pour votre aide. J'aurais appris encore quelque chose
              Mon site de photos du Pays Basque : nenex-argazkia.net

              Commentaire


              • #8
                Code:
                <a href="http://degooglisons-internet.org" target="_blank"><img src="https://degooglisons-internet.org/img/badge_bourrepif.png" alt="Dégooglisons Internet, une initiative du réseau Framasoft" style="display: block; margin-left: auto; margin-right: auto; border: 1px solid #000000;" title="Découvrir le projet et les services en ligne libres proposés par Framasoft"></a>
                salut, pour resoudre cela:
                changer l'url de l'image pour https://degooglisons-internet.org/im..._bourrepif.png (cette url existe directement, donc pas besoin de la charger ailleurs), mais pas que: il faut aussi changer l'url du lien en https://degooglisons-internet.org/ .
                Tu peut récupérer le code de ton module personnalisé et juste en ajoutant s aux deux url , ton dysfonctionnement disparaitra.
                Mon site en cours de construction avec de nouvelles catégories de documents...
                https://informaticien51.fr

                Commentaire


                • #9
                  Effectivement, maintenant que tu le dit, Framasoft sont en HTTPS.
                  Mon site de photos du Pays Basque : nenex-argazkia.net

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X