Site inaccessible sans www après activation SSL

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Site inaccessible sans www après activation SSL

    Bonjour,

    J'ai besoin de votre aide concernant l'accès à mon site sans les www depuis que j'ai activé mon certificat SSL pour passer en https.

    Je résume le problème :
    Mon site est actuellement hébergé chez Gandi, qui me permet d'avoir un certificat SSL gratuitement avec mon nom de domaine. J'ai donc activé ce certificat et passé mon site en https.
    Après quelques difficultés au début j'ai finalement réussi à obtenir l'affichage souhaité avec ces différentes méthodes d'accès :
    https://www.mon-domaine.co.za
    http://www.mon-domaine.co.za

    Par contre quand je tente d'y accéder par les liens suivant, j'obtiens des erreurs :
    Avec https://mon-domaine.co.za
    Ce site ne peut pas fournir de connexion sécurisée


    mon-domaine.co.za utilise un protocole incompatible.

    ERR_SSL_VERSION_OR_CIPHER_MISMATCH
    Avec http://mon-domaine.co.za
    Error 404 Vhost unknown.


    Vhost unknown.

    Varnish L7 server

    Cela ne semble ce produire qu'avec certain navigateur, peu importe l'ordinateur utilisé. En effet sur mon Macbook j'ai l'erreur sur la dernière version de Google Chrome mais aucun soucis avec Safari.
    Sur mon téléphone Android idem, j'ai l'erreur en utilisant Chrome et le navigateur de mon téléphone.
    Sur un PC je n'ai pas d'erreur en https mais j'ai la même erreur en http ...

    Je suis totalement perdu, auriez vous de l'aide à m'apporter pour m'assurer que le site soit bien visible par tout le monde, quelque soit son navigateur ou la façon dont il arrive sur le site.

    D'avance merci.
    Dernière édition par Tixy22 à 19/04/2019, 09h03

  • #2
    Bonjour,

    Si tu as déjà une redirection automatique de sans www vers avec www le problème doit se situer au niveau des paramétrages du certificat dans la gestion de ton compte chez Gandi, qui intervient avant ce passage en www.
    J'ai reproduit les erreurs dont tu parles sur mon PC avec Chrome.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Bonsoir,

      En effet j'ai bien une redirection en place sur Gandi :
      https://mon-domaine.co.za
      http://mon-domaine.co.za
      PERMANENT https://www.mon-domaine.co.za
      Par contre j'ai deux certificat SSL, le problème vient peut-être de là :
      Un certificat pour mon-domaine.co.za et un autre pour www.mon-domaine.co.za

      Mon nom de domaine est associé au certificat mon-domaine.co.za (l'autre ne semble associé à rien).
      Dernière édition par Tixy22 à 19/04/2019, 09h04

      Commentaire


      • #4
        Bon, le problème semble clairement venir du certificat SSL pour le domaine "mon-domaine.co.za", en effet lorsque je fais un SSL checker ce nom de domaine ne semble pas avoir de certificat SSL... par contre "www.mon-domaine.co.za" lui possède bien un certificat, valide.

        Je ne comprend pas trop du coup ... le certificat "www.mon-domaine.co.za" devrait suffire avec ou sans www. Faut t-il que je supprime pour certificat "mon-domaine.co.za" ?
        Dernière édition par Tixy22 à 19/04/2019, 09h04

        Commentaire


        • #5
          Pose la question à Gandi, ce n'est pas logique que tu n'aies pas un seul certificat qui couvre le nom avec et sans www. Probablement un paramétrage, mais je n'ai ps d'expérience des certificats SSL chez Gandi.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            J'attends leur réponse depuis 48h ...
            En effet leur certificat gratuit permet de protéger avec ou sans le www, c'est bien stipulé dans l'offre, je n'ai donc besoin que d'un seul certificat et logiquement je devrait avoir uniquement "mon-domaine.co.za" puisque c'est celui-ci qui est associé à mon offre.

            Edit :
            Bon j'ai révoqué le certificat "www.mon-domaine.co.za" pour ne garder que celui qui devrait être logiquement le bon "mon-domaine.co.za"
            Lorsque je fais un SSL checker sur mon domaine "www.mon-domaine.co.za" j'ai bien les deux domaines avec et sans www qui apparaissent comme "protégés".

            Du coup j'ai testé en tapant simplement "mon-domaine.co.za" dans mon navigateur, je suis bien redirigé en https vers le site https://www.mon-domaine.co.za
            Par contre site je tape "http://mon-domaine.co.za" j'ai toujours cette erreur ...

            Partant du principe que jamais personne ne tape "http://" je vais arrêter mes recherches pour le moment et reviendrais sur le sujet plus tard.
            Dernière édition par Tixy22 à 19/04/2019, 09h05

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X