Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

index,php dans mon URL sinon 404 page non trouvée

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] index,php dans mon URL sinon 404 page non trouvée

    Bonjour

    je viens d'upgrader mon site : www.jbnature.com en joomla 3.8 et j'ai un problème avec mes urls

    j'aimerais afficher http://www.jbnature.com/nouveautés et j'ai
    http://www.jbnature.com/index.php?op...=47&Itemid=329

    j'essaye de modifier Réécriture au 'vol' des URL à oui , dans ce cas j'ai le bon url mais j'ai erreur 404 non trouvé

    dans apache le mod rewrite est bien activé, j'ai un fichier .htaccess

    dont le contenu est
    ##
    # @package Joomla
    # Copyright Copyright (C) 2005 - 2017 Open Source Matters. All rights reserved.
    # @license GNU General Public License version 2 or later; see LICENSE.txt
    ##

    ##
    # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
    #
    # The line 'Options +FollowSymLinks' may cause problems with some server configurations.
    # It is required for the use of mod_rewrite, but it may have already been set by your
    # server administrator in a way that disallows changing it in this .htaccess file.
    # If using it causes your site to produce an error, comment it out (add # to the
    # beginning of the line), reload your site in your browser and test your sef urls. If
    # they work, then it has been set by your server administrator and you do not need to
    # set it here.
    ##

    ## No directory listings
    <IfModule autoindex>
    IndexIgnore *
    </IfModule>

    ## Can be commented out if causes errors, see notes above.
    Options +FollowSymlinks
    Options -Indexes

    ## Mod_rewrite in use.

    RewriteEngine On

    ## Begin - Rewrite rules to block out some common exploits.
    # If you experience problems on your site then comment out the operations listed
    # below by adding a # to the beginning of the line.
    # This attempts to block the most common type of exploit `attempts` on Joomla!
    #
    # Block any script trying to base64_encode data within the URL.
    RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
    # Block any script that includes a <script> tag in URL.
    RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
    # Block any script trying to set a PHP GLOBALS variable via URL.
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    # Block any script trying to modify a _REQUEST variable via URL.
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    # Return 403 Forbidden header and show the content of the root home page
    RewriteRule .* index.php [F]
    #
    ## End - Rewrite rules to block out some common exploits.

    ## Begin - Custom redirects
    #
    # If you need to redirect some pages, or set a canonical non-www to
    # www redirect (or vice versa), place that code here. Ensure those
    # redirects use the correct RewriteRule syntax and the [R=301,L] flags.
    #
    ## End - Custom redirects

    ##
    # Uncomment the following line if your webserver's URL
    # is not directly related to physical file paths.
    # Update Your Joomla! Directory (just / for root).
    ##

    # RewriteBase /

    ## Begin - Joomla! core SEF Section.
    #
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    #
    # If the requested path and file is not /index.php and the request
    # has not already been internally rewritten to the index.php script
    RewriteCond %{REQUEST_URI} !^/index\.php
    # and the requested path and file doesn't directly match a physical file
    RewriteCond %{REQUEST_FILENAME} !-f
    # and the requested path and file doesn't directly match a physical folder
    RewriteCond %{REQUEST_FILENAME} !-d
    # internally rewrite the request to the index.php script
    RewriteRule .* index.php [L]
    #
    ## End - Joomla! core SEF Section.

    j'ai essayé de changer plusieurs choses mais sans succès
    pouvez vous m 'aider ?
    merci d'avance
    ...
    Dernière édition par manu93fr à 08/11/2017, 19h57

  • #2
    Bonsoir,
    as tu bien modifié le nom du fichier htaccess.txt en .htaccess (point suivi de htaccess) a la racine du site ?

    Sinon, c'est dommage d'avoir un site Joomla! en 3.8 avec un template NON responsive ....
    Dernière édition par manu93fr à 07/11/2017, 18h21
    Jday 2018 - 18/19 Mai !!! J'y serai ... et vous ?

    Commentaire


    • #3
      oui oui c'est le cas

      Commentaire


      • #4
        Envoyé par bunny1213 Voir le message
        oui oui c'est le cas
        C'est le cas mais encore ...
        Tu as un fichier htaccess.txt ET .htaccess ?
        Si c'est le cas ... renomme provisoirement ton fichier actuel en .htaccesshold et renomme celui en txt (celui d'origine de Joomla!) en .htaccess pour qu'il prenne la main
        Evidemment, il faut avoir selectionné "reécriture des url au vol" a oui
        Jday 2018 - 18/19 Mai !!! J'y serai ... et vous ?

        Commentaire


        • #5
          Merci de votre aide
          j'ai juste le fichiet .htaccess au sommet du site chez l herbergeur uniquement et effectivement, j'ai essayé de mettre réécriture des url au vol à oui et dans ce cas, j'ai un url qui me convient(plus d'index php) mais j'obtiens 404 page non trouvée,,,,,

          Commentaire


          • #6
            Quel est ton hébergeur ? Le mod_rewrite est-il activé ?
            Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
            C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
            Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

            Commentaire


            • #7
              mon hebergeur est infomaniak.ch mais effectivement je vais leur ecrire pour avoir l information je ne la trouve pas sur leur site
              pour la template, nous voulions conserver ce fond noir qui met en valeur les photos, j ai donc dû adapter une vieille template

              Commentaire


              • #8
                j ai trouvé cette info sur infomaniak donc oui, le mod-rewrite est activé :

                Le module Apache "mod_rewrite" est disponible et est activé par défaut.

                Toutefois, il n'est supporté chez nous que via un fichier .htaccess; il faut en outre faire attention à ce que les expressions régulières du chemin ne commencent pas par "/".

                Concernant le virtualhost (vhost), nous ne donnons pas accès à sa configuration et n'effectuons aucune modification.

                Commentaire


                • #9
                  J'ai modifié le .htaccess de cette façon et ça marche


                  ##
                  ######## URL rewriting #########

                  <IfModule mod_rewrite.c>
                  RewriteEngine On
                  RewriteCond %{REQUEST_FILENAME} !-f
                  RewriteRule ^(.*)$ index/$1 [QSA,L]
                  </IfModule>

                  Commentaire


                  • #10
                    Merci de passer la discussion en [RÉGLÉ]. Voir encadré en haut de page.
                    Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
                    C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
                    Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

                    Commentaire

                    Travaille ...
                    X