Loadmodule dans un article ne fonctionne pas ...

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Loadmodule dans un article ne fonctionne pas ...

    Bonjour

    J'essaye de loader un module dans un article de cette façon : {loadmodule maposition}
    Et ça ne fonctionne pas, le plug est activé et je l'ai entré en mode html
    Pourquoi je me suis mis à joomla ?

  • #2
    Re : Loadmodule dans un article ne fonctionne pas ...

    Bonjour,
    il se passe quoi ? Le code reste affiché ? Il ne s'affiche rien ?
    On est bien dans un article ?
    Le module est bien dans "maposition" ?
    Le module fonctionne quand affiché dans une position normale ?
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Re : Loadmodule dans un article ne fonctionne pas ...

      il se passe quoi ? Le code reste affiché ? Il ne s'affiche rien ?
      Le code est affiché
      On est bien dans un article ?
      oui
      Le module est bien dans "maposition" ?
      oui
      Le module fonctionne quand affiché dans une position normale ?
      oui

      Commentaire


      • #4
        Re : Loadmodule dans un article ne fonctionne pas ...

        Aaaahhhh,
        j'étais passé à coté :
        leplugin s'appelle loadmodule, mais le code c'est {loadposition maposition}
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Re : Loadmodule dans un article ne fonctionne pas ...

          Ah mince j'ai mal recopier sur le forum désolé, c'est en effet {loadposition maposition} qui ne marche pas.

          Commentaire


          • #6
            Re : Loadmodule dans un article ne fonctionne pas ...

            Re,
            hum...
            (re) vérifie :
            > qu'il n'y a pas de faute de frappe dans maposition, ici ou dans le module,
            > qu'il n'y a pas de faute de frappe dans loadposition,
            > que le truc entre loadposition et maposition est bien une espace,
            > que le module est publié, activé, public,
            > que le plugin est activé,
            > que tu n'as pas été marabouté....

            et au fait, l'article est affiché normalement via le com_content ?
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Re : Loadmodule dans un article ne fonctionne pas ...

              et au fait, l'article est affiché normalement via le com_content ?
              AAAAAAh
              Oui mais pas avec le layer par defaut ! je vais fouiller de ce côté là...

              Commentaire


              • #8
                Re : Loadmodule dans un article ne fonctionne pas ...

                Merci, bien vu grand Schtoumpf ! Dans le layer je n'ai pas utilisé le même objet pour afficher le contenu donc automatiquement...

                Commentaire


                • #9
                  Re : Loadmodule dans un article ne fonctionne pas ...

                  Re,
                  pense à passer le sujet en réglé..
                  Schtroumpfe toi le Schtroumpf t'aidera.
                  Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                  Commentaire


                  • #10
                    Re : Loadmodule dans un article ne fonctionne pas ...

                    Bonjour tt le monde la solution est la suivante:

                    1. METTRE UN MODULE JOOMLA DANS UN ARTICLE

                    - Connectez vous dans l'administration de Joomla
                    - Allez dans le menu Extensions - Gestion des plug-ins et publier le plug-in Content - Load Module * (Description: Permet d'insérer des positions de modules au sein du contenu)
                    -Maintenant, allez dans le menu Contenu - Gestion des articles pour éditer l'article en question (celui dans lequel vous voulez afficher un module)
                    Insérez le code à l'endroit où vous voulez afficher le module de Joomla
                    note : choisissez une position que vous n'avez pas dans votre template pour éviter les erreurs. Si vous ne savez pas laquelle choisir, vous avez deux solutions pour retrouver les positions présentes dans le fichier index.php, de votre template Joomla
                    allez dans menu Extensions - Gestion des Templates, sélectionnez en un et cliquer sur le bouton Prévisualiser
                    http://www.votre_site.tld/index.php?tp=1

                    Pour finir, allez dans le menu Extensions - Gestion des modules et publiez le module que vous voulez insérer dans un article, dans la position user9

                    note : si la position user9 n'existe pas dans votre template, il vous faudra de la rajouter manuellement.

                    Pour ce faire, ouvrez le fichier templateDetails.xml de votre template Joomla et insérez y le code suivant, entre les balises <positions> et </positions> ...

                    <positions>
                    <position>user9</position>
                    </positions>

                    ds l'article insérez la balise {loadposition user9}
                    et Voila ... c facile non

                    Commentaire


                    • #11
                      Re : Loadmodule dans un article ne fonctionne pas ...

                      Bonjour,
                      note : choisissez une position que vous n'avez pas dans votre template pour éviter les erreurs. Si vous ne savez pas laquelle choisir, vous avez deux solutions pour retrouver les positions présentes dans le fichier index.php, de votre template Joomla
                      allez dans menu Extensions - Gestion des Templates, sélectionnez en un et cliquer sur le bouton Prévisualiser
                      http://www.votre_site.tld/index.php?tp=1
                      Mouais... déjà en 1.6 il faudra s'assurer au préalable dans les paramètres des templates que l'aperçu est activé. Ensuite en utilisant des noms comme MaPositionFictivePourLeModuleMachin il y a assez peu de risque pour tomber sur une position existante.

                      note : si la position user9 n'existe pas dans votre template, il vous faudra de la rajouter manuellement.
                      Pour ce faire, ouvrez le fichier templateDetails.xml de votre template Joomla et insérez y le code suivant, entre les balises <positions> et </positions> ...
                      <positions>
                      <position>user9</position>
                      </positions>
                      Pas besoin. Il suffit de saisir directement le nom voulu dans le paramètre position du module, sans afficher la liste des positions.
                      Dernière édition par Grand Schtroumpf à 18/08/2011, 16h29
                      Schtroumpfe toi le Schtroumpf t'aidera.
                      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                      Commentaire


                      • #12
                        Re : Loadmodule dans un article ne fonctionne pas ...

                        sujet déplacé forum Joomla! 1.6/1.7 Questions générales ---> Gestion des Modules
                        sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                        http://virtuemart.fr

                        Commentaire


                        • #13
                          Re : Loadmodule dans un article ne fonctionne pas ...

                          Envoyé par Grand Schtroumpf Voir le message
                          Aaaahhhh,
                          j'étais passé à coté :
                          leplugin s'appelle loadmodule, mais le code c'est {loadposition maposition}
                          Merci grand Schtroumpf.
                          J'ai cherché pendant un moment.

                          Joomlamitié
                          akalbs
                          Si tu veux marcher vite, marche seul
                          Si tu veux marcher loin, marche avec les autres

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X