Installation de sourcerer

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Installation de sourcerer

    Bonjour,

    Je souhaiterais installer sourcerer dans Joomla mais je ne connais pas la procédure.
    Quelqu'un pourrait-il m'aider ?
    Merci beaucoup,

  • #2
    Re : Installation de sourcerer

    http://kiwik.net/joomla/3/trucs-et-a...-une-extension
    Christophe
    http://www.webcrea.fr

    Commentaire


    • #3
      Re : Installation de sourcerer

      Merci beaucoup j'ai donc suivi la procédure seulement l'installation ne s'effectue pas correctement j'ai ce message Fatal error : Call to une fonction membre getQuery () sur un non-objet dans /home/gcsms/www/administrator/C:/wamp/www/crcom3s/tmp/install_541ab1063a559/helper.php en ligne 161

      Commentaire


      • #4
        Re : Installation de sourcerer

        Bonjour,

        ton url me semble bien bizarre !
        /home/gcsms/www/administrator/C:/wamp/www/crcom3s/tmp/install_541ab1063a559/helper.php
        tu as installé un site local, OK, pas de soucis, j'ai aussi installé sourcerer et je l'ai aussi installé d'abord en local, mais visiblement là, ça ne se passe pas bien.

        Peux tu vérifier et t'assurer que les chemins de tes répertoires temporaires et logs sont correctement renseignés et positionnés?
        Quelles version locale de wampserver as tu utilisé ?

        As tu déjà installé autre chose sur ce site local ? comment cela s'est il passé ?
        Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

        Commentaire


        • #5
          Re : Installation de sourcerer

          Bonjour,

          Effectivement je suis d'accord avec toi, l'URL me paraît également bizarre.
          J'ai essayé de l'installer depuis un dossier (par FTP), j'ai décompressé le dossier puis via WinSCP je l'ai transféré sur mon serveur chez OVH dans le répertoire tmp. Puis dans la gestion de l'extension, j'ai fait installer depuis un dossier (chemin : crcom3s\www\tmp\sourcerer-v4.4.4) et là j'obtiens encore une erreur "veuillez saisir un répertoire de pack". Je ne comprends vraiment pas.

          Je n'ai fait aucune installation en local tout se trouve sur le serveur d'OVH. Sur mon disque local j'ai installé WampServer afin d'utiliser l'outil Wordpress pour tout autre chose. Cela n'a rien à voir avec le site actuel.

          Je te remercie d'avance pour ton aide.

          Commentaire


          • #6
            Re : Installation de sourcerer

            et pourtant ton installation OVH fait référence à : C:/wamp/www/crcom3s/tmp/install_541ab1063a559/helper.php

            ce qui semble bien pointer sur ton poste local non ?

            Reprenons tranquillement, et confirme moi :
            1) ton site est installé chez OVH et fonctionne normalement
            2) tu as déjà installé d'autres extensions ou plugins sur ce site (ou template pareil)
            3) as tu essayé d'installer sourcerer en appliquant la méthode suivante :
            - laisser le zip sur ton PC
            - en mode administration utiliser extension > Gestion des extensions onglet Archive A Envoyer et depuis el bouton Parcourir aller chercher l'archive sur ton PC

            Cordialement
            Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

            Commentaire


            • #7
              Re : Installation de sourcerer

              Je pense que je ne devais pas spécifier le bon chemin, il me semble l'avoir trouvé seulement j'ai encore une erreur, la voici : Fatal error : Call to une fonction membre getQuery () sur un non-objet dans /home/gcsms/www/tmp/sourcerer-v4.4.4/helper.php en ligne 161

              Pouvez-vous l'aider ?

              Commentaire


              • #8
                Re : Installation de sourcerer

                Bonjour,

                1) ton site est installé chez OVH et fonctionne normalement
                Oui, il est installé chez OVH et il fonctionne correctement

                2) tu as déjà installé d'autres extensions ou plugins sur ce site (ou template pareil)
                Non jamais

                3) as tu essayé d'installer sourcerer en appliquant la méthode suivante :
                - laisser le zip sur ton PC
                - en mode administration utiliser extension > Gestion des extensions onglet Archive A Envoyer et depuis el bouton Parcourir aller chercher l'archive sur ton PC
                Oui j'ai essayé avec la méthode suivante et c'est là où j'obtiens le message suivant Fatal error : Call to une fonction membre getQuery () sur un non-objet dans /home/gcsms/www/administrator/C:/wamp/www/crcom3s/tmp/install_541be23cb60ec/helper.php en ligne 161

                Merci par avance
                Cordialement

                Commentaire


                • #9
                  Re : Installation de sourcerer

                  As tu vérifié les chemins des répertoires Tmp et Log comme je te l'avais demandé ?

                  Quelle version exacte de Joomla as tu ? et la version PHP utilisée par ton site chez OVH ?

                  La ligne 161 du helper.php de sourcerer (V4.4.4) dit ceci :
                  $query = $this->db->getQuery(true)
                  ->update('#__extensions')
                  ->set($this->db->quoteName('enabled') . ' = 1')
                  ->where($this->db->quoteName('element') . ' = ' . $this->db->quote('qlue404'));
                  Ce qui aurai tendance à montrer que soit tu passes un pointeur $this invalide, soit ta base de données ne répond pas (correctement) aux sollicitations qui lui sont faites.

                  NB : dans cette partie du code, sourcerer essaie de rétablir une fonction qu'il a détournée lors d'un appel précédent. Appel qui semble n'être effectué que lorsque Joomla n'est pas dans une version 3x et / ou que QLUE Custom 404 est installé
                  Dernière édition par PieceOfCake à 19/09/2014, 11h55
                  Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                  Commentaire


                  • #10
                    Re : Installation de sourcerer

                    Bonsoir,
                    Je te remercie pour ces éléments mais j'ai trouvé une solution à mon problème, j'ai en fait installé l'éditeur JCE et cela a fonctionné correctement.
                    Encore merci à tous

                    Commentaire


                    • #11
                      Re : Installation de sourcerer

                      Si tu es satisfaite de la situation, merci de clôturer le sujet

                      Cordialement
                      Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X