Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

    Bonjour,

    Il semble que le cryptage en MD5 ne fonctionne plus avec la mise à jour d'un utilisateur par l'interface Utilisateur de Joomla (j'utilise la version 2.5.18).

    Si je modifie la colonne password de la table users avec un crpytage md5, j'arrive à me connecter à Joomla sans difficulté avec le mot de passe en clair.

    Si quelqu'un a une idée de mon problème ?
    Merci
    Laurent

  • #2
    Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

    Bonjour, je pense avoir le même problème.
    Depuis la mise a jour joomla 2.5.18 tout les nouveaux utilisateurs ne peuvent pas se connecter en créant un compte ( ca donne une soit disant erreur de mot de passe) .
    Quand je vais dans phpmyadmin et que je regarde la table user je vois que les anciens utilisateur ont de smot de passe crypter style :
    84a49b3bef95c ( ils peuvent se connecter )
    et les nouveaux ont des mots de passe style
    $P$DqO ( eux ne peuvent pas se connecter )
    Apres plusieurs recherche il me semble que cela vient de PhPass introduit dans la mise a jour.
    Ce qui est bizarre c'est que ca ne semble pas toucher tout le monde. J'ai 3 sites en production et la meme erreur sur les trois pourtant a part l'hebergeur 1&1 je n'ai pas du tout les même modules ou extension.
    J'ai testé plusieurs version de mysql 5.4, 5.5 mais ca ne change rien. Si quelqu'un à une idée ou un piste cdt.

    Commentaire


    • #3
      Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

      Envoyé par chikiro Voir le message
      Bonjour, je pense avoir le même problème.
      Depuis la mise a jour joomla 2.5.18 tout les nouveaux utilisateurs ne peuvent pas se connecter en créant un compte ( ca donne une soit disant erreur de mot de passe) .
      Quand je vais dans phpmyadmin et que je regarde la table user je vois que les anciens utilisateur ont de smot de passe crypter style :
      84a49b3bef95c ( ils peuvent se connecter )
      et les nouveaux ont des mots de passe style
      $P$DqO ( eux ne peuvent pas se connecter )
      Apres plusieurs recherche il me semble que cela vient de PhPass introduit dans la mise a jour.
      Ce qui est bizarre c'est que ca ne semble pas toucher tout le monde. J'ai 3 sites en production et la meme erreur sur les trois pourtant a part l'hebergeur 1&1 je n'ai pas du tout les même modules ou extension.
      J'ai testé plusieurs version de mysql 5.4, 5.5 mais ca ne change rien. Si quelqu'un à une idée ou un piste cdt.
      Bonjour,

      Oui, c'est exactement le même problème !
      J'ai changé un mot de passe en utilisant l'interface standart avec code de vérification envoyé par email et dans la base de donnée, je vois un mot de passe du style $P$DU/Y4jtw1ZOFJU1SgHxUibkfgTLZb/.
      Tous les anciens mot de passe sont plutôt du style 054f85121f8bec67569b231cb330 ou 9a9fb959fcaf87121b7eb2afd8d75498:QnYR0HNY4i58nKkXu YF9DVmeJMT7 .. du vrai MD5 je pense...

      Le problème est que l'utilisateur ne peut plus se connecter même en changeant son mot de passe, idem si l'administrateur passe par son interface.
      J'ai l'impression que ceux qui ne changent pas leur mot de passe n'ont pas de soucis mais que le problème vient que pour les nouveaux que l'on modifie.
      La solution de dépannage est de coder soi-même le mot de passe en MD5 directement dans la colonne password
      Le problème est survenu lors d'une montée de version Joomla mais je ne sais pas laquelle ..
      Ci dessous des infos systèmes : le site est aussi herbergé chez 1&1.


      PHP exécuté sur Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
      Version de la base de données 5.1.73-log
      Interclassement de la base de données utf8_general_ci
      Version de PHP 5.4.26
      Serveur web Apache
      Serveur web pour interface PHP cgi-fcgi
      Version de Joomla Joomla! 2.5.18 Stable [ Ember ] 6-February-2014 16:00 GMT
      Version de la plateforme Joomla! Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
      Navigateur Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0

      Commentaire


      • #4
        Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

        et avec la version 2.5.19 ca donnes quoi?
        Mon site en cours de construction avec de nouvelles catégories de documents...
        https://informaticien51.fr

        Commentaire


        • #5
          Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

          Même constat

          Commentaire


          • #6
            Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

            Envoyé par chikiro Voir le message
            Même constat
            Oui, je viens de faire la mise à jour vers la version 2.5.19 et j'ai la même erreur

            Quand j'enregistre "idadherent" dans le mot de passe de l'utilisateur par l'interface Administrateur, je trouve
            $P$D0tRztiE.TJpKbLVyYVhD5TF2J1Ns9. dans la base de données.

            L'utilisateur est donc incapable de se loguer !

            Qui peut avoir la solution ?
            Ce peut il que la base Mysql change "automatiquement" le mot de passe aprés la mise à jour de la zone par Joomla ?
            Dernière édition par Deliquintessence à 28/03/2014, 07h37

            Commentaire


            • #7
              Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

              bon, j ai verifié en local et en distant, j ai aucun soucis de ce type.

              Ta base est bien une base mysql et non mysqli...

              Second point a tu tésté avec un autre navigateur?

              Ce serait plus une erreur d encodage du mdp qu une erreur joomla lui meme......
              Mon site en cours de construction avec de nouvelles catégories de documents...
              https://informaticien51.fr

              Commentaire


              • #8
                Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                Envoyé par lefabdu51 Voir le message
                bon, j ai verifié en local et en distant, j ai aucun soucis de ce type.

                Ta base est bien une base mysql et non mysqli...

                Second point a tu tésté avec un autre navigateur?

                Ce serait plus une erreur d encodage du mdp qu une erreur joomla lui meme......
                Pour le navigateur, je n'y croyais pas trop mais j'ai testé qd même en testant avec IE11 : rien de changé qu'avec mon FF version 27 : le mot de passe est transcodé soit par Joomla, soit la base elle-même...

                C'est bien une BD MYSQL :
                Version du logiciel: 5.1.73-log - MySQL Community Server (GPL)
                Version du protocole: 10
                Jeu de caractères du serveur: UTF-8 Unicode (utf8)


                C'est peut être l'interclassement de la colonne de cette DB de 1&1 qui a changé ?

                Commentaire


                • #9
                  Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                  Re bonjour,

                  Il y a tous les jours maintenant des remontées de problème de ce type. Il y en a aussi pas mal sur forum.joomla.org et a priori pas de solutions, à part celle que j'ai proposé et qui a semble t il marché dans le post : http://forum.joomla.fr/showthread.ph...ferrerid=81188

                  Mais cette solution n'est qu'un pis aller et elle ne fonctionne pas pour tout le monde, FloAriege n'arrive pas elle à se connecter même comme ça.
                  Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                  Commentaire


                  • #10
                    Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                    Envoyé par PieceOfCake Voir le message
                    Re bonjour,

                    Il y a tous les jours maintenant des remontées de problème de ce type. Il y en a aussi pas mal sur forum.joomla.org et a priori pas de solutions, à part celle que j'ai proposé et qui a semble t il marché dans le post : http://forum.joomla.fr/showthread.ph...ferrerid=81188

                    Mais cette solution n'est qu'un pis aller et elle ne fonctionne pas pour tout le monde, FloAriege n'arrive pas elle à se connecter même comme ça.
                    Merci pour les nouvelles ! : effectivement je ne suis pas le seul et je vais attendre que tout se décante ..
                    Apparemment, il n'y pas que la version 3.2 de Joomla qui est concernée et je ne vois pas de notion de mot de passe "fort" dans ma version 2.5.19

                    Commentaire


                    • #11
                      Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                      La dernière piste nécessite de jeter un œil sur le PHPInfo de ton site, tu peux ?

                      il faudrait vérifier si l'extension 'crypt' pour PHP ets bien installé (éventuellement demander à ton hébergeur). Cette extension est utilisée par PHPAss (qui est quand même assez récent)

                      Tu nous tiens au courant ?
                      Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                      Commentaire


                      • #12
                        Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                        Envoyé par PieceOfCake Voir le message
                        La dernière piste nécessite de jeter un œil sur le PHPInfo de ton site, tu peux ?

                        il faudrait vérifier si l'extension 'crypt' pour PHP ets bien installé (éventuellement demander à ton hébergeur). Cette extension est utilisée par PHPAss (qui est quand même assez récent)

                        Tu nous tiens au courant ?
                        Bonjour,

                        Mon site est sur PHP Version 5.4.26 chez 1&1.
                        Voici les informations de la rubrique Crypt du PhpInfo :
                        mcrypt
                        mcrypt support enabled
                        mcrypt_filter support enabled
                        Version 2.5.8
                        Api No 20021217
                        Supported ciphers cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
                        Supported modes cbc cfb ctr ecb ncfb nofb ofb stream

                        Directive Local Value Master Value
                        mcrypt.algorithms_dir no value no value
                        mcrypt.modes_dir no value no value

                        Commentaire


                        • #13
                          Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                          idem

                          mcrypt
                          mcrypt support enabled
                          mcrypt_filter support enabled
                          Version 2.5.8
                          Api No 20021217
                          Supported ciphers cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
                          Supported modes cbc cfb ctr ecb ncfb nofb ofb stream

                          Directive Local Value Master Value
                          mcrypt.algorithms_dir no value no value
                          mcrypt.modes_dir no value no value

                          Commentaire


                          • #14
                            Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                            Pour essayer d'avancer faudrait savoir si quelqu’un héberger chez 1&1 a fait une mise a jour et a essayé de créer un nouveau utilisateur pour voir si c vraiment lié à 1&1 ou pas

                            Commentaire


                            • #15
                              Re : Cryptage MD5 d'un utilisateur de Joomla ne fonctionne plus ?

                              Envoyé par chikiro Voir le message
                              Pour essayer d'avancer faudrait savoir si quelqu’un héberger chez 1&1 a fait une mise a jour et a essayé de créer un nouveau utilisateur pour voir si c vraiment lié à 1&1 ou pas
                              Ce serait déjà un point effectivement, voir même créer un site neuf depuis une installation Joomla vide (en 3.2.3 ou en 2.5.19, ou les deux encore mieux). PHPAss s'appuie sur le module Apache crypt, et ce que tu retournes semble suffisant
                              Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X