Pb d'URL sur la page d'accueil avec SH404SEF

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Pb d'URL sur la page d'accueil avec SH404SEF

    Bonjour,

    J'ai toujours trouvé des solutions sur ce forum - merci à vous - mais pour la 1ère fois, je dois faire appel à la communauté !

    Voilà mon problème :
    Quand j'active l'optimisation des url avec SH404SEF (dernière version) :
    - l'url monsite.fr ne pointe plus sur la home page composée d'un article + quelques custom html mais directement vers l'article lui-même,
    - tandis que la home page devient accessible via l'url monsite.fr/fr/
    C'est d'ailleurs SH404SEF qui ajoute ce lien sur le bouton "Accueil" du menu de navigation principal.

    J'ai activé le mod-rewrite (pour supprimer les index.php dans les url) avec le .htaccess, qui est celui fourni par joomla avec simplement l'ajout d'une ligne pour préciser la version de php. dès que je désactive l'optimisation des url via joomla tout rentre dans l'ordre.

    Quelqu'un a-t-il déjà rencontré ce problème ?

    Merci par avance pour vos réponses.
    Dernière édition par toffffe à 18/12/2012, 16h16

  • #2
    Re : Pb d'URL sur la page d'accueil avec SH404SEF

    essaie de rajouter la langue "french"dans gestion des langues/contenu
    http://www.creaweb40.com/ - Creation de sites internet dans les Landes

    Commentaire


    • #3
      Re : Pb d'URL sur la page d'accueil avec SH404SEF

      Salut
      En fait tu as un site en plusieurs langue
      ou le multilingue est paramétré
      il faut dans ce cas aller dans la configuration de sh404sef/langue/ Activer support multi-langues : Oui et désactiver le plugin "filtre de langue" de joomla
      Formation Joomla agence internet https://www.stylitek.com
      Melijoy création de site Joomla compétitif https://www.melijoy.fr
      agence web spécialiste référencement http://www.agence-web-stylitek.fr

      Commentaire


      • #4
        Re : Pb d'URL sur la page d'accueil avec SH404SEF

        Merci beaucoup pour vos réponses VENT40 et Toffffe,

        J'avais déjà vu sur le forum des réponses à ce sujet. Le site n'est pas censé être multilingue, par contre, c'est vrai qu'un camarade a installé un pack de traduction pour la partie admin, c'est peut-être l'origine du problème :
        - Le filtre langue est désactivé.
        - dans la gestion des langues, figurent :
        > Installée(s)- site :
        English
        French (défaut)

        > Installée(s) - Administration :
        English
        French (défaut)

        > Contenu
        English (activé)

        Qu'en pensez-vous ?

        J'oubliais : je n'ai vu nul part ou activer le support multi-langues dans SH404SEF !
        Dernière édition par Miju60 à 18/12/2012, 13h31

        Commentaire


        • #5
          Re : Pb d'URL sur la page d'accueil avec SH404SEF

          J'oubliais : je n'ai vu nul part ou activer le support multi-langues dans SH404SEF !
          dans sh404sef tu as dans la configuration un onglet "langue" et tu as du mettre les réglages sur "oui"
          Par contre avec sh404sef quand tu fais un changement il faut souvent vider les anciennes url
          (pas si facile la bête )
          Formation Joomla agence internet https://www.stylitek.com
          Melijoy création de site Joomla compétitif https://www.melijoy.fr
          agence web spécialiste référencement http://www.agence-web-stylitek.fr

          Commentaire


          • #6
            Re : Pb d'URL sur la page d'accueil avec SH404SEF

            Merci Toffffe, j'ai trouvé l'onglet langue. Par contre aucun changement que je passe sur oui ou non... tout en pensant bien à purger SH404SEf et mon navigateur.
            Au cas voilà une copie d'écran des réglages de l'onglet langue dans sh404sef :


            Y a-t-il quelque chose à changer selon toi ?

            Commentaire


            • #7
              Re : Pb d'URL sur la page d'accueil avec SH404SEF

              Etonnant
              As-tu bien pensé à faire une sauvegarde avec akeeba de ton site (fichier et bdd)
              Ensuite tu désactive le composant, tu supprime toutes les url avec duplication, les 404, ...
              tu rafraichis ton site et tu réactive sh404sef
              Formation Joomla agence internet https://www.stylitek.com
              Melijoy création de site Joomla compétitif https://www.melijoy.fr
              agence web spécialiste référencement http://www.agence-web-stylitek.fr

              Commentaire


              • #8
                Re : Pb d'URL sur la page d'accueil avec SH404SEF

                as tu essayé d'installé la langue french ds gestion des langues/contenu?
                http://www.creaweb40.com/ - Creation de sites internet dans les Landes

                Commentaire


                • #9
                  Re : Pb d'URL sur la page d'accueil avec SH404SEF

                  Merci pour ta patience Toffffe.
                  Bon j'ai désisntallé sh404sef, vider la bdd url custo par sh404 et réinstallé :
                  Pas de changement...
                  J'ai donc désinstallé et purger la bdd une seconde fois et j'ai cette fois réinstallé la version 3.4 de sh404sef que j'avais gardé suite à un projet précédent. Et bien le problème disparait partiellement :
                  - la page d'accueil s'affiche bien,
                  - mais il continue toujours à m'ajouter le /fr/ sur le bouton accueil.

                  Ce qui est étonnant c'est qu'après chaque désisntall / reinstall, malgré la purge de la bdd, le composant est directement paramétré sur mes réglages précédent, ce qui n'est pas le cas en général lors de la 1ere install...

                  Y aurait t-il autre à purger dans Joomla et que je ne connais pas ?
                  Je vais finir par tenter une désinstallation de la langue également.

                  Commentaire


                  • #10
                    Re : Pb d'URL sur la page d'accueil avec SH404SEF

                    Envoyé par VENT40 Voir le message
                    as tu essayé d'installé la langue french ds gestion des langues/contenu?
                    Non en effet, je ne l'ai pas fait. Je vais tester.

                    Commentaire


                    • #11
                      Re : Pb d'URL sur la page d'accueil avec SH404SEF

                      Je vais tenter l'installation de la langue dans le content, mais avant cela voilà le résultat de mes dernières manip : j'ai rétabli la langue anglaise par défaut pour le site et le pb disparait complétement... alors bien sur j'ai un <html lang="en-gb" dir="ltr"> à la place d'un FR-fr, mais c'est un moindre mal.
                      je tente l'install de la langue dans le content et de réactiver le francais par défaut pour le site et vous tiens au courant.

                      Commentaire


                      • #12
                        Re : Pb d'URL sur la page d'accueil avec SH404SEF

                        Envoyé par VENT40 Voir le message
                        as tu essayé d'installé la langue french ds gestion des langues/contenu?
                        VENT40, je ne vois absolument pas comment installer la langue pour le contenu ?? une idée ?

                        Commentaire


                        • #13
                          Re : Pb d'URL sur la page d'accueil avec SH404SEF

                          tu fais "nouveau" puis tu rentres les infos!
                          tu peux regarder comment c'est fait ds "english"
                          http://www.creaweb40.com/ - Creation de sites internet dans les Landes

                          Commentaire


                          • #14
                            Re : Pb d'URL sur la page d'accueil avec SH404SEF

                            J'avais trouvé entre temps... c'était tellement évident que je ne pigeais pas.
                            Mais l'important c'est que ça marche parfaitement !

                            Merci à vous deux pour vos réponses et votre patience !

                            La morale de cette histoire :
                            - éviter de développer un site à partir d'un template avec des données exemples, c'est laid.
                            - installer le pack de langues sur un joomla sans données exemples

                            et après tout le reste se passera bien.

                            Merci encre une fois.

                            Commentaire


                            • #15
                              Re : Pb d'URL sur la page d'accueil avec SH404SEF

                              Je viens de me rendre compte que j'ai publié le sujet dans les anciennes versions de joomla alors qu'il s'agit bien d'un site tout neuf sur Joomla 2.5.8. Si vous voulez déplacer le sujet dans la bonne rubrique n'hésitez pas, si ça peut servir la communauté...

                              Merci !

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X