Mauvaise Mise en Page en Multi-Colonne pour les menu 'Category Blog' ou 'Featured'

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Mauvaise Mise en Page en Multi-Colonne pour les menu 'Category Blog' ou 'Featured'

    Bonsoir à tous !

    Tout nouveau dans l'univers Joomla! (en fait depuis la version 2.5 beta 1), j'ai patiemment attendu la sortie de la version stable pour pouvoir faire une installation propre sur un serveur.

    Après avoir sécuriser le site en utilisant la documentation de joomla.org, je viens de me lancer dans la création du contenu et des articles.

    Si la création des articles et leur présentation en 'category list' se passe sans problèmes, il s'avère que l'affichage sous forme de Blog est catastrophique.

    En effet, dès que je souhaite utiliser 2 ou 3 colonnes pour organiser l’enchaînement des articles d'introduction, ces derniers se superposent et ne respecte pas du tout la grille en ligne et en colonne.

    Ce que je ne comprend pas, c'est que sur la version locale (en Beta 1) avec laquelle je me suis fait la main avant de faire le grand saut, je n'avais pas se problème là. L'affichage était correct.

    J'ai donc chercher à comparer les deux version avec Firebug et voilà les résultats:
    • Pour un affichage correct cela donne :

    Code:
    <div class="blog-featured">
    
         <div class="items-row cols-3 row-0">
              <div class="item column-1">
              <div class="item column-2">
              <div class="item column-3">
              <span class="row-separator"></span>
         </div>
    
         <div class="items-row cols-3 row-1">
              <div class="item column-1">
              <div class="item column-2">
              <span class="row-separator"></span>
         </div>
    
    </div>
    • Pour le site en ligne on a plutôt cela :

    Code:
    <div class="blog-featured">
         <div class="items-row cols-3 row-0">
              <div class="item column-1">
              <div class="items-row cols-3 row-1">
                   <div class="item column-1">
                   <h2>
                   <ul class="actions">
                   <div class="img-intro-left">
                   <div>
                   <div>
                   <div>
                   <div>
                   <div>
                   <div class="item column-2">
                             <h2>
                             <ul class="actions">
                             <div class="img-intro-left">
                             <div>
                             <div>
                             <div>
                             <div>
                             <div>
                             <div class="item column-3">
                             <div class="items-row cols-3 row-2">
                                       <div class="item column-1">
                                      <h2>
                                      <ul class="actions">
                                      <div class="img-intro-left">
                                      <div>
                                      <div>
                                      <div>
                                      <div>
                                      <div>
                                      <span class="row-separator"></span>
                             </div>
                  </div>
              </div>
    </div>
    • Ce que j'ai compris (enfin je crois) :

    Pour avoir un affichage correct, la structure du fichier HTML doit être celle-ci : Un bloc par ligne (row), contenant les trois colonnes, puis un autre bloc de ligne contenant ces colonnes et ainsi de suite.
    Visiblement, l'HTML généré sur mon site, n’attends pas d'avoir fini le bloc de la première ligne avant d’attaquer la suivante. D'où cette affichage en cascade.
    • Ce que j'ai essayé de faire (sans succès)

    Dans un premier temps, j'ai donc soupçonner un fichier php buggé ou corrompu. J'ai donc essayé de changer le fichier 'blog.php' dans //components/com_content/views/category/tmpl en utilisant celui que j'avais en locale. Puis j'ai essayé de changer tous les fichiers contenu dans //.../com_content/, toujours sans succès.

    Dans un second temps, j'ai donc penser à un problème de template (Beez en l’occurrence). J'ai donc utiliser d'autres templates (y compris celui que j'ai utiliser en locale) mais le problème persiste.
    • Et là je sèche.

    Avant d'avoir à me lancer dans une nouvelle installation (je peux encore me le permettre vu que le site est tout juste au début), je serai heureux de pouvoir mettre en oeuvre vos conseils !

    Parce que le plus important c'est de comprendre...

    Merci d'avance !!
    Dernière édition par zaXoular à 23/02/2012, 11h13
    http://www.luckylucy.org/
    Joomla! 2.5.1 - In Motion Hosting - Shared Server
    OS (linux x86_64) - Apache (2.2.21) - PHP (5.2.17) - MySQL (5.1.56-log)

    Parce que le plus important c'est de comprendre !

  • #2
    Re : Mauvaise Mise en Page en Multi-Colonne pour les menu 'Category Blog' ou 'Feature

    Bonjour à tous !

    Après de nombreuses tentatives pour essayer de résoudre ce problème au niveau des fichiers systèmes de Joomla!, je suis finalement repassé par la case départ. J'ai donc procédé à une réinstallation complète de Joomla 2.5 sur mon serveur.

    Toutefois, par acquis de conscience, j'ai essayé de repartir sur mon ancienne base de donnée, et le problème a persisté. Mais quand j'ai créer une nouvelle Base de Donnée, mon problème d'affichage à été résolu.

    J'en conclus que c'était la base de donnée qui était corrompue et non pas les fichiers d'installation de Joomla!

    Pourquoi ? Comment ? Mystère, mais si quelqu'un à un début d'explication, je reste preneur !

    Un grand merci à tous ceux qui ont pris le temps de lire ce long post !
    http://www.luckylucy.org/
    Joomla! 2.5.1 - In Motion Hosting - Shared Server
    OS (linux x86_64) - Apache (2.2.21) - PHP (5.2.17) - MySQL (5.1.56-log)

    Parce que le plus important c'est de comprendre !

    Commentaire

    Annonce

    Réduire
    1 sur 2 < >

    C'est [Réglé] et on n'en parle plus ?

    A quoi ça sert ?
    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
    Comment ajouter la mention [Réglé] à votre discussion ?
    1 - Aller sur votre discussion et éditer votre premier message :


    2 - Cliquer sur la liste déroulante Préfixe.

    3 - Choisir le préfixe [Réglé].


    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

    2 sur 2 < >

    Assistance au forum - Outil de publication d'infos de votre site

    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

    UTILISER À VOS PROPRES RISQUES :
    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

    Problèmes connus :
    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

    Installation :

    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

    Archive zip : https://github.com/AFUJ/FPA/zipball/master

    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
    et remplacer www. votresite .com par votre nom de domaine


    Exemples:
    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
    Télécharger le script fpa-fr.php dans: /public_html/
    Pour executer le script: http://www..com/fpa-fr.php

    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
    Télécharger le script fpa-fr.php dans: /public_html/cms/
    Pour executer le script: http://www..com/cms/fpa-fr.php

    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
    Voir plus
    Voir moins
    Travaille ...
    X