pourquoi IE n'affiche-t-il pas (presque) mon site?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] pourquoi IE n'affiche-t-il pas (presque) mon site?

    Bonjour,
    sur ce site www.encorebeta5.regiscoque.com je découvre qu'IE8 n'affiche pas mon header, et IE9 n'affiche simplement que le slideshow et pas mon contenu.... quelqu'un a une idée d'ou ca peut venir en sachant que ff et chrome ne posent aucun soucis?

  • #2
    Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

    PS: plus de détails: IE9 64bits ne pose pas de problème...
    mais IE9 32bits lui n'affiche quasi rien de ma page....

    Commentaire


    • #3
      Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

      Envoyé par bagou01 Voir le message
      quelqu'un a une idée d'ou ca peut venir
      La réponse est dans ta question; deuxième mot.

      Bon, je sors.
      Christophe (cavo789)
      Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
      Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
      Mes logiciels OpenSource : https://www.avonture.be

      Commentaire


      • #4
        Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

        :-p je sais, moi aussi j'aimerais éradiquer IE de la planète, mais en attendant, il est là, et je dois trouver pourquoi il refuse d'afficher mon header :-/

        Commentaire


        • #5
          Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

          Pour info, chez moi sous IE9 Vista 32 bits, le site semble affiché tout à fait correctement.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

            Envoyé par bagou01 Voir le message
            :-p je sais, moi aussi j'aimerais éradiquer IE de la planète, mais en attendant, il est là, et je dois trouver pourquoi il refuse d'afficher mon header :-/
            Si une majorité de webmasters arrêtaient d'écrire des patchs, bricoles, hacks, ... pour que l'Immonde Explorateur puisse compter jusqu'à deux sans erreur; IE n'y survivrait pas

            Pour en revenir à ta question : j'ai deux écrans, sur l'un j'ai ouvert ton site avec FF 12 et sur l'autre IE9 (sous W7 64bits) et je ne vois pas de différences sur ta page d'accueil. Si je bascule IE9 en mode IE8, j'ai une différence : ton petit logo avec ton raton laveur est manquant. Le slideshow est bien présent et fonctionnel.

            Je te suggère donc d'utiliser IE9, de basculer en mode IE8 (appuie sur la touche F12 pour cela) et ensuite, utilise l'inspecteur de CSS afin de déterminer quelle est la règle CSS qui est mal interprêtée et qui empêche l'affichage du bandeau.

            Bonne soirée.
            Christophe (cavo789)
            Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
            Mes logiciels OpenSource : https://www.avonture.be

            Commentaire


            • #7
              Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

              ok merci beaucoup, je vais faire, ça,
              par contre je dois aussi comprendre pourquoi sur ma machine de tests IE9 ne fonctionnait pas en 32 bits :-/
              merci du conseil en tout cas ! si je trouve, je viens en dire plus

              Commentaire


              • #8
                Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                Bonjour,

                Par curiosité, j'ai monté une VM Windows 7 en 32 bits, une en 64 bits, une XP 32 bits...

                Et effectivement, sur ces VM, la XP 32 bits SP2 avec IE9 fonctionne, mais plus avec le SP3...

                La VM 7 32 bits, idem, ça fonctionne sans le SP, mais plus après.

                Les mystères des upgrades de Microsoft...
                Pas de demande de support par MP.
                S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                Commentaire


                • #9
                  Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                  le tout est de trouver pourquoi :-s

                  Commentaire


                  • #10
                    Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                    Là, la réponse est simple, dans le bric à brac des mises à niveau Microsoft..
                    Quand tu patches pour une version, c'est lautre qui ne fonctionne plus...
                    Pas de demande de support par MP.
                    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                    Commentaire


                    • #11
                      Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                      non, la question est de trouver ce qui dans mon site fait planter :-p

                      Commentaire


                      • #12
                        Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                        Dans tonsite, ce qui fait planter une version de IE ne fait pas planter une autre.. et inversement, si tu modifies un truc, le SP2 marchera, mais plus le SP1...

                        La seule solution serait de fabriquer des patches pour toutes es versions de IE (dépendant du 32 ou 64 bits) et capables de récupérer le build ou le SP...)
                        Genre mission impossible (sauf à éviter sur le site les éléments problématiques avec IE)
                        Pas de demande de support par MP.
                        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                        Commentaire


                        • #13
                          Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                          oui mais bon,c'est qu'il y a une astuce quelquepart puisque ça n'arrive qu'avec mon site, les autres que j'ai fait n'ont pas ce problème (ptin j'espère en tout cas), donc je vais quand meme chercher ce qui fait planter dans mon site qui n'est pourtant pas non plus très compliqué...

                          Commentaire


                          • #14
                            Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                            Ben ne sois pas pessimiste, il y a des dizaines de milliers de sites qui ont un rendu écran différent suivant les versions et builds IE...

                            ça fait partie des "joies" de ce navigateur.
                            Pas de demande de support par MP.
                            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                            Commentaire


                            • #15
                              Re : pourquoi IE n'affiche-t-il pas (presque) mon site?

                              Envoyé par jisse03 Voir le message
                              ça fait partie des "joies" de ce navigateur.
                              Si tant de monde le déteste (et j'en suis), ce n'est pas sans fondement. Le nombre de fois que je me suis pris la tête dessus alors même que FF et Chrome étaient OK, ... Le dernier truc qui m'a fait râler abondamment : IE ne sait pas charger plus de 32 fichiers CSS or, parfois, tu dépasses ce nombre (un template avec beaucoup de css, plusieurs modules, l'un ou l'autre plug-ins et le composant). Et pour sûr, IE n'informe pas l'utilisateur : tu arrives sur ton site et oh? l'un ou l'autre CSS a sauté. Tu cherches et cherches et cherches et ... râle car seul IE contient cette limitation digne du DOS 5.0. Et point de salut si ce n'est de fusionner plusieurs CSS en un seul.

                              C'est une des joies de IE.
                              Christophe (cavo789)
                              Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                              Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                              Mes logiciels OpenSource : https://www.avonture.be

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X