Joomladay francophone 2018 à Paris 18 et 19 mai

Template s'affiche mal

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Template s'affiche mal

    Bonjour,

    Je viens d'installer Joomla (v3.4.8) en local sur un wamp serveur(v2.5) et je n'arrive pas a utiliser de Template.
    Pour m'expliquer, j'ai réussi a installer le Template en le téléchargeant en zip et en le chargeant aussi en zip.
    L'installation ce passe bien mais lorsque j'essaie de prévisualiser j'ai des erreurs de partout du genre
    "Style: none outline".
    Et évidemment lorsque je met le Template par défaut les éléments en "none outline" ne sont pas présent ce qui fait qu'il ne reste presque rien sur le site.

    j'ai télécharger 3 ou 4 Template qui sont "normalement" d'après le site ou je les ai téléchargé (joomland) compatible avec joomla 3.X mais lorsque je suis dans "panneau de configuration ==> Extensions ==> Template" je vois que les versions des Templates par défauts sont de 3.quelques chose mais que celle que j'ai téléchargé sont de 1.quelques chose.

    Donc mes questions dans l'ordre sont :

    - Mes Template sont-elles à la bonne version ?
    - Comment puis-je régler mon problème avec ces Template ?
    - Et si possible, des liens de bons site de Template gratuit et libre de droit pour joomla 3.x ?

    Merci à ceux qui ont lu jusqu'au bout.
    Dernière édition par paboulinc à 01/03/2016, 09h17

  • #2
    Re : Template s'affiche mal

    Bienvenue !

    N'as-tu pas d'erreur lors de l'installation de ces templates ? S'il n'y en a pas, tu devrais retrouver les templates dans les onglets styles et templates de l'administration. Essaie éventuellement de passer par la fonction "découvrir" dans la gestion des extensions, pour voir si ça corrige le problème.
    Quelle est la version de PHP de ton serveur Wamp ?
    Tu peux trouver des templates gratuits (attention, certains ne le sont que pour usage privé) sur joomlaos.de.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Re : Template s'affiche mal

      Merci pour ta réponse, je pense que t'es sur la bonne piste car je n'ai aucun Template de découvert.
      J'ai essayé de supprimer un des Template et de le ré-installer en passant pas l'archive et j'ai eu les messages :

      "Alerte
      Installation d'un gabarit : gabarit déjà installé

      Erreur
      Template : erreur à l'installation"

      Messages surement dû à une mauvaise suppression.
      Mais du coup je comprend pas pourquoi je n'ai pas de Template découvert, je vais chercher de mon coté mais si quelqu'un à la réponse, qu'il ne se gène pas.

      Commentaire


      • #4
        Re : Template s'affiche mal

        Si tu n'as aucune découverte de template, ça veut dire que les templates installés ont bien été pris en compte dans la base de données, la question restant de savoir pourquoi ils n'apparaissent pas dans la gestion des styles et des templates.
        Le message d'erreur correspond au fait que le fichier XML servant à l'installation n'a pas de paramètre permettant la mise à jour : il faut désinstaller la précédente version pour réinstaller (ce qui se fait dans la gestion des extensions->Gérer)
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Re : Template s'affiche mal

          Oui je viens de trouver la réponse en ce qui concerne la désinstallation propre et j'ai réinstaller mon Template sans aucun problème.
          Par contre je crois que tu as mal compris mon problème, le Template est présent dans gestion des styles et des Template mais lorsque je prévisualise j'obtiens ceci :
          et lorsque je met le Template par défaut tout les éléments avec "style : none outline" n'apparaissent pas.
          Et j'ai ce problème pour tous les Template testés jusque la.

          Commentaire


          • #6
            Re : Template s'affiche mal

            Effectivement, j'avais mal compris.
            On ne peut pas voir la pièce jointe, passe en mode avancé pour l'insérer.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Re : Template s'affiche mal

              http://www.hostingpics.net/viewer.ph...510Capture.png

              Voila un lien ça sera plus simple.

              Commentaire


              • #8
                Re : Template s'affiche mal

                C'est normal, tu as en prévisualisation l'ensemble des positions du template, sur un site sans contenu.
                Pour voir le site lui-même sans ces noms de positions, va en haut et à droite de la page de l'administration (en bas à gauche également) et clique sur le nom du site.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Re : Template s'affiche mal

                  Mais un Template modifie l’apparence de mon site je devrais normalement quand même conserver mes menus, formulaires etc... non ?

                  Commentaire


                  • #10
                    Re : Template s'affiche mal

                    Oui et non : tous les templates n'ont pas les mêmes noms de positions pour les modules, ce qui veut dire que si tu as un menu en "position-7" sur un template et que tu changes pour un autre qui ne possède pas ce nom de position, ton module ne sera pas affiché.
                    Seule la partie "contenu" correspondant aux composants dont celui affichant les articles sera toujours visible, sauf si le template utilise par défaut le masquage de cette partie sur la page d'accueil et nécessite de changer le paramètre dans la configuration du style.
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Re : Template s'affiche mal

                      Au final quand j'active ce template il n'y que le header et le footer qui restent, moi je pensais qu'en général les templates s'adaptaient aux codes afin de modifier surtout l'apparence. Tu as des conseils si jamais je voulais adapter un template quelconques au contenu qui marchait avec template de base ? Sachant que pour l'instant j'ai juste rajouté un menu pour tester.

                      Commentaire


                      • #12
                        Re : Template s'affiche mal

                        Il faut regarder deux choses dans ton template : la position du menu à mettre en "left" par exemple, au lieu de position-7 (probablement dans protostar), et dans le style du template, voir s'il n'y a pas un paramètre pour ne pas afficher le contenu (article par exemple) en page d'accueil.
                        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                        Commentaire


                        • #13
                          Re : Template s'affiche mal

                          Pour info, je viens d'installer et tester ce template sur un de mes sites de test, il ne masque pas mon contenu, et j'ai mis le menu en position topmenu.
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                          Commentaire


                          • #14
                            Re : Template s'affiche mal

                            Bonjour, j'ai essayé ce que tu m'as dis en mettant protostar par défaut et j'ai essayé directement sur le site en me connectant dessus en super admin de modifier la position, sauf que je ne peux pas mettre "left" ou "topmenu", j’ai essayer de modifier sur le panneau admin dans le formulaire "type de menu" ou on peut modifier directement en écrivant et pas en sélectionnant dans un liste déroulante.

                            Mais rien ne marche ou alors je m'y suis mal pris

                            Commentaire


                            • #15
                              Re : Template s'affiche mal

                              J'ai l'impression que tu confnds des choses différentes : les positions "left" ou "topmenu" sont à affecter au module qui est chargé d'afficher ton menu principal.
                              Si tu ne l'as pas encore fait, consulte Joomla! 3 Le Livre pour tous sur hhtp://cinnk.com
                              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X