administration inaccessible(page blanche) sous joomla 2.5

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • administration inaccessible(page blanche) sous joomla 2.5

    depuis un mois la console d'administration de notre site est inaccessible. la page reste désesperement blanche. Par contre le site lui s'affiche sans problème. Au secours???,

  • #2
    Bonjour,

    Comment peut-on vous aider avec aussi peu d'info !

    Pour voir une éventuelle erreur, passez en mode debug développement
    ou en FTP, modifiez la ligne $error_reporting du fichier configuration.php pour quelle soit comme ceci :
    Code:
    public $error_reporting = 'development';
    Essayez de rapatrier une sauvegarde pas trop ancienne pour la réinstaller en local. Ce sera aussi l'occasion de passer à la dernière version de Joomla! en 2.5, plus grand monde pourra vous aider et vous aller au-devant d'une catastrophe.
    Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
    ---
    UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
    bgMax
    , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

    Commentaire


    • #3
      Merci Iomart pour votre diligence a ma reponse.
      j'ai essayer la manip (changement de la ligne
      public $error_reporting toujours le meme résultat. En faite le frontend fonctionne sans problème. Si j'ajoute /administrator a la suite de l'adresse du site j'ai une page toute blanche et puis plus rien. Voila, esperant vous avoir donné des details. Merci d'avance.

      Commentaire


      • #4
        Envoyé par rakim Voir le message
        Merci Iomart pour votre diligence a ma reponse.
        j'ai essayer la manip (changement de la ligne
        public $error_reporting toujours le meme résultat. En faite le frontend fonctionne sans problème. Si j'ajoute /administrator a la suite de l'adresse du site j'ai une page toute blanche et puis plus rien. Voila, esperant vous avoir donné des details. Merci d'avance.
        Tu as certainement fait une erreur, vérifie bien que tu as bien saisi

        public $error_reporting = 'development';

        à la place de

        public $error_reporting = 'none';

        Sinon regarde aussi le html généré (clic droit dans le navigateur -> code source).
        Il peut arriver que le message d'erreur php soit planqué dans une balise et non affiché (ou affiché en blanc sur fond blanc).
        Dernière édition par roland_d_alsace à 21/04/2018, 19h52
        A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
        Rejoignez le Joomla Users Groupe Alsace...
        roland_d_alsace va-t-il devenir roland_du_grand_est ?

        Commentaire


        • #5
          Bonsoir.

          Ce que Lomart (et d'autres) attend, c'est des informations du style: depuis quand est ce en panne. Après l'installation d'une extension ? Après une mise à jour (moins probable vu la version). Ce type de panne ne survient pas sans que quelque chose n'ait été changé.
          Cordialement.
          __
          Eddy !!!
          Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

          Commentaire


          • #6
            Envoyé par Eddy.vh Voir le message
            Bonsoir.

            Ce que Lomart (et d'autres) attend, c'est des informations du style: depuis quand est ce en panne. Après l'installation d'une extension ? Après une mise à jour (moins probable vu la version). Ce type de panne ne survient pas sans que quelque chose n'ait été changé.
            +1
            et aussi : hébergeur, URL du site
            Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
            ---
            UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
            bgMax
            , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

            Commentaire


            • #7
              En faite il n'y a eu aucune opération technique sur le site. ca fonctionnait bien depuis 2013. Aucune mise a jour n'a été faite depuis.
              je precise que c'est la version 2.5 de joomla. Attend toujours une solution, merci d'avance
              cordialement

              Commentaire


              • #8
                Les sites n'arrêtent pas de fonctionner d'eux-mêmes, donc forcément quelque chose à changé. Si ce n'est pas vous, c'est peut-être votre hébergeur (changement de version de PHP), encore qu'en principe vous avez dû être prévenu. Si ce n'est pas lui, c'est peut-être une personne mal intentionnée. Le fait que le front-end fonctionne toujours n'est pas une garantie que le site n'a pas été piraté.
                Comme demandé plus haut, êtes-vous sûr d'avoir fait la modification de la ligne "$error_reporting" ? Attention, normalement le fichier configuration.php est protégé en écriture pour éviter justement les modifications en dehors de Joomla!, donc AVANT de le modifier, vous devez changer ses permissions de '444' à '644', puis faire la modification.
                Donc il est possible que votre modification n'a pas été prise en compte.
                Enfin, une URL serait aussi utile pour éventuellement vous donner d'autres pistes.
                Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
                Administrateur certifié Joomla! 3
                https://www.betterweb.fr/services

                Commentaire


                • #9
                  Merci bien jfque, je precise que j'ai pas eu besoin de changer les autorisations pour modifier le fichier configuration.php. je vais reverifier tout de meme. Merci encore

                  Commentaire


                  • #10
                    rebonsoir jfque
                    voici le lien du site

                    Commentaire


                    • #11
                      bonsoir jfque
                      il faut ajouter /n/administrator pour voir
                      merci encore

                      Commentaire


                      • #12
                        Bonsoir,
                        ce n'est pas une "page blanche" mais une erreur 500 (une erreur serveur)
                        il faut aller fouiller les logs d'erreur de votre hébergeur pour y découvrir les premières pistes
                        Ce qui est sûr, c'est que d'être resté en version 2.5.11 est suicidaire
                        Quand on utilise un cms quel qu'il soit, il faut rester informé des mises a jour de celui ci et appliquer ces mises a jour ...
                        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
                        Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                        Commentaire


                        • #13
                          Bonsoir

                          Envoyé par rakim Voir le message
                          ca fonctionnait bien depuis 2013. Aucune mise a jour n'a été faite depuis.
                          Prenez en considération de faire vos mises-à-jour à temps. Votre site aurait déjà été "à l'abandon" pendant 5 ans; c'est un réel problème en matière de sécurité.

                          Bonne soirée.

                          Christophe (cavo789)
                          Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                          Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                          Mes logiciels OpenSource : https://www.avonture.be

                          Commentaire


                          • #14
                            Je vous renvoie à la dernière réponse que j'ai apporté ici : https://forum.joomla.fr/forum/joomla...http-error-500
                            Peut être envisager de passer le site dans sa dernière version de Joomla, en faisant une installation à neuf, ce qui, pour la sécurité de l'outil, est certainement nécessaire.

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X