Joomladay francophone 2022 à Bruxelles, les 20 et 21 mai 2022

Lien lire la suite => Erreur 404

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Lien lire la suite => Erreur 404

    J'ai un souci sur un site client. J'ai repris ce site et j'ai supprimé l'affichage des num. de catégories et d'articles dans les urls.

    Je ne sais pas si c'est lié à cela, mais tous les articles avec lien "lire la suite" amènent sur une erreur 404 quand on clique sur le lien, mais seulement sur certains articles.

    Exemple, colonne de droite (qui est en fait un affichage en module "Flash d'information" qui charge les articles d'une catégorie : https://proenfance.ch/atouts

    Par contre, les liens "lire la suite" de la page d'accueil fonctionnent (https://proenfance.ch). Bref, j'y comprend rien et ne trouve pas le problème...
    Dernière édition par thefbi à 22/10/2021, 09h13
    “Un problème sans solution est un problème mal posé." - Albert Einstein
    "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

  • #2
    Bonjour,

    En testant les adresses de la colonne de droite et en les comparant avec le résultat de recherche, il apparaît que le terme "atout" supprimé de ces adresses d'articles du module fonctionnent.
    As-tu vérifié d'abord en désactivant toute réécriture ? Ensuite, n'aurais-tu pas un conflit d'alias de menu et d'alias de catégorie ?

    En complément, si je fais une recherche sur le terme "bénéfices", j'ai deux articles "Les bénéfices de l'accueil en résumé", dont l'un est celui de la colonne Flash qui donne une erreur 404 et un second qui lui aussi en provoque une.
    Ta suppression des ID dans les adresses est en effet très certainement la cause ou la conséquence de titres/alias identiques.
    Dernière édition par RobertG à 21/10/2021, 15h17
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      Hello,

      OK, donc effectivement en testant sans l'url rewrite ça marche.
      Ensuite tu as raison, les articles sont à double, donc avec le même titre et alias.
      Il y a aussi des alias de menu et de catégories pareil...

      Bref, mais si je prend deux articles identiques et que je change l'alias, ça devrait marcher non ? Car en le faisant, ça ne change rien => 404.
      Est-ce que le fait d'avoir des catégories et menus avec les mêmes alias peut poser problème ?
      “Un problème sans solution est un problème mal posé." - Albert Einstein
      "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

      Commentaire


      • #4
        Salut,
        Envoyé par thefbi Voir le message
        Est-ce que le fait d'avoir des catégories et menus avec les mêmes alias peut poser problème ?
        Si cela pointe vers des contenus différents, oui, assurément, car le système ne saura pas vers lequel des deux contenus pointer, son choix sera donc arbitraire (probablement l'ID le plus ancien << à vérifier).
        S'il s'agit du même contenu, tu auras un problème de "duplicate content", quoique sur un même site/domaine c'est moins gênant, mais quand même un peu...

        A noter que Joomla permet de créer des liens de menu de type "alias" pour permettre de pointer vers un menu déjà existant mais avec un autre intitulé d'affichage, l'url utilisée tant celle du lien source.
        Je préfère éclairer que briller.” - “J'ai peut-être l'air froid, mais je suis pas givré.- "ça dépend ça dépasse"
        Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
        Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

        Commentaire


        • #5
          OK, merci,
          mais dans le cas de cette page par exemple : https://www.proenfance.ch/atouts
          Les articles de la partie principale sont chargé par le lien de menu "Atouts" qui affiche une catégorie (Atouts) en format blog.
          Les liens "lire la suite" fonctionnent.

          La colonne de droite et un module (flash) qui charge les articles d'une catégorie (Atouts-droite).
          Là, les liens "lire la suite" ne marchent pas.

          Désolé, mais j'y comprend plus rien. D'autant plus que certains articles sont en double, OK, mais pas tous. Et quand je fait une modification de l'alias de l'article en double, ça marche quand-même pas... Voir sur ce lien de recherche, mes deux premiers articles avaient des alias idem. J'ai ajouté -1 / -2 pour voir, => 404 quand-même.
          https://www.proenfance.ch/component/...all&Itemid=104

          Honnêtement, suis complètement perdu là...
          “Un problème sans solution est un problème mal posé." - Albert Einstein
          "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

          Commentaire


          • #6
            Si maintenant, le premier article de ma page "Atouts" (Les bénéfices de l'accueil en résumé" est lié à un lien de menu (menu test => article => mon article), lorsque je suis sur cette page Atouts, dans ma colonne de droite, le lien "lire la suite" prend le lien du menu (en l'occurence "Test") et il fonctionne.

            Donc il doit y avoir un problème avec ce module qui veut charger l'article lorsqu'il n'est pas lié à un lien de menu.
            “Un problème sans solution est un problème mal posé." - Albert Einstein
            "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

            Commentaire


            • #7
              Re, j'ai trouvé une solution !
              Si maintenant, je crée un menu fantome et que je fait un lien de menu par exemple "Atouts colonne droite" qui affiche la catégorie en question (Atouts-droite) en blog, mes problèmes de liens de modules sont résolus.
              “Un problème sans solution est un problème mal posé." - Albert Einstein
              "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

              Commentaire


              • #8
                Désolé, mais je n'arrive pas à reproduire le problème.
                J'ai testé un lien de menu qui pointe vers un blog de catégorie et dans la même page un module Flash d'information qui affiche les articles de cette même catégorie.
                Que ce soit en routage d'url mode "legacy" (avec ID) ou mode "moderne" (avec id masquée) mes liens lire la suite fonctionnent tous parfaitement.

                Du coup, je me demande quelle procédure tu as suivi pour supprimer les ID ?
                Et d'où viennent ces articles doublons ?
                Je préfère éclairer que briller.” - “J'ai peut-être l'air froid, mais je suis pas givré.- "ça dépend ça dépasse"
                Ne m'envoyez pas de message privé pour résoudre vos problèmes sans y avoir été invité.
                Dolmenhir : tailleur de site web depuis 1997. Spécialiste Joomla depuis 2005. https://www.dolmenhir.fr

                Commentaire


                • #9
                  Non, le module flash n'affiche pas les articles de la même catégorie que celle chargée par le menu. Et c'est à mon avis là qu'est le problème.
                  Pour la procédure, je suis en routage moderne et suppression des ids dans les paramètres intégrations
                  Dernière édition par thefbi à 22/10/2021, 08h32
                  “Un problème sans solution est un problème mal posé." - Albert Einstein
                  "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

                  Commentaire


                  • #10
                    Pour les doublons, c'est le client qui à fait des articles avec le même titre. Mais c'est un autre problème. Mon problème principal était ces affichages de lire la suite.
                    Tout est réglé en affectant ces catégories à des liens de menu.
                    Dernière édition par thefbi à 22/10/2021, 10h58
                    “Un problème sans solution est un problème mal posé." - Albert Einstein
                    "La sagesse, c’est d’avoir des rêves suffisamment grands pour ne pas les perdre de vue quand on les poursuit." - Oscar Wilde

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins

                    Partenaire de l'association

                    Réduire

                    Hébergeur Web PlanetHoster
                    Travaille ...
                    X