Perte du template sur un module

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Perte du template sur un module

    Bonjour à tous,

    comme le titre ne l'explique pas trop... je perd mon template lors de l'utilisation d'un module.
    Je tente une explication...

    J'utilise News Show Pro GK5 pour mes actus. J'ai créé un menu "Actualités" qui pointe vers "Blog des articles en vedette" et la catégorie d'articles "Actualités".
    Jusque là tout va bien mes actus se lancent correctement. Voir http://www.moselle-entreprendre.org/actualites

    Ensuite, je souhaite mettre un module en position-7 (juste en dessous du main menu) qui reprend la dernière actu.
    J'ai donc créé un module News Show Pro GK5 appelé "derniere_actu" que je configure pour n'afficher que la dernière actu puis un autre module de contenu personnalisé dans lequel j'appelle la fonction {loadposition derniere_actu}. Position donnée au module précédent News Show Pro GK5 appelé "derniere_actu".

    On voit bien la dernière actu sur mon template à gauche en dessous du main menu.
    Le souci vient quand je clique sur cette dernière actu, je perd tout mon template, les modules autour et tout et tout... l'actu s'affiche bien mais sans respecter le template.

    Je ne sais pas si j'ai été assez clair, c'est pas évident à expliquer :/

    Merci en tout cas d'avance pour vos lumières.
    http://www.solucetech.fr
    http://www.facebook.com/solucetech

  • #2
    Re : Perte du template sur un module

    Que je clique à gauche ou au milieu sur une actu, le template est bien présent

    PS : Vire ce fond horrible on se croirait dans les années 2000, sur une page perso
    Christophe
    http://www.webcrea.fr

    Commentaire


    • #3
      Re : Perte du template sur un module

      Merci pour ta réponse webcrea.
      Le template est effectivement présent si on se situe d'abord dans le menu "Actualités". Mais si on est sur une autre page du site, par exemple "nous contacter" et qu'on clique sur la dernière actu à gauche on perd le template.

      PS: oui je sais que ça fait années 2000 lol mais on me force à garder ce fond j'ai encore quelques batailles à mener pour gagner lol
      http://www.solucetech.fr
      http://www.facebook.com/solucetech

      Commentaire


      • #4
        Re : Perte du template sur un module

        Bein pas chez moi, ça fonctionne...

        PS: Propose d'en faire un bandeau et/ou menace les d'être au top des sites https://www.branded3.com/blog/top-10-worst-websites/
        Christophe
        http://www.webcrea.fr

        Commentaire


        • #5
          Re : Perte du template sur un module

          C'est très bizarre...
          Peux-tu essayer de cliquer sur l'image de l'actu à gauche sous le main menu en partant de ce lien: http://www.moselle-entreprendre.org/mur

          J'essaye depuis 2 PC différents et c'est pareil, je vois bien l'actu dans une nouvelle page mais je perd mes modules "menu principal" et "connexion". En fait l'actu prend tout l'écran alors que normalement c'est divisé en 3 colones, gauche, milieu et droite.

          PS: oui pas bête l'idée du top 10
          http://www.solucetech.fr
          http://www.facebook.com/solucetech

          Commentaire


          • #6
            Re : Perte du template sur un module

            Bonjour,

            Vous n'avez pas les mêmes liens sur vos 2 pages:
            - celui qui fonctionne depuis la page actualités : http://www.moselle-entreprendre.org/...ites/14-actu-2
            - celui qui "foire", le mur : http://www.moselle-entreprendre.org/...ites/14-actu-2

            Pascal
            If anything can go wrong, it will...
            If I can help, I will ..https://conseilgouz.com

            Commentaire


            • #7
              Re : Perte du template sur un module

              Petites questions complémentaires: quelle version Joomla utilisez-vous ? êtes vous en mode Réécriture URL ? avez-vous mis non à réécriture au vol des URL, car je ne vois pas l'index.php ? quel type de serveur utilisez-vous ?

              Pascal
              If anything can go wrong, it will...
              If I can help, I will ..https://conseilgouz.com

              Commentaire


              • #8
                Re : Perte du template sur un module

                Envoyé par tchao57 Voir le message
                C'est très bizarre...
                Peux-tu essayer de cliquer sur l'image de l'actu à gauche sous le main menu en partant de ce lien: http://www.moselle-entreprendre.org/mur
                Là je vois effectivement que les modules ne montent pas parce qu'ils ne sont pas assignés pour ce lien comme le souligne Pascal, les 2 liens sont différents.

                Est-ce que c'est un menu en bas ou un html personnalisé ?

                Il faudrait ajouter le lien vers /mur dans une option de menu et assigner les modules à cette option.

                Si tu ne veux pas faire apparaître ce lien dans le menu, tu peux créer un menu caché
                Christophe
                http://www.webcrea.fr

                Commentaire


                • #9
                  Re : Perte du template sur un module

                  Bonjour pmleconte, merci.

                  oui en effet, l'un est dans un menu mais pas l'autre. J'avais bien remarqué cette subtilité, le souci c'est que je ne vois pas comment y remédier pour l'instant.
                  http://www.solucetech.fr
                  http://www.facebook.com/solucetech

                  Commentaire


                  • #10
                    Re : Perte du template sur un module

                    Envoyé par webcrea Voir le message
                    Là je vois effectivement que les modules ne montent pas parce qu'ils ne sont pas assignés pour ce lien comme le souligne Pascal, les 2 liens sont différents.

                    Est-ce que c'est un menu en bas ou un html personnalisé ?

                    Il faudrait ajouter le lien vers /mur dans une option de menu et assigner les modules à cette option.

                    Si tu ne veux pas faire apparaître ce lien dans le menu, tu peux créer un menu caché
                    Ok pour le menu caché, j'en ai déjà créé un mais je ne vois pas comment faire le lien avec le module de la dernière actu.
                    Je n'arrive plus réfléchir lol
                    http://www.solucetech.fr
                    http://www.facebook.com/solucetech

                    Commentaire


                    • #11
                      Re : Perte du template sur un module

                      Par exemple, à gauche ton menu principal est un module. donc si tu vas dedans tu peux l'assigner pour qu'il s'affiche sur ton option de menu "mur" en cochant la case... Tu comprends?
                      Christophe
                      http://www.webcrea.fr

                      Commentaire


                      • #12
                        Re : Perte du template sur un module

                        Ce qui est "bizarre", c'est que, dans votre module "dernière actualité", il y a un lien:
                        - soit avec le menu http://www.moselle-entreprendre.org/...ites/14-actu-2 et là, le lien fonctionne correctement (c'est la cas pour les menus actualités,nous contacter, nous rejoindre) ,
                        - soit le lien sans menu http://www.moselle-entreprendre.org/...ites/14-actu-2 (pour les menus Entrée, accueil et profil sociétés membres, par exemple), là, on perd le template ????

                        Pascal
                        If anything can go wrong, it will...
                        If I can help, I will ..https://conseilgouz.com

                        Commentaire


                        • #13
                          Re : Perte du template sur un module

                          Ignorez mon dernier commentaire, vous écrivez plus vite que moi
                          If anything can go wrong, it will...
                          If I can help, I will ..https://conseilgouz.com

                          Commentaire


                          • #14
                            Re : Perte du template sur un module

                            Envoyé par webcrea Voir le message
                            Par exemple, à gauche ton menu principal est un module. donc si tu vas dedans tu peux l'assigner pour qu'il s'affiche sur ton option de menu "mur" en cochant la case... Tu comprends?
                            Je pense comprendre oui mais là j'ai le cerveau qui coule depuis quelques jours lol...

                            'fin bon, dans mon module "menu principal" je vais dans l'option "assignation des menus" et je prend l'option "sur toutes les pages" donc il apparait bien sur toutes les pages du site.
                            Je fais pareil avec mon module "dernière actu" mais visiblement les autres modules n'apparaissent pas.

                            D'un autre côté, j'ai un template pour l'entrée du site et un autre pour le reste du site. Peut-être que le souci vient de là...
                            Je vais faire un test...
                            http://www.solucetech.fr
                            http://www.facebook.com/solucetech

                            Commentaire


                            • #15
                              Re : Perte du template sur un module

                              Bon j'ai trouvé, c'est bien le fait que j'utilise 2 template différents. Un pour l'entrée du site et un pour le reste.
                              Du coup, vu que lorsqu'on clic sur le module de gauche on tombe directement sur l'article on a le template de l'entrée du site, sans les modules autour.
                              Bon du coup, je ne pense pas qu'il y ait de solution viable, j'ai viré le module dernière actu...
                              http://www.solucetech.fr
                              http://www.facebook.com/solucetech

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X